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Part 1
STARTING YOUR WORK

This part of the User Guide will help you get started.  Product Registration, Technical Support
and Installation are covered here.

Part 1 includes:
• Introducing WebShop
• Installing WebShop
• Starting WebShop



Chapter 1.
Introducing WebShop

Overview of WebShop

Welcome to WebShop.  This is your gateway to designing Web pages, managing Web sites,
creating graphic objects, and much more.  This application opens the door to the Internet by
providing you with all of the tools that you need to create dynamic and exciting Web sites.
WebShop includes the new release of the award winning Internet Design Shop Gold.  In
addition it has significant enhancements and a number of pioneering new features not available
in the previous version of the Internet Design Shop Gold or other products.

WebShop is actually many applications in one.  It provides you with a rich assortment of tools
and utilities for graphic work.  All of these tools are easily accessible directly from within the
WebShop application window.  They give you an unparalleled ease of use to design even the
most complex graphic projects.

Topics covered in this chapter include:
• Product Registration
• Assistance In Using WebShop
• Technical Support
• User Guide Conventions

Product Registration

WebShop features a convenient online registration system that is activated the first time you
open it.  If your computer has a Modem, you can register using the automatic dial-up to
Boomerang Software, Inc.  This is a toll free call (in the US and Canada) that takes less than a
minute to complete.  If you do not have a modem or if you prefer to register by telephone, you
may call the number indicated in the online registration dialog box to register.

When you register your product you are eligible for notification of upgrades to WebShop as
well as information about WebShop related products.
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Assistance in Using WebShop

WebShop documentation includes:

••••• User Guide.  Provides an overview of the operation of the WebShop application.

••••• Quick Start Guide .  Provides a step by step overview of significant WebShop features.

••••• E-Commerce User Guide.  Provides an overview of the E-Commerce features of the
WebShop application.

••••• Graphic Editor PDF User Guide.  Provides a complete presentation of the Graphic Editor
module that comes with WebShop.

••••• Dynamic Page PDF User Guide.  Provides a step-by-step tutorial for creating the most
commone Dynamic Page applications.

••••• Online Help System .  For quick reference on a particular operation or feature in WebShop,
you may use the Help system.  You may access the Help files by selecting the Help >
Contents  menu options or by pressing F1.  The Online Help includes a subject index, word
index (in Windows 95, 98 & NT), and extensive cross-reference links to related subjects.
The Help file is ideal for finding specific detailed information.  You may use the search
feature, or the many Help buttons of WebShop application.

Technical Support

Before you call Technical Support, please check the Readme  file to see if it can answer your
question.  If you cannot solve your problem, contact Boomerang software technical support at
the following phone number, fax number, or mail address:
Tech Support (voice): 617.484.4664
Tech Support email: techsupport@boomerangsoftware.com
Tech Support (fax): 617.489.1486
Tech Support (mail): Boomerang Software, Inc.

ATTN: Tech Support
90 Concord Ave.
Belmont, MA 02478

When Contacting Tech Support by Phone

It is more effective if you follow these guidelines when contacting tech support by voice:
• Provide the following system information:

• The version number for WebShop.  To get the exact version number, choose the Help
> About  menu option in WebShop.

• The type of computer and the version of Windows that you are using.
• Record and provide the following problem related information:

• The exact sequence of events that created the problem.  Make sure that you can
reproduce the problem by following the same series of steps.

• The amount of free hard disk space on your drive and your PC’s RAM capacity.
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• Your currently installed browser name and version number (this is important for any
preview or browser-related problems).

• The text of any error messages that may appear with regard to the problem.
• Be at your computer with the computer turned on if you call on the voice line.

If you are having problems, do not return the program.  Most problems may be easily solved.
You may also check the www.boomerangsoftware.com Web site for posted Questions &
Answers.

Documentation Conventions

The following documentation conventions were applied when putting this User Guide together:
• Commands you are asked to type and specific content you are instructed to enter are

indicated in a sans-serif font, such as: CD\TEMP.  Ignore any punctuation included unless
specified otherwise.

• Keystrokes, or individual keys that you are asked to press or type are indicated with bold,
all capital text, such as: ALT , F1, TAB , ENTER.  Ignore any punctuation included unless
specified otherwise.

• When you are asked to select more than one menu option in sequence, the options are
separated by a greater-than sign (>).  The instruction “Select Frames > Advanced  >
Rename” asks you to complete these steps in sequence: 1.  select the Frames  menu; 2.
select the Advanced  option in the Frames menu; and 3.  select the Rename  option in the
Advanced menu.

• When you are asked to “select,” “click,” or “double-click” with the mouse, use the left
mouse button.  In some cases, you will be instructed to “right-click.” If you have reversed
the configuration of the mouse buttons in Windows, you should reverse the button instruc-
tions in this User Guide.

• When you are asked to “select” or “highlight” an object, item, or icon, click on it once.  In
some cases, the object selected will be surrounded by blue or the prevailing “active”
Windows system color.

Note:  Program operations can be launched by using one of these methods:
(1) Clicking on sequential menu option selection, as described above;  (2) Clicking on a
program button icon from a toolbar;  (3) Selecting an item or object, right-clicking and
selecting a program  option from a pop-up menu;  and (4) Pressing a single or combination
shortcut key.
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Using the Online Help System

WebShop 2000 comes with an Online Help System that you can use to answer some of your
questions about how to use specific feature.  To access the Online Help System, select Help >
Help Topics .  The WebShop Online Help  dialog box appears and the Table of Contents  is
displayed.

Online Help Window Options

The WebShop Online Help  dialog box has
several options that you can select using the
Online Help toolbar that appears directly below
the title bar.  These options include:

••••• Backward .  Returns the screen display to
the last topic.

••••• Forward .   Returns the screen display to
the next topic in sequence.  The button is
only active once the Backward button is used.

••••• Table of Contents .  Displays the Table of Contents.

••••• Bookmark .  Opens the Bookmark dialog box.  Use this dialog box to store bookmarks that
will take you to selected topics.  This listing is user-defined and is saved when you exit the
program.

••••• Search .  Opens the Search dialog box.  Use this dialog box to selectively search for
information on a topic.  This dialog box has two tabs, Index and Search .  Use the Index tab
to select a topic from the topic list.  Use the Search tab to search on a word or phrase.  The
program returns a list of topics that contain the specified word or phrase.  Click the topic
that you want to see and click Display .  For faster access, double-click on the topic.

••••• Related Topics .  Moves the cursor to the next available link in the topic being displayed.
Use this feature to quickly access additional topic links associated with a topic.

Using F1

By pressing F1, the WebShop Online Help  dialog box appears with the Table of Contents
displayed.  Use this “hotkey” to quickly access the Online Help System from any where in the
program.

Exiting Online Help

To exit online help, select View > HelpViewer .  This option operates as a toggle switch to turn
on and off the Online Help System.  You can also click Close window button in the upper-right
corner of the dialog box.

Figure 1.1 – Online Help Toolbar

forward search

backward
table of
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Chapter 2.
Installing WebShop

Introduction

This chapter provides instructions on installing WebShop and registering your software when
the installation is completed.  Based on the version of the program you have received, you may
selectively install or not install certain parts of the program to manage the amount of hard disk
space used up.

Topics covered in this chapter include:
• Installing WebShop
• Starting WebShop
• Online Registration

Installing WebShop

WebShop comes with an installation program to guide you though the installation process.

Before You Begin
Check the system requirements before installing the application.  While compliance with system
requirements enables you to run WebShop, using the system recommendations enables you to
more efficiently take advantage of the program’s features.

System Requirements
• A 100 MHZ processor (or better) computer with Windows 95,  98, or Windows NT 4.0 or

higher
• Approximately 50 MB (minimum) of hard disk space, with an additional 40 MB of free

hard drive space for “virtual memory” functions
• 32 MB of RAM
• A mouse (or similar pointing device)
• A printer and printer driver compatible with Windows 95, 98, 2000 and NT 4.0 or higher
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• A CD-ROM drive for installation
• SVGA monitor and graphics card or better

System Recommendations
• Personal computer with a 200 MHZ processor (or better)
• 64 MB of RAM
• 290 MB free hard disk space for all WebShop libraries with 80 MB minimum free hard

drive space for “virtual memory” functions.  These could be different based on the version
of WebShop you have received.

• SVGA video card set to True Color (24-bit) mode with a resolution of 800 x 600 or higher

Windows 95 / 98 / 2000 / NT Installation
It is recommended that you turn off any virus checking software that may be running in the
background during the installation.  Since the WebShop program set is provided on CD-ROM
and is thoroughly checked before the CD is made, the chances of getting a virus from the
installation are extremely small.  You can turn on all such programs after the installation is
done.

The WebShop installation uses an “auto-run” installation program for Windows 95 that should
start when you insert the CD-ROM in the drive.  If the installation program does not open
automatically when you close the CD-ROM drive door, use the manual installation procedure
described in the next section.

Manual Installation
To open the WebShop installation program manually, follow these steps:
1. With the CD-ROM in the CD drive, select Start > Run .  In the Run  dialog box, press

SPACEBAR  to clear any previous command line entry and select Browse .
2. In the Browse dialog box, select the Look in  drop-down menu.  From the list of available

hard drives, select the CD-ROM drive and select Open .  The Browse dialog box reappears.
3. Select the file Install.exe  and select Open .  The Run  dialog box reappears.  Select OK.

WebShop Welcome Screen
The installation program opens with a Welcome to WebShop title screen with installation menu
options.  Install each application simply by selecting the option in the title screen.  It is not
necessary to install all of the included applications to use WebShop.

You can always put the CD in the drive or start the installation and install one of the other
applications.  To install any application, simply click on it in the welcome screen.

Note:  The package that you received includes a large Clipart  collection with thousands of
files.  To conserve hard drive space, these files are not installed on your hard disk.  To use
an image from this collection, simply import from the CD directly into WebShop as needed.
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Running WebShop Installation Program
1. To begin installing WebShop select the Install WebShop option in the Welcome to

WebShop  screen.  The Welcome  dialog box is displayed.  Select Next to continue.
2. Read the software license agreement (use the scroll bar on the right to view the entire

agreement).  After reading and accepting the terms of the agreement, select Yes to proceed.
The User Information  dialog box appears.

3. Specify Name, Company, and Serial Number.  When done, click Next .  The Choose
Destination Location  dialog box appears.

4. The Choose Destination Location  dialog box indicates the default Destination Folder,
X:\Program Files\Boomerang Software\WebShop , where X: is the primary hard drive on
your system.  For most users, the primary hard drive is C:.  If the default folder does not
exist in your system, WebShop will create it for you.  This is the easiest method for most
users.  To change the default installation location, select Browse .  The Choose Folder
dialog box appears.

5. The default Path  can be deleted, enabling you to enter a different directory and folder
where you want to install WebShop.  If you have already created a target directory or folder
other than the default selection, use the Directories  section to browse to the new folder.
When you are satisfied with the destination location, click OK.  Your selection is repeated
in the Destination Folder section of the Choose Destination Location  dialog box.

6. Select Next  to continue.  The Select Components  dialog box appears, giving you the
opportunity to selectively omit certain WebShop options.  The Components  section
displays all available WebShop components, the total amount of available hard drive space
and the hard drive space required to install currently selected components.  By default all
components are installed.  The Description  section describes each component and contains
the Change  button, which allows you to open the component and choose among sub-
components.  Select Additional Libraries,  then select Change .

Note:  If you uncheck and remove all optional components, a minimum set of sampling of
the libraries will still be installed as part of the minimum installed system.  The program will
operate properly.  You will have access to a small number of library components such as
buttons, Clipart , and so forth

7. The Select Sub-components  dialog box appears, displaying the list of available sub-
components and the hard drive space required by each.  Select Clipart Libraries , then
select Change  again.  The Select Sub-Components  dialog box re-appears, displaying
another level of available sub-components, each accompanied by the amount of hard drive
space required to install that sub-component.

8. Full WebShop installation requires approximately 240 Mb.  The Space Required  option
shows the amount of hard disk space required to install the selected components.  Space
Available  indicates the amount of space available on the destination drive.  To avoid an
error message, Space Available  must be greater than Space Required .

9. Customize the installation of the WebShop optional items by using the Sub-components
dialog boxes for each listed component.  Specify the components you want and click Next .
The Select Program Folder  dialog box appears.

Note:  One of the sub-components that is installed with Gold 2000 is an BoomFTP program.
This is a utility program that you can use to upload selected files to your Web-server.
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10. The Select Program folder allows you to customize the Program Group folder for
WebShop.  The default program group folder is Boomerang Software.  You can accept the
default, enter a name for a new program group folder, or place WebShop in an existing
Program Group.  Select ,or accept the Program Group, then click Next .  The installation
begins and will finish without further instructions.

11. When the installation is complete, a dialog box prompts you to install Microsoft Internet
Explorer (IE) 5.0, this may not appear on OEM or certain versions of WebShop.  WebShop
uses IE version 4 or 5 to preview your Web pages and to display the online WebShop Help
files, so you must have either IE 4 or 5 installed on your computer to view them.  It is
recommended that you use IE 4.  IE 3 may not display all program features properly.
• If you do not have IE version 4 or 5 on your system, you should select Yes so that

WebShop can install IE 5 on your system.
• If you already have IE or Netscape, select No.  WebShop automatically finds either

version and uses it to display the online Help files.

Remember!  Version 4 or better is recommended.

12. When the installation is completed, the original Welcome to WebShop  screen appears.
You may install another application from the program CD.  If you want to run WebShop,
select Exit .  You are not required to install all the programs listed (if any) in the Welcome
Screen together at the same time.  You can always place the CD ROM in the drive (or start
the Welcome Screen) and from the Welcome Screen install whatever you like.

Starting WebShop
To launch WebShop
• Select Start > Programs > Boomerang Software > WebShop .

Note:  The actual name of the WebShop menu option may be different if you changed it
during the installation.

Online Registration
The first time you start WebShop, the Online Registration  dialog box appears.  The first dialog
box welcomes you and explains the registration process.   The second dialog box gives you
three choices for Online registration.

Note:  If your Windows system ever crashes or you have to reinstall WebShop, you may
need to reregister WebShop again.

To register by Internet
1. The first choice is Register by Internet,  which is the easiest way to register if you have a

browser installed in your system.  Select Next .  The Online Registration form appears.
2. Please fill out the registration form completely.  When the form is filled, select Next .  Your

Browser connects to the registration web site and completes the registration process in less
than a minute.  A confirmation message displays.
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4. Select Finish.  WebShop opens and displays the default Web site project screen display.

To register by Modem
1. The first choice is Register by Modem,  which is the easiest way to register if you have a

modem installed in your system.  The telephone call is made to a toll-free 800 number and
takes less than a minute to complete.  Select Next .

2. The Online Registration  dialog box appears and displays the list of available modems.
Use the Properties and Settings  buttons to make configuration changes, if necessary,
before dialing.  If you have recently used the Dial Up Networking function, you will
probably not need to make any configuration changes.  Select Next .  The Online Registra-
tion form appears.

3. Please fill out the registration form completely.  When the form is filled, select Next .  Your
modem connects to the toll-free number and completes the process in less than a minute.

4. Select Finish.  WebShop opens and displays the default Web site project screen display.

To register by Calling on the Telephone
1. If you choose not to use the automatic modem registration, or if you experience problems

with the online registration, you may call Boomerang Software office and register manu-
ally.  Be prepared to give the following information over the telephone: Name, Company
(if applicable), address, email address (if applicable), telephone, fax, and the dealer from
whom you purchased WebShop.  Hours of operation are Monday through Friday (exclud-
ing holidays), 9 AM to 5 PM EST.

2. When you call, state that you want to register your WebShop application.

Figure 2.1 – Online Registration  Dialog Box
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Introduction

Before beginning work with WebShop after installation, it is a good idea to set the application
preferences to your liking.

Topics covered in this chapter include:
• Setting User Preferences
• Common Procedures

Setting User Preferences

WebShop offers a number of preference settings that you can use to control various aspects of
the application.  While you may not wish to change these settings until you are more comfort-
able with the operation of the program, it is good to review the preference settings so that you
know what is available.  You can come back to the Preferences options and change them at any
time.

To launch WebShop
• Choose Start > Programs > Boomerang Software > WebShop .

Note:  The program group for WebShop may be different if you changed it during installation.

To access the Preference settings
• Choose File > Preferences .  The Preferences dialog box appears.

The Preferences dialog box includes a number of tabs that effect the operation of the application
in different areas.  These areas and the preference settings include:

General
••••• Undo/Redo .  This feature lets you set the levels (that is, the number of previous steps

which you can undo and redo in the application).  The number can be anything between 0
and 32,767.  The higher the number, the more virtual memory is required to store the
different levels.

••••• Startup .  You can have WebShop open with a blank page, the WebShop About  dialog
box, the Template selector (choose a template for a new project), or to the Open File  dialog
box.
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••••• Autosave .  The Autosave feature, when
turned on, enables the program to automati-
cally save your project every certain number
of minutes.

• Create Backup Files .  If you enable the
Create Backup Files feature, WebShop will
not overwrite existing files when you try to
save a file to an existing name.  If you try to
save a file to a file name that already exists,
WebShop will create a backup copy of the
existing file before it saves the current file.
To open a file from list, select File > File
Name.

••••• Recent File List .  The program can remem-
ber and display at the end of the File menu,
the names of the files you worked with most
recently.  Enter the number of file names
you want, most people use about 5 or 6.  To
open a file from the list of the main program
menu, select File > File Name .

Graphic Editor
••••• Ruler Units .  You can select inches, centi-

meters, millimeters, or pixels as the units of
measure in the work page.  Note: The Ruler feature works with Graphic Editor and with
Free Pages.  It does not apply to page types other than Free Pages.

••••• Workspace .  You can select the Sheet and Shadow options in the Workspace section.
When both options are turned on (that is, there is a checkmark in the box to the left of the
item), the work page in Graphic Editor displays as a rectangle with a gray drop shadow.
Click on the color sample box to the right of the options to select the color for the Sheet and
the Drop Shadow.

••••• Objects .  The Objects option lets you determine where new objects, such as graphics and
text, are inserted into the workspace in Graphic Editor.  You can elect to have all new
objects inserted in the center of the work page or in the center of the visible work area (if
you are zoomed in on a particular portion of the work page).

••••• Grid .  The Grid feature lets you select the frequency or the number of lines for the grid in a
given space.  The frequency selection measurement depends upon the units of measure
selected.  For example, if you select inches as the Ruler Units, you can select the grid based
upon the number of lines per inch.  Make sure the Ruler Units and Grid frequency you
choose are reasonable.  For example, 100 grids per inch is not reasonable and the program
will instead display the maximum number of grids possible.  The Grid feature works only if
you turn on the grids.  You can do this from the View menu of the main program.

Web Site
• Headers/Footers .  Check the check box to have the program automatically place the default

header and/or footer in a new page.  Headers and Footers are placed inside dotted bounding
boxes.

Figure 3.1 – Preferences Dialog Box
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••••• Physical Layout .  Check the check box if you want the program to display the list of all
files on your site i.e., HTML, images in the Site Manager’s left Physical window.

••••• Navigate Layout .  Here you can set the colors for pages and links that are viewed in the
Site Manager’s graphical Navigate Layout.  To change the color of a Selected Page,
Orphan Page, Internal and External Link select the color box to the right of each option.

Browsers
••••• Browsers .  The Browsers option lets you specify the default Internet browser to use when

you want to test view your Web pages.  You may add as many different Web browsers as
you wish.  If you are doing a good deal of Web design, you may want to install and use
several of the most popular browsers, including Microsoft Internet Explorer and Netscape
Navigator.  It is good to see how your pages will display in each.  If during the initial
program installation you install the default browser, the Browsers window lists an Internal
Browser.  It is recommended that you use Browser Version 4 or higher.

• Web-Promote .  This function lets you promote your site to the Internet community.  The
options include quick access to a number of Internet search engines and Web site promo-
tion services.  After you create your site and place it on the internet server or your ISP, you
should go to these sites to register your Web site with the search engines.  Many Internet
users depend solely on the search engines to find sites that are of interest to them.  If your
site is not registered with the major search engines, finding your site is more difficult.  You
can also add your own personal favorite sites to the Web-Promote list to provide you quick
access to those sites from within WebShop.  To add a new site to the list, enter a name and
the Web address in the Name and URL fields and click Add.  To remove one from the list,
click on it to select it and then click Delete.  To use this feature from the main program
screen, Select File > Web Promote  and select your choice.

Common Procedures
There are several common procedures you will to know to get started.

To start a new Web site
1. After launching the program, select the File > New  menu options, or click the New button

on the Main toolbar.  The New dialog box appears with the “Web Site” tab already se-
lected.

2. Click on the Library Name  drop-down arrow.  A list of libraries appears.
3. Select the template library that you wish to view.  The Library Preview area displays the

templates available.

Note:  Each template in a template library appears as a thumbnail graphic. The first template
in each library is a blank template.

4. Select the blank template and click OK.  The template is opened.  The Site Manager–
Physical Layout  window appears.

Note:  To open a template quickly, double-click on the preview graphic.

To add a page to a Web site
1. Click the Home Page  icon to select it and right-click.  A pop-up menu appears.
2. Select New.  The Add Logical Page  dialog box appears.  There are selection three tabs.
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3. Select the Create New Resource  tab and select the resource type you want to create.

Note:  By default, the Plain Page resource type is selected.  This is a plain HTML page
without frames (as with a FrameSet Page), without Free-Form Editing (as with a Free Page),
or without Dynamic elements (as with a Dynamic Page).

4. When done, click OK.  The physical resource associated with the new page is created.

Normally, you would use the Add Logical Page dialog box to add a new page.  However, you
can split any type of page into a FrameSet, and add Frames and Frame-Content Overlays.
Frames and Frame-Content Overlays are closely associated resources.  One frame can have
many Frame-Content Overlays.  The program lets you create navigation links between all the
Frame-Content Overlays used with a frame.  The program’s Frame Manager helps you create
and manage your frame resources.  Refer to the chapter titled “WebShop Frames” for more
details.

To add a new Home Page

1. Click anywhere in the blank space of the Logical Layout (not on a page icon).
2. Right-click and select New Home Page .
3. A new Home Page is added directly at the top of your site hierarchy.  The old Home Page

becomes its first level child.

To move a page to a different location

1. From Site Manager–Logical Layout , click the page that you want to move.
2. Right-click and select Delete .  The selected page disappears from Logical Layout.

Note:  When deleting pages from Logical Layout, only the Logical icon is deleted.  The Page
resource (physical file) is still available.

3. Click the Page icon that you want to be the new parent for the page you just removed from
Logical Layout.

4. Right-click and select New.  The Add Logical Page  dialog box appears.  There are
selection three tabs.

5. Select the Existing Resource  tab and select the resource page that was just deleted from
Logical Layout.

6. When done, click OK.  The new page is inserted using a page resource that was created
earlier.

To turn the automatic Header / Footer feature on or off

1. Select the File > Preferences  menu options.
2. Click the WebSite tab in the Preferences  dialog box.
3. Click the check box next to the Insert default Header/Footer automatically  option.
4. Click OK to make the change.

You can edit and create new headers and footers using the Page Editor feature in the Header/
Footer window.  When you make a change in either the header or the footer, that change is
reflected in all appropriate pages throughout the Web site.  If you have already generated the
site (that is, created the HTML and resource files in Web site format), you will have to regener-
ate it to have the pages with the new headers.



Part 2
BASIC FEATURES

This part of the User Guide examines some of the basic features of WebShop.  These features
will help you manage your Web site and create Web Pages that have the content and style that
you want.

Part 2 includes:
• WebShop Toolbars
• Site Manager
• Cascading Style Sheets
• Creating Web Pages
• Page Editor Features and Procedures
• Web Site Wizard



Chapter 4.
WebShop Toolbars

Introduction
WebShop comes with a variety of toolbars designed to make it easier to use the various program
features.  You may want to review these before reading the rest of this User Guide.

Topics covered in this chapter include:
• Accessing Toolbars
• Main Toolbar
• Physical Layout Toolbar
• Logical Layout Toolbar
• Navigate Layout Toolbar
• Common Objects Toolbar
• Styles Toolbar
• Frames and Page Editor Toolbar
• Free Page–New Object Toolbar
• Plain Page–Insert Object Toolbar
• Standard Toolbar
• Formatting Toolbar
• Form Fields Toolbar
• Dynamic Page Toolbar

Accessing Toolbars

All program features are accessible through the menus.  Most of the important and often used
features are also accessible through the buttons or icons of the toolbars.  The toolbar buttons or
icons have Quick Tips.  These one or two word descriptions are automatically displayed when
you place the mouse on a button and keep it there for a few seconds.  When you place the
mouse over icons, toolbars or parts of the program screen, a one-line help message also appears
in the bottom Help/Status line.
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Floating Toolbars
When you first start the program, toolbars are placed at the top of the program screen area by
default.  Most of the WebShop toolbars can be made to float or be relocated to different
positions in the Page Editor window.  A floating toolbar can be moved to any location for easier
access and convenience.  You can dock a floating toolbar by returning it to its default location
or to one of the toolbar locations at the top, bottom, right or left of a WebShop window.

To relocate (or undock) a toolbar, double-click in the toolbar area (not inside one of the toolbar
buttons).  The toolbar will be immediately undocked.  Place the mouse pointer on the toolbar
title bar and drag it to the position that you want.

Most toolbars can be repositioned–except the Main toolbar and the Frames and Page Editor
toolbar.  If you place it at the left or right sides of the screen, the program re-orients it vertically.
To turn on or off the display of a toolbar, select the View menu then select the toolbar you want.
When you exit the program, the program saves the toolbar locations and brings up the same
layout next time you start the program.

The program also displays Window toolbar at the bottom of the screen with window tabs.  This
toolbar is similar to the Windows program tabs that switch you from one program to another.
The window tabs are placed automatically and they correspond to the different windows that
you have opened.  These tabs include a Site Manager  tab to access Site Manager; any currently
open Web Pages  to access the associated Page Editor windows; any currently open Preview
Windows  to access the browser preview for a Web page, or any currently open Image Files  to
access the associated Graphic Editor window.  To shift between windows, simply click on tab.

Main Toolbar

The Main toolbar appears at the top of the WebShop window just below the Menu bar.  This is a
standard application toolbar and is not context specific.  It also cannot be moved.
• New.  Opens the New dialog box to start a new project design.

• Open .  Opens an existing file in WebShop.
• Save.  Saves the current file.
• Page Setup .  Allows you to change some of the image attributes when editing in graphic

editor window.
• Undo .  Undoes the last action in WebShop.  The Preferences dialog box enables you to set

the number of levels you may use for Undo.  If you have more than one level of undo set in

output type selector

new save page
setup

undo cut paste preferences help preview

open print redo copy generate
project

 window

Figure 4.1 – Main Toolbar
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the Preferences, you may step back through as many steps undoing each.  For example, if
you have the undo level set to 25, you can undo the last 25 steps that you completed in
WebShop.  The Undo feature is only functional with operations within WebShop.  For
example, you cannot undo a save operation.

• Redo .  Redoes the last undo in WebShop.  The Preferences dialog box enables you to set
the number of levels you may usee for Redo.  If you have more than one level of redo set in
the Preferences section, you may go forward through as many undo steps redoing each.
For example, if you have the redo level set to 25, you can redo the last 25 undo steps that
you completed in WebShop.  The Redo feature is only functional with operations within
WebShop.  For example, you cannot Redo a save operation.

• Cut .  Deletes the selected graphic or text object and places it in the Windows clipboard.
• Copy .  Copies the selected graphic or text object to the Windows clipboard.
• Paste .  Pastes or inserts a graphic, text or any other type of object from the windows

clipboard into the current document.
• Preferences .  Opens the Preferences dialog box and enables you to set user preferences.
• Show Project Window .  Displays the project window, where you can have as many Site

Manager windows as you like.  This comes very handy when you want to have different
Layouts open at the same time in different windows.

• Toggle Help Viewer Window .  Opens or closes the WebShop Help window.
• Generate Web Site .  Creates all of the necessary HTML and resource files necessary for a

Web site.
• Preview .  Opens the Internet browser with the active Web page and shows you what it

looks like in a browser.  All the other pages are also generated to enable you to test the
links.  Do not use this feature to view dynamic pages, as they need Internet Information
Server (IIS) running.

Physical Layout Toolbar

The Physical Layout toolbar appears when the Site Manager–Physical Layout  window is
active.  Use this to manage the physical resources of your site.
• New Folder .  Creates a new folder in the Site Manager–Physical Layout window of the

Web site.  The new folder is given a temporary name of “Folder” plus a number.  You can
enter a new name for the folder in the space provided.  The folder is created as a child of

new
folder
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page

new dynamic
page

import
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new
image

import
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small icons details

import
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Figure 4.2 – Physical Layout Toolbar
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the folder you have selected.  No selection means that the root folder is selected by default.
• New Frame Set .  Creates a new FrameSet in the Site Manager–Physical Layout window of

the Web site.  The FrameSet is created with one default frame without any frame-content
overlays.  To edit the FrameSet, double-click it.  You may split it as you like, and add
frame-content overlays.  You can later add it to the logical structure of your site.  The frame
is created inside the selected folder, or in the root folder if nothing is selected.

• New Page .  Creates a new page in the Site Manager–Physical Layout window of the Web
site.  You can edit and add it to the logical structure of your site.  The page is created and
placed in the selected folder or in the root folder if nothing is selected.

• New Free Page .  Creates a new Free page in the Site Manager–Physical Layout window of
the Web site.  You can drag, drop, align, overlap and move objects on a Free page as you
like.  You can edit this page and later add to the logical structure of your site.  The page is
created and placed in the selected folder, or in the root folder if nothing is selected.

• New Dynamic Page .  Creates a new dynamic page in the Site Manager–Physical Layout
window of the Web site.  You can edit and add it to the logical structure of your site.  The
page is created and placed in the selected folder or in the root folder if nothing is selected.
Do not confuse Dynamic HTML with dynamic pages.  They are unrelated.

• New Image .  Inserts a holder file for an image that you want to insert in a page.  After you
create the file, you can double-click it to open the WebShop Graphic Editor window.  Use
this feature to create JPEG, GIF (87a format), and transparent GIF (89a).  For ease of
reference, it is a good idea to place all of the images of your site in one central folder.  The
Site Manager – Physical Layout automatically creates the Images folder that you can use to
store graphics.  To place an image in the Images folder, click the Images folder then click
Create Image.

• Import Java .  Imports a Java class file from your hard disk.
• Import Multimedia .  Imports a audio, video, and animated GIF files from your hard disk.
• Import Shortcut .  Creates a shortcut to any file.  You can have a shortcut to image, text, or

any file without importing it into your site project.  This is very convenient when you want
to place content in your site, but the content is not ready yet.  You can modify the shortcut
file itself outside the program, without having to edit the whole site project file.  Every time
you generate the site the shortcut file is placed instead of its shortcut.  So you can always
have the last updated version of the file used.

• Import Custom .  Imports any file, which is generated without change.
• Import Data Base .  Imports a database from your hard drive.
• Rename .  Renames any folder or file in the Web site.  When you click Rename, the name

editor becomes active enabling you to enter a new name.  To exit the rename feature
without changing it, press the ESC key.

• Delete .  Removes the selected folder or file from the Web site.
• Properties .  Opens the Properties dialog box so that you can set the properties for the

selected resource. The tabs available in the Properties dialog box depend on the resource
selected.  You can select several common resources and view or update their properties at
once.  For example, select several GIF images and change their type to JPEG.  You do not
need to change the format for each, one-by-one.  Attributes you can change include:
HTML title, alias, headers and footers (HTML page resources), image properties – JPEG,
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GIF, colors (image resources); shortcut properties; database properties and others.
• Style .  Opens the Style dialog box to set the visual style settings, such as background,

banner and others.
• Large Icons .  Displays the items in the left side as large icons.
• Small Icons .  Displays the items in the left side files as small icons.
• List .  Displays the items in the left side as a list.
• Details .  Displays the items in the left side with details.

Logical Layout Toolbar

The Logical Layout toolbar appears when the Site Manager–Logical Layout  window is active.
Use the Logical Layout window to add, move, and
delete individual pages in your Web site.  It
displays an organization-type chart showing the
relationship of the pages to one another.  Use the
toolbar to manipulate the window display and each
of the logical resources associated with your site.
• New.  Adds a new page to the Web site.  The

Add Logical Page dialog box appears.  Use this
dialog box to add a new page beneath the page
currently selected.  If no page is selected, the
program adds the new page above the entire site structure as a Home Page.

• Delete .  Deletes a logical page from the Web site.
• Rename .  Renames a logical page in the site.
• Properties .  Opens the Properties dialog box.  You can set the properties for a page

including the title, alias, and any headers or footers.
• Style .  Opens the Style dialog box to set the visual style settings, such as background,

banner, and others.
• Zoom In .  Increases the magnification view of the Logical Layout window.
• Zoom Out .  Reverses Zoom In.  Displays more of the picture.
• Actual Size .  Returns the Logical Layout window display to normal.

Navigate Layout Toolbar

The Navigate Layout toolbar appears when the Site Manager–Navigate Layout  window is
active.  The Navigate Layout window displays all of the pages and resources of a Web site.
This view is useful for viewing the relationship of each page to other pages as well as to
external Web sites.  You can open any Web element or image for editing by double-clicking on
it.  This layout features two views: Spiral and Centered.  In the Spiral view, all of the selected
resources are displayed in a spiral fashion.  In the Centered view, the selected resource high-
lighted in the Spiral view item is placed in the center, and all the resources that contain links to
it are displayed.  You can selectively choose to include those resources that you want to see.
The Navigate Layout is designed to give you either a global view of all your Web site resources,

zoom in actual
size

delete properties

new rename style zoom out

Figure 4.3 – Logical Layout Toolbar
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or a selective view.  When in Horizontal view, linked items are displayed from top to bottom.
When in Vertical view, linked items are displayed left and right.  Use this toolbar to manage and
view the links between resources.
• Properties .  Opens the Properties dialog box for the selected resource.  Set the properties

for a page including the title, alias, and any headers or footers.
• Frame Sets .  Toggles the Frame Set Page display on and off.  When turned off, Frame Set

Pages do not display.
• Pages .  Toggles the Plain Page display on and off.  When turned off, Plain Pages do not

display.
• Free Pages .  Toggles the Free Page display on and off.  When turned off, Free Pages do

not display.
• Dynamic Pages .  Toggles the Dynamic Page display on and off.  When turned off,

Dynamic Pages do not display.
• Images .  Toggles the display of image resource files on and off.  When turned off, image

resource files do not display.
• Multimedia .  Toggles the display of multimedia resource files on and off.  When turned off,

multimedia resource files do not display.
• Java .  Toggles the display of Java resource files on and off.  When turned off, Java

resource files do not display.
• Custom .  Toggles the display of custom resource files on and off.  When turned off,

custom resource files do not display.
• External .  Toggles the display of external resources on and off.  When turned off, links to

external resources outside the Web site do not display.
• Incoming Links .  Toggles the display of incoming links on and off for the selected

resource.  When turned off, links coming into the selected page, frame, frame-content
overlay, or resource from an outside URL do not display.

• Outgoing Links .  Toggles the display of outgoing links on and off for the selected re-
source.  When turned off, links going from the selected page, frame, frame-content overlay,
or resource to an outside URL do not display.

• Show All Links .  Toggles the display to show all of the links in the site.
• Vertical Orientation .  Toggles the display of icons in the detail window.  When turned on,

links and icons appear vertically.
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Figure 4.4 – Navigate Layout Toolbar
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• Horizontal Orientation .  Toggles the display of icons in the detail window.  When turned
on, links and icons appear horizontally.

• Zoom In .  Increases the magnification view of the Site Manager–Navigate Layout window.
• Zoom Out .  Decreases the magnification view of the Site Manager–Navigate Layout

window.
• Actual Size .  Returns the Site Manager–Navigate Layout window display to normal.

Common Objects Toolbar

The Common Objects toolbar appears when the Site Manager–Common Objects  window is
active.  Use this toolbar to enter any number of headers and footers that you want.  Once they
are created, you may then assign any one of them to a page.  This eliminates the tedious work of
having to complete repetitive tasks for inserting standard information or graphics on pages.  Use
this toolbar to manipulate the window display and to insert, delete, or rename the common
objects.
• Create Object .  Creates a new header or

footer.
• Delete Object .  Deletes an existing header or

footer.
• Rename Object .  Renames a header or

footer.
• Edit Object .  Opens the header or footer edit

window for editing.
• Set As Default .  Sets the selected header or

footer as the default in a Web site.
• Large Icons .  Displays the objects in the active window as large icons.
• Small Icons .  Displays the objects in the active window as small icons.
• List .  Displays the objects in the active window as a list.

Styles Toolbar

The Styles toolbar appears when the Site Manager–Styles
window is active.  Use this toolbar to manages the window
display and to insert Site Styles from a Style Library.
• Insert Style .  Inserts a new default style in the Site Styles

list.  You can redesign the new style as you want and use it
in your project.

• Large Icons .  Displays the style names in folder view.
• Small Icons .  Displays the style names in a list format with

scroll bars if needed.
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Figure 4.5 – Common Objects Toolbar
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• List .  Displays the style names in a list format without scroll bars but arranges them in
different columns.

Frames and Page Editor Toolbar

The Frames and Page Editor toolbar appears when you open a page resource in Page Editor.
This toolbar appears at the top of the Page Editor window and is a fixed part of the window
design.  It cannot be moved.

To activate the Frame Manager, click the Frame Manger  toggle button.  Use this toolbar to
manage the window display and to assign Frame-Content Overlays to your Web pages.  Refer to
the chapter titled “WebShop Frames” for more details.

• Frame Manager .  Toggles to the Frame Manager window.
• Delete .  Deletes the selected items from the Frame Manager window.  When the Frame

Manager is closed or hidden, it deletes the active or currently visible frame-content overlay.
• Add New Frame-Content Overlay .  Creates a new frame-content overlay for the frame.
• Frame-Content Overlay Pull Down .  Selects the frame-content overlay for the page or a

particular frame.
• Split Vertical .  Splits the active frame into two vertical frames.
• Split Horizontal .  Splits the active frame into two horizontal frames.
• Page Properties .  Displays the Properties dialog box.

Free Page–New Object Toolbar

The New Object toolbar appears when you open a Free Page in Page Editor or when working
with Free Page objects.  Use a Free Page when you want to place graphic or text objects
anywhere on the page.  This is the more versatile page style where you are not limited by the
text line limitation of the simple plain Web
page.  If you want to be artistic, place
objects on the page, and drag them, even
use snap to grid options and transparent
overlaps, then use this type of a page.  Use
this toolbar to insert a variety of graphic
objects.
• Free-Form .  Inserts a blank free page

Figure 4.7 – Frames and Page Editor Toolbar
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Figure 4.8 – New Object Toolbar
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object.
• Text Box .  Inserts a blank text box.
• Navigation Bar .  Opens the NavBar dialog box.  You can edit the properties of the naviga-

tion bar you want to insert.
• Banner .  Inserts banner object.
• Image .  Opens the Image Properties dialog box to place an image in the current page.  You

can select an image from a WebShop library, Web resource (that is, an image already used),
or import an image file.

• Java Applet .  Opens the Java Applet Properties dialog box.  Select a Java Applet to insert
and set the properties.

• Embedded Object .  Opens the Embedded Object Properties dialog box.  Select an ani-
mated GIF, video, sound, or other multimedia file to embed in the current page.

• Group / Ungroup .  Groups or un-groups the selected objects to be treated as a single
object.

• Align & Size .  Align and resizes selected objects in reference to one another or to the page
area.

• Style .  Sets a style to the free page frame content overlay.

Plain Page–Insert Object Toolbar

The Insert Object Toolbar appears and is active only when the cursor is on a Plain Page.  Use
this toolbar to insert a number of different types of objects onto a Plain Page.
• Navigation Bar .

Opens the NavBar
dialog box.  Use this
dialog box to set or
edit the properties of
the navigation bar
you want to insert.

• Banner .  Inserts a
banner on the page.

• Form .  Inserts a form
in the current page.
Forms are used to
collect responses from users.  The response may be as simple as selecting a Submit button
or as complicated as filling out an order form.

• Link .  Opens the Link dialog box.  Use this dialog box to insert a link in the current page.
• Bookmark .  Opens the Bookmark dialog box.  Use this dialog box to add a bookmark in

the page.
• Table .  Opens the Table Properties dialog box.  Use this dialog box to insert and edit a table

in the current page.
• Image .  Opens the Image Properties dialog box.  Use this dialog box to place an image in
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Figure 4.9 – Insert Object Toolbar
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the current page.  You can select an image from a WebShop library, a Web resource or
import an image file.

• Horizontal Rule .  Places a Horizontal Rule (that is, a graphic bar used as a divider) at the
location of the cursor in the page.

• Text .  Opens the Import Text dialog box.  Use this dialog box to import a text file, or part
of a text file.

• Java Applet .  Opens the Java Applet Properties dialog box.  Use this dialog box to select a
Java Applet, set its properties, and insert it.

• Embedded Object .  Opens the Embedded Object Properties dialog box.  Use this dialog
box to select an animated GIF, video, sound, or other multimedia files and place them in
the current page.

• Special Text .  Opens the Special Text dialog box.  Use this dialog box to select a date
format, and insert a date, or to insert mail-to, or copyright information.

• HTML Code .  Lets you insert your own HTML code in the current page.
• Script .  Lets you create a Java Script or VB script with as many functions as you want and

insert it on the page.

Standard Toolbar

The Standard toolbar appears
whenever you open a Web page.
This toolbar is automatically
displayed and cannot be
accessed through the View
menu.  Use this toolbar to
change your visual settings,
spell check your document, or
assign paragraph styles.

• Visual Setting .  Opens the
Style dialog box.  You can edit the style settings only for the current active frame content
overlay.

• Paragraph .  Opens the Paragraph Properties dialog.  Use this dialog box to edit the
paragraph attributes for text alignment, margins, word wrap, and indentation.  You can also
edit the paragraph Bulleting and paragraph Numbering attributes in this dialog box.

• Font .  Selects a particular font, style (such as italic and bold), size, and color.
• Object Properties .  Opens the corresponding Attributes dialog box for the selected object.

Use this dialog box to edit the object’s attributes.  These include border, alignment,
alternate text, spacing and others.

• Form Properties .  Opens the Form Properties dialog box.
• Global Search .  Opens the Find dialog box.  Use this dialog box to search the entire Web

site for a specific text string.

Figure 4.10 – Standard Toolbar
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• Global Replace .  Opens the Replace dialog box.  Use this dialog box to search and replace
the entire Web site for a specific text string.

• Search .  Opens the Find dialog box.  Use this dialog box to search the current page for a
specified text string.

• Replace .  Opens the Replace dialog box.  Use this dialog box to search the current page
and replace a specified text string.

• Global Spelling .  Opens the Spelling dialog box.  Use this dialog box to spell check the
entire Web site for misspelled words.

• Spelling .  Opens the Spelling dialog box.  Use this dialog box to spell check the current
page.

• Show/Hide .  Toggles on and off the display of many hidden control symbols.  These
include symbols for hard and soft returns, form object boundaries, and others.

Formatting Toolbar

The Formatting Toolbar appears by default.  To remove it from the screen display, select View
> Formatting Toolbar .  The program also hides or removes it from the screen if the cursor is
not in a Web page.  The Formatting toolbar includes tools that enable you to format the text and
lines on the page.  To use it, simply select the text on the page and click on the formatting icon
you want.

• Style Pull Down .  Selects the HTML paragraph style.
• Font Pull Down .  Selects the HTML text logical style.
• Size Pull Down .  Selects the HTML font size for the selected text.
• Bold .  Bolds the text.
• Italic .  Italicizes the text.
• Underline .  Underlines the text.
• Align Left .  Aligns left the selected text or paragraph.
• Center .  Centers the selected text or paragraph.
• Align Right .  Aligns right the selected text or paragraph.
• Bullets .  Turns on/off the bulleting of paragraphs.
• Numbering .  Turns on/off the numbering of paragraphs.
• Increase Indent .  Increases the amount of indentation for the selected text or paragraph.
• Decrease Indent .  Decreases the amount of indentation for the selected paragraph.
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Figure 4.11 – Formatting Toolbar
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Form Fields Toolbar

The Form Fields toolbar appears when you are in Page
Editor and want to insert a form field.  It becomes
active only when you click Insert Form  on the Insert
Object toolbar or select Insert > Form .
• Text Line .  Inserts a box that accepts a single line

of text.
• Push Button .  Inserts a push button form field.
• Check Box .  Inserts a check box form field.
• Radio .  Inserts a radio button field.
• Combo Box .  Inserts a drop-down or combo box form field.
• List Box .  Inserts a list box form field.
• Text Box .  Inserts a text box form field that can accept multiple lines of text.

Dynamic Page Toolbar

The Dynamic Page toolbar appears when the cursor is
in a Dynamic Page.  It becomes active only when you
click on a resource tree element in the Dynamic Page
Manager.   Use this toolbar to insert and delete
dynamic elements from a Dynamic Page.
• Delete .  Deletes the selected item from the

resource tree in the Dynamic Page Manager
window.

• Insert .  Inserts a Dynamic Page Element into the Page Editor area to the right of the
Dynamic Page Manager window.  To activate the Insert feature, you must select one of the
Frame-Content Overlay icons in the Dynamic Page Manager window.

FrameSet Toolbar

The FrameSet Page toolbar appears when the cursor is
in a FrameSet Page.  It becomes active only when you
click on a resource tree element in the FrameSet Page
Manager.   Use this toolbar to insert and delete
FrameSet elements from a FrameSet Page.
• Visual Settings .  Lets you modify the style sheet

associated with an individual Frame or with a
FrameSet Page.  The Frame Style  or FrameSet
Style  dialog box appears depending upon the FrameSet Element selected.

• Frame / FrameSet Properties .  Lets you modify the properties associated with an indi-
vidual Frame or with a FrameSet Page.  The Frame Properties  or FrameSet Properties
dialog box appears depending upon the FrameSet Element selected.
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Figure 4.12 – From Fields Toolbar
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Chapter 5.
Site Manager

Introduction

The Site Manager is one of the most important parts for building a Web site.  Unlike other
programs, the Site Manager in WebShop is not a separate module or program.  It is an integral
part of the program and acts as a foundation upon which you build and manage your entire site.
It provides different views of your site and performs many important functions.

Topics covered in this chapter include:
• Physical Layout Window
• Logical Layout Window
• Navigate Layout Window
• Common Objects Window
• Styles Window

Getting Started

To launch WebShop
1. Select Start > Programs > Boomerang Software > WebShop .  The Program Group name

for WebShop may be different if you changed it during installation.
2. By default, WebShop should start the Site Manager , displaying a few windows.  One

window displays the Logical Layout , another window displays the Home page in Page Edit
mode.  If you want to start a WebShop project from scratch, you are ready.

To start Site Manager manually and return to the default screen display

Occasionally during development, you might close all visible windows.  If you have a com-
pletely blank work space and want to open Site Manager in the default mode, follow these
steps:
1. Select View > Project.   The Site Manager is launched.  The Site Manager–Logical Layout

window appears.
2. Double-click the Home  Page icon.  The Home Page window opens in Page Editor.
3. Select Window > Tile Vertically .  Both Site Manager and the Home Page window in Page

Editor are displayed side-by-side.  This is the default window display that appears when a
new Web site project is created.
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Site Manager Windows

The Site Manager includes the following windows:

••••• Physical Layout.   The Physical Layout window shows the folder view arrangement of the
files and folders of your Web site.  It is organized and operates similar to the Windows
Explorer format you are accustomed to.  The program stores all of the Physical Layout
information in a single file.  This simplifies the management of your Web site.  The folders
and files that you see in the Physical Layout window are not actually created on the hard
disk until you generate or upload the site.

••••• Logical Layout.   The Logical Layout provides a graphical display of the arrangement of
the various pages in a site.  The display arranges the pages in an “organization chart”
arrangement.  This makes it very easy to see how the site is organized, particularly with
respect to which pages are “parents” or “children” of other pages.

Important!  If you want to always be able to see every Web page in the Logical Layout “org
chart” view, you must always be in the Logical Layout when you add a page.  Advanced
users may not need to use Logical Layout.  If that is the case, an advanced user may add
pages using the Physical Layout and use the Navigate Layout to observe all links between
pages.  For most users, however, it is recommended that they add pages in the Logical
Layout first.

For example: If you import an image, using the Physical Layout it is not automatically
inserted in the Logical Layout because it is not treated as a logical element with a page and
parent assignment.  In fact, the Logical Layout will show only the Home Page.  In such a

Figure 5.1 – Default Site Manger Window
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case, it is left up to you to manually set the page properties (including style sheet inherit-
ance) and do the tasks that Logical Layout would have done automatically.

••••• Navigate Layout.   The Navigate Layout window displays your Web site in a graphical
display showing the links between pages and, if you wish, all of the resources in the Web
site.  This window is especially useful for viewing the link structure between the various
pages and with external Web sites.  The Navigate Layout has two different views: Spiral
view that displays the entire site including all the resources in the site, and Centered view
for links to and from the selected page.

••••• Common Objects.   The Common Objects window enables you to create both default and
custom headers and footers to handle repetitive information in many pages.  You create and
name your own customized headers and footers to use in any Web page.  The Program
places a blank default header and footer in the Home page upon start up.  You may disable
automatic insertion of blank headers and footers by accessing the preferences dialog box.
To do this, select File > Preferences > WebSite .

••••• Styles.   The Styles window enables you to manage the artistic style used in your site.  By
default, WebShop uses a simple style that you may replace easily with one of the other
included style sets.  You may create different styles, add them to the Styles Library, insert
one or more in your Web site and change styles at any time.  Since a common style is not
required throughout your site, you may customize any individual page if you want.

The Site Manager enables you to open many windows for different parts of your site.  This is
quite helpful when you want to have different layouts open in different windows simulta-
neously.  Furthermore, the program places navigation buttons or tabs at the bottom of the
program screen.  You can click on any of these tabs to open its corresponding window.

Site Manager–Physical Layout Window

To view this window, click the Physical Layout  tab in Site Manager.  The Site Manager–
Physical Layout  window displays the physical aspects of the Web site.

These include the directory structures and the actual files of the site.  It is organized and
operates very similar to the standard Windows Explorer.  When you generate a Web site, the
program creates all of the HTML, graphics, CGI, and support files.  These files are placed in the
same directory structure indicated in the Physical Layout.  Besides viewing, you can perform
many functions in this window.  To import a graphic file, there is a drag and drop feature that
lets you copy a file directly into Site Manager.  This can also be done from within a graphics
program that lets you select part or all of an open image.  In this case, the drag and drop
operations creates a new image file with a default name.

To rename a resource

1. From the Site Manager–Physical Layout  window, select and right-click the resource that
you want to rename.  A pop-up menu appears.

2. Select Rename .
3. Type the new name for the resource.



Chapter 5. Site Manager

WebShop 2000 User Guide5–4        ◆   ◆   ◆

BASIC FEATURES

To delete a resource

1. From Site Manager–Physical Layout  window, select and right-click the resource you
want to delete.  A pop-up menu appears.

2. Select Delete .  The item is deleted.

To create a new resource

1. From Site Manager–Physical Layout  window, select and right-click the resource folder
you want in the tree view.  A pop-up menu appears.

2. Select Create <resource type> .
3. Type the name for the new resource.

To drag and drop an image file from Windows Explorer into Physical Layout
1. Open Windows Explorer and locate the file you want to bring in.
2. Tile Windows Explorer and WebShop so that both windows are visible.
3. Click and drag the file from Windows Explorer to the currently open resource folder.
4. Release the mouse.  The file is copied into physical layout.

Figure 5.2 – Physical  Layout Window
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To drag and drop an open image file from a Windows graphic application into
Physical Layout
1. Open the Windows graphic application and open or create an image.
2. Tile the Windows graphic application and WebShop so that both windows are visible.
3. Select all or part of the open image using the graphic application tools.
4. Click and drag the image selection from the graphic application to the currently open

resource folder.
5. Release the mouse.  The image selection is copied into a default image file.

You can set specific folders in which certain types of objects are stored.  Some Internet Service
Providers may require that certain files be in a particular folder.  To accomplish this, you should
create the new folder and then assign it as the default folder for files of that type.  For example,
if your multimedia files must be stored in a folder labeled “Multimedia,” you can create the
folder and then set it as the default folder for all multimedia files.

To set a folder as a default folder

1. Right-click the folder you want to make the default.
2. Select the Set as Default  menu option.
3. Select the type of object that this folder will contain such as pages, images, multimedia.

To import a resource

1. Right-click the folder in the tree view or right-click in the blank area away from any files in
the list view.  The pop-up menu appears.

2. Select Import <resource type> .  The Open dialog box appears.

Note:  Verify that the files of type lists the type of file you want to import.

3. Navigate the correct file and click OK.  The resource is imported.

To edit an image

1. Right-click the image file that you want to edit.  A pop-up menu appears.
2. Select Edit .  The image appears in the Graphic Editor window.
3. Specify your edits by selecting the image objects that you want to change or by inserting

new objects.

Note:  For more information on how to edit an image, see the chapter titled “Graphic Editor.”

To create a shortcut

1. Right-click the folder in the tree view or right-click away from any files in the list view.
The pop-up menu appears.

2. Select Import Shortcut.

You can make a shortcut to an image, text, or any file without importing it into your site project.
This can be very helpful in cases when you want to place an object in your site, but the content
of the object is not ready yet.  In such a case you can edit or modify the shortcut file in another
program and you will not need to change the Web site project file.  Every time you generate the
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site the shortcut file is used instead of its shortcut.  As a result, you can always use the last
updated version of the file.

WebShop has the ability to store a particular object or resource as a slot or placeholder.  A slot
contains no information other than the type of object and the dimensions.  You might want to
use a slot in a Web page to set the placement of a graphic object that changes with every page.
For example, you might have a particular graphic button that you want to include on every
page, but the actual graphic is different.  You can design the page, place the object, and then
convert the object to a slot.  There are two advantages to doing this: first, if a Web site or page
has one object that is converted to a slot, you can save it as a template to use as a master.
Second, when you open the template to insert the actual graphic, all you have to do is double-
click the slot to insert an object of that type.  If the slot is an image, double-clicking on the slot
will open the Insert Graphic dialog box.

To show a resource as a slot

1. Right-click the object that you want to convert to a slot.
2. Select the Show as Slot option in the pop-up menu.

When the Physical Layout  window is open, the Physical Layout toolbar is enabled.  The
buttons on this toolbar are described in the chapter titled, “WebShop Toolbars.”

Site Manager–Logical Layout Window

The Logical Layout tab is one of the most useful features in Site Management.  This window
enables you to add, move, and delete Web pages from your Web site.  The Logical Layout
window organizes the Web pages in a hierarchical structure, similar to an organization chart.
This format enables you to readily see and plan the link structure for your Web site.

The Logical Layout organizes the site in a hierarchy of parents, children, and siblings.  The
Home Page is a parent page since all other pages in the Logical Layout are below it.  Pages on
the level below the Home Page are children of the Home Page.  The children of a Home Page
are also called First Level Pages.  All children or sub-pages of a particular page are sibling
pages.

While the Site Manager–Physical Layout  window allows you to manage and arrange all types
of objects and resources, the Logical Layout  window enables you to organize the Web pages in
your site.  A new Web site begins with a Home Page.  All other pages flow from this page in a
hierarchy that displays as an organization style chart.  This feature enables you to view and
structure your site logically, adding new pages, moving pages, and deleting pages as needed.

While the pages in the Logical Layout  window appear to be linked in the chart structure, the
pages themselves do not have any links until you add them.  For example, if you create a new
Web site and add a page below the Home Page, there are no links for the user to get to that page
or return to the Home Page.  The lines in the Logical Layout  window only show the organiza-
tional structure of the Web site and not the link structure.  If you want to view the link structure,
you must use the Site Manager–Navigate Layout  window.

Each page icon in the Logical Layout  window represents a logical page.  For example, if a page
has two frames, it is actually made up of three HTML files.  The Logical Layout  window
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shows only the page itself and not the related HTML files.  When you open a logical page,
WebShop automatically opens all related HTML pages for you to view and edit.

To open a page for editing

1. Double-click the page that you want to open.  The Page Editor window appears.
2. Page Editor displays the page and enables you to edit it, add to it and work with the page.

If the page contains more than one frame, as with a FrameSet page, the page will open and
display all of the frames associated with that page.  You may edit any of them.

To perform operations on more than one page
1. If you wish to perform an operation on more than one page, such as opening pages or

setting the visual properties for a set of pages, hold down the CTRL key as you click on
each page you want.

2. With the pages that you want selected, right-click.  A pop-up menu appears.
3. Select the menu option that you want to apply to all of the pages as a group.

To add a new page to a Web site

The Site Manager–Logical Layout  window uses an “organization chart” system for classifying
pages as parent, child, and siblings.  The Home Page is the parent page of those pages that come
directly below it.  The pages that come directly below the Home Page are children of the Home
Page.  All pages that are tied to a particular page are sibling pages.  You can associate a new
page with any existing plain page, frame set, free page, or dynamic page.
1. To add a page, select and right-click the parent page.  A pop-up menu appears.
2. Select New.  The Add Logical Page  dialog box appears with the Create New Resource

tab selected.  Plain Page is the default selection.

Figure 5.3 – Logical Layout Window
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3. Select the type of page that you want to add and click OK.

To add a new page that is currently defined as a resource, click on the Use Existing Resource
tab.  Select the folder where the resource is located and select the resource that you want to add.
Click OK to continue.

To rename a page

1. Right-click the page.  A pop-up menu appears.
2. Select Rename .

To delete a page

1. Right-click the page.  A pop-up menu appears.
2. Select Delete .

To move a page

1. Click the page and, while holding down the mouse button, drag the page to a new location.
2. When the page and mouse pointer are over the new parent page, release the mouse button

to drop the page as a child page to the selected file.  When you are moving a page, you
must drag it to and drop it on a new parent page.  The only page in the Logical Layout
window that does not have a parent is the Home Page.

When the Logical Layout  window is open, the Logical Layout toolbar is enabled.  The buttons
on this toolbar are described in the chapter titled, “WebShop Toolbars.”

Physical and Logical Page Properties
After you add a new page, there are a number of steps that you should take to complete the page
setup.  These steps include inserting headers and footers, assigning style to the page, inserting
Meta tags, among others.  Some of these are placed by the program in the pages by default.  If
you do not want the new page to inherit the default settings, then you should change the
properties of the page.

Properties Dialog Box
To change the properties of a page, right-click the page you want in the Logical Layout.  Select
Properties  from the pop-up menu.  The Properties  dialog box appears.  This dialog box gives
you information about the page, and enables you to enter certain data.  When selected for a Page
resource, the Properties dialog box has two tabs.

Note:  The Properties dialog box appears with other resources such as folder, image or
database.  The dialog box that displays depends upon the object selected.

The Resource  tab includes:

••••• Name.  Displays the name of the page as it appears in the Logical Layout.

••••• Type .  Displays the Type of page it is.  Types include, Plain Page, Free Page, Dynamic
page and others.

••••• Path .  Displays the path or location of this page in your Physical Layout folder.
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••••• Size.  Displays the size of the page or object.  It mostly applies to graphic images or single
files.

••••• Alias .  Displays the alternate name for the page that is used with Banners and Navigation
Bars.  To change the Alias, check the Alias checkbox and enter the name you want.

The HTML tab includes:

••••• Title .  Displays the title of the page.  This is the text that appears in the title bar when the
browser displays the page.  You may enter your own title if you like.

••••• Meta information .  Displays the meta tag of the page.  This is explained in more detail in
the following section.

The Page tab includes:

••••• Header .  Displays a drop-down list of Headers currently available.  The resource name
used are as they appears in Site Manager–Common Objects.

••••• Footer .  Displays a drop-down list of Footers currently available.  The resource name used
are as they appears in Site Manager–Common Objects.

Meta Tags
One of the most important elements of Web pages are Meta tags.  These text lines appear at the
top of almost every Web page, but most of them are generally not displayed by the browser.

Figure 5.4 – Properties Dialog Box for a Plain Page
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Meta tags can include keywords that describe the Web page content, page author, language
encoding, and page description.  The keywords and page description are especially important
for a number of major search engines.  These search engines automatically catalog vast numbers
of Web pages collecting information stored in the Meta tags.  If your pages do not use Meta
tags, your site may not be accessible through one of these search engines.

To enter Meta tag information
1. Click Add  in the HTML tab of the Properties  dialog box.  Enter the Meta tag information

that you want and click OK.
2. If you want to modify an existing Meta tag, click the tag that you want to edit and click

Modify.

To remove a Meta tag from the list
• Select the tag, then click Delete.

Site Manager–Navigate Layout Window

Visitors to your site navigate in your site a lot like running a software application.  Most Web
sites require a certain amount of interaction with the visitor.  This enables them to go to various
pages or find a particular piece of information.  It is important to remember that the first time
visitors arrive at your site, they will have no advance information about how your site is
organized.  They may have a general idea of how other Web sites operate and how to navigate
them, but they have no idea as to how your navigation system works.  In addition, they have no
user guide or help file for your site.

The main standard followed by visitors of Web sites is that they navigate in your site by
pressing on the links of your pages.  Therefore, it is extremely important that you have complete
control on the building, management and update of the links in your site.  The Navigate Layout
provides you that control.

The Site Manager–Navigate Layout  window graphically displays the links and navigational
controls between pages, resources, and external Web sites.  This helps you review the links of
your site.  You should make sure that all of the pages in your site have links.  Follow the
guidelines of the program, use the NavBars, Header/Footers and other automated functions of
the program to minimize broken links or orphan pages.  The Navigate Layout gives you an
added level of insurance against such errors, as it enables you to visually and graphically
examine your entire site and all the links.

You can even set your own colors for the pages, resources, internal and external links (repre-
sented by connecting lines).  This will help you visually identify each part of the graphical view
of your site.

The Navigate Layout window provides two views: Spiral  and Centered.   The Spiral view
displays the entire site with all the resources and links.  You can zoom in and zoom out of
different parts of the Spiral view.  The Centered view displays the selected page (or resource) in
the center.  The incoming links are displayed at the top or left and the outgoing ones at the
bottom or right.  You can choose from Vertical  (top to bottom) and Horizontal  (left to right)
views.  The linked pages can be expanded and collapsed to display the links.
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To change the colors in Navigate Layout display
1. Select the File > Preferences  menu options.
2. Click the WebSite  tab in the Preferences  dialog box.
3. In the Site Manager–Navigate Layout  window section, click the color sample box for the

option you wish to change, such as Selected Page.
4. In the Choose Color  dialog box, click the color you want.
5. Click OK to make the color change.

The Site Manager–Navigate Layout  window provides many ways you can view the site or
links.  For example, you may wish to turn the resources display off when you are checking for
orphan pages.

To show pages in Navigate Layout

• Click Include Pages  on the Navigate Layout toolbar or select the Navigate Layout >
Include > Pages  menu options.

Figure 5.5 – Navigate Layout Window
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To show resources in Navigate Layout

• Click Include Resources  on the Navigate Layout toolbar or select the Navigate Layout >
Include menu options and select the resource you want.

You can set the Site Manager–Navigate Layout  window to show all links between pages in
two different formats.  You can choose to show all of the links all the time or, you can choose to
show only the links to and from the selected page or resource.  To apply some of these options,
you must first click and select the page in the Logical Layout, then select the menus or tools.

To show all external resource links all the time in Navigate Layout

• Click Include External Locations  on the Navigate Layout toolbar or select Navigate
Layout > Include > External Resources menu options.

If you have elected to show only the links for the selected pages or resources, you can also
choose to display different types of links.

To show incoming external links in Navigate Layout

• Click Show Incoming Links  on the Navigate Layout toolbar or select Navigate Layout >
Show Links > Incoming For Selected  menu options.

To show outgoing external links in Navigate Layout

• Click Show Outgoing Links  on the Navigate Layout toolbar or select the Navigate Layout
> Show Links > Outgoing For Selected  menu options.

To show all links in Navigate Layout

• Select the Navigate Layout > Show Links > All  menu options.

To show outgoing resource links in Navigate Layout

• Click Show Outgoing Resource Links  on the Navigate Layout toolbar.

To include or exclude certain links, page types, or resources in Navigate Layout
• Click Navigate Layout > Include  and select the one you want.

To move a page to the center in the Centered view of Logical Layout
• Click on the page in the left window and select Navigate Layout > Move to Center  from

the menus.

Zoom Feature
The Site Manager–Navigate Layout window includes a zoom feature.  Use it to increase or
decrease the magnification view.  This can be especially helpful for very large Web sites.

To zoom in your view

• Select Zoom In  on the Navigate Layout toolbar or select the Navigate Layout > Zoom > In
menu options.

To zoom out your view

• Select Zoom Out  on the Navigate Layout toolbar or select the Navigate Layout > Zoom >
Out  menu options.
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To return Navigate Layout to normal view
• Select Actual Size (1:1)  on the Navigate Layout toolbar or select the Navigate Layout >

Zoom > Normal  menu options.
When the Navigate  Layout  window is open, the Navigate Layout toolbar is enabled.  The
buttons on this toolbar are described in the chapter titled, “WebShop Toolbars.”

Site Manager–Common Objects Window

The Common Objects  tab enables you to create standard headers and footers to use in Web
pages.  A header or footer can be inserted in any page or page frame.  Each new Web site
begins with a blank default header and a default blank footer.  You can create as many new
headers and footers as you want for your Web site.

Information usually included in standard headers and footers might include a navigational bar
or button bar in the header and a copyright notice, company logo, and mail-to option in the
footer.  Since you would probably want these items to appear on one or more pages, creating
and using a standard header and footer can save you a great deal of repetitive work.

Common Objects are context-sensitive.  If you insert a relative link or navigation bar in a
header, the links will point to different destinations based upon whether the header is inserted in
a page or a frame within a page.  When you insert a header or footer into a frame, it is inserted
in all sources of the frame.

The program includes a feature that automatically inserts a default header and footer in every
page that you add to the site.  You must enter the information that you want the header and
footer to contain.  If you like, you can turn this feature off.  If you create a default header but
not a footer, selecting the automatic header/footer feature will only insert the default header.

Figure 5.6 – Common  Objects Window
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To turn the automatic Header / Footer feature on or off

1. Select the File > Preferences  menu options.
2. Click the WebSite tab in the Preferences  dialog box.
3. Click the check box next to the Insert default Header/Footer automatically  option.
4. Click OK to make the change.

You can edit and create new headers and footers using the Page Editor feature in the Header/
Footer window.  When you make a change in either the header or the footer, that change is
reflected in all appropriate pages throughout the Web site.  If you have already generated the
site (that is, created the HTML and resource files in Web site format), you will have to regener-
ate it to have the pages with the new headers.

To insert a Header or Footer in a page
1. From Site Manager–Logical  or Physical Layout , select and right-click the page that is to

receive the header or footer.  The pop-up menu appears.
2. Select Properties  and click the Page tab.  Click on the pull-down menu and select the

Header  or Footer  you want to insert.

Note:  You can insert a Header or footer only in a Plain Page, and not in a Free Page or
Dynamic Page.

To open a Header or Footer for editing

1. In the Site Manager–Common Objects window, double-click the Default Header or
Default Footer  icon to edit.

2. The Page Editor  window opens with the selected Header or Footer.  Specify your edits and
click OK.

Note:  Besides text, the program enables you to insert many graphic elements into a header
or footer.

To create a new Header or Footer

1. Right-click inside the Default Header or Default Footer  frame.  A pop-up menu appears.
2. Select New.
3. When the new Header  or Footer  icon appears, select it and right-click.  A pop-up menu

appears.
4. Select Open .  The Page Editor window appears for the object selected.
5. Type the content you want to appear.

To rename a Header or Footer

1. Right-click the Header or Footer  icon.  A pop-up menu appears.
2. Select Rename .
3. Type the new name in the space provided.

To delete a Header or Footer

1. Right-click the Header or Footer  icon you wish to delete.  A pop-up menu appears.
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Note:  If you wish to delete more than one header or footer, hold down the CTRL key as you
click the Header or Footer  icons.

2. Select Delete .
3. Click Yes to confirm.

The program enables you to create as many header and footer files as you want.  You can insert
any one in any Plain Page.  However, only one of each can be designated as the default.  The
one selected as the default is added to pages when you select the insert default header/footer
option.

To set a Header or Footer as the default

1. From the Site Manager–Common Objects  window, select and right-click the Header or
Footer  that you want to be the default.  A pop-up menu appears.

2. Select Set as Default .  A check mark appears indicating that this is the default.

To view Headers or Footers as large or small icons

1. Open the Web page that has the Header or Footer.  Right-click anywhere inside the Header
or Footer area.  A pop-up menu appears.

2. Select View > Large Icons, Small Icons .  The Header or Footer display changes as
requested.

When the Common Objects  window is open, the Common Objects toolbar is enabled.  The
buttons on this toolbar are described in the chapter titled, “WebShop Toolbars.”

Site Manager–Styles Window

The Styles  tab enables you to set the look and appearance of pages.  In its simplest form, you
can use one style on all the pages, and the entire site will have the same motif.  In a more
interesting Web site, you may want to use few styles for different parts of the site.  The style
effects a number of key elements of Web pages.  These include items such as Background,
Banner, Navigation Bar, Horizontal Rule, Paragraphs (Normal, Headings, Address, Pre-
formatted), Logical Font Types (Definition, Site, Code, Emphasis, Helvetica, Keyboard,
Sample, Strong, Variable) and Link Colors.

The program allows you to design your own style and place it in a program library for use in
your project.  However, designing styles needs some artistic talent, and the time dedicated to
create a presentable, attractive, yet functional style.  The program includes a number of profes-
sionally created styles.  The installation of the program gives you the option to install some or
all of the styles.  These styles are placed in libraries that you can readily use.

The Site Manager–Styles  window has three areas.  The Style Library  area, the Site Style  area
and the Preview  area.  On the left is the Styles Library .  It lists the styles or style groups you
have installed.  These are not made part of your project.  They are simply listed as styles from
which you can choose.

To see what each style looks like, click on a style in Styles Library .  The corresponding style
appears in the Preview  area to the far right.  You can double-click on any object or element in
the style to edit it.



Chapter 5. Site Manager

WebShop 2000 User Guide5–16        ◆   ◆   ◆

BASIC FEATURES

If you want to use a style in your Web site, you must first include it as part of your project’s
active styles.  To activate a style, select and right-click on a style displayed in the Styles
Library area.  A pop-up menu appears.  Select Insert .  The style is inserted in the Site Styles
area.  You can include as many styles as you want.  Once a style is listed in the Site Styles area,
you can refer to it or use it from any page of your Web site.  The Site Styles area holds the
currently active styles for your project.  During development, each time you open the project
file, the program remembers and lists the styles you have selected.  This is your “palette of
styles.”

To modify a style after inserting into the Site Styles list, select the style and double-click on any
of the elements (or objects) in the Preview  area.  Depending upon what you select, a dialog box
appears.  Make your changes.  After you modify a style, you may want to rename it.  To do this,
right-click the style in the Site Styles  area and select Rename .  Enter the name you want.

When you use a style in your project, the style is activated and saved with the project.  In
addition to being able to use styles in your Web site, you can assign or apply styles to pages
based on certain settings.  For example, you can set the pages such that every time you insert a
page, it will inherit the style from its parent page.  The program provides you with different
methods of transferring or applying styles from one part of the site to the other.  This topic also
referred to as Cascading Style Sheets are covered in detail in the chapter titled “Dynamic
HTML and Cascading Style Sheets.”

When the Styles  window is open, the Styles toolbar is enabled.  The buttons on this toolbar are
described in the chapter titled, “WebShop Toolbars.”

Figure 5.7 – Styles Window
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Introduction
You will want to set up one or more Cascading Style Sheets for use with your Web site.  A
Cascading Style Sheet is an exciting feature that allows for the dynamic presentation of Web
site text and graphic objects.  The word “cascading” implies that styles can be implemented in a
hierarchical fashion – with style specifications defaulting down through a specified hierarchy.
In WebShop, the hierarchy is your Web site’s page hierarchy, which is graphically illustrated
using the Site Manager–Logical Layout  window.  Each Web page either accepts a default (or
inherited style) from the next highest page or is specifically assigned one.  With Cascading
Style Sheets, you can set a presentation style for your whole Web site and change it, dynami-
cally, by changing the style sheet default or be assigning a page to a new style sheet.

The basic principle behind Cascading Style Sheets is straightforward: predefine the display
treatment of specific Web page elements and then apply the display treatment automatically
whenever the object or element is applied on a page.  As you will see, the “look” you define
through a style sheet impacts the presentation quality of your entire Web site.  Bold or subdued–
anything is possible.

The Cascading Style Sheet Standard (CSS1) is a standard that was created by the World Wide
Web Consortium.  It provides for the use of Style Sheets and absolute positioning of objects on
a page.  Absolute positioning of objects is handled through WebShop’s Free Page feature,
which is covered later.  Style sheets apply to all page types and are used to manage the visual
elements of your Web page design.

Note:  For more information about Free pages, see the chapter titled “Dynamic HTML and
Free Page Design.”

Cascading Style sheets are specified using Site Manager–Styles  window.  WebShop comes
with predefines Style Sheets that you can use without modification, use with modification, or
create from scratch.

Topics covered in this chapter include:
• What Makes a Style Sheet Different?
• Creating Styles Sheets for Your Web Site
• Assigning a Style Sheet to a Web Page
Applying Style Sheet Elements
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What Makes a Style Sheet Different?
Conventional Web page design was very difficult to manage.  There was very little control over
the presentation of text (or objects) placed on a page.  For example, the tag <H1> is called
Header 1.  This header has specific size, font and other display characteristics.  If Web designers
wanted some text to be slightly different, they would have to change the <H1> “style” by
specifying every characteristic and attribute with every occurrence.  With the use of a Style
sheet, you can specify what the styles are going to be for the whole document or Web site all at
once.  This saves a significant amount of time.

When a browser reads a Style sheet tag, it looks for an interpretation of the tag in the Style sheet
definition.  Style sheets are defined in HTML at the top of each page.  These definitions tell the
browser how to present each element so that it displays according to the designer’s needs.

Creating Styles Sheets for Your Web Site

WebShop has defined Style Sheets for fonts, font color, banners, NavBars, background,
bulleting and numbering.  Before you create your Web site, you should review the predefined
styles and decide what styles you want to use.

To begin working on styles
1. Open WebShop.  By default, a blank project file appears.
2. Select File > New  if you wish to use a Web site template or select File > Open  if you have

already created a file.  The Site Manager–Logical Layout  window appears.
3. Click Styles  tab.  The Site Manager–Style  window appears.

You will see the Styles Library  list box and display box, a Site Styles  display area and a
Preview  area.  By default, the Styles_0  Style Library is selected.  Click Style01 to see a
preview.  By previewing styles from the Style Library, you can decide what styles you want to
use.  Once you select a style you want, you must insert it into the Site Styles list.

To insert a Library Style into the Site Style list
1. Highlight on the style you want and right-click.  A pop-up menu appears.
2. Select Insert Style .

The style you selected has now been inserted into the Site Styles  display area.  It is now
available for use.  You can insert as many Library Styles as you want.  If you do not like any of
the Library styles, you may also create a Custom Style.

To create a custom style
1. Right-click on the Site Styles  box (in the white space).  A pop-up menu appears.
2. Select New Style .

Making a new style in this way creates a copy of the default style.  By default, any custom style
based on the default style is named Style , Style1 , Style2 , successively.  You should rename
your custom styles and your inserted library so they have a distinctive name, one that tells you
how that style will be used.
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To rename a style
1. Highlight the style you want to rename and right-click.  A pop-up menu appears.
2. Select Rename .  A box appears around the style name.
3. Type the new name.

Once you have renamed the style, you are ready to customize the style.

To modify (or customize) a style
1. Highlight the style in the Site Styles list.
2. In the preview area, select and double-click on the style element that you want to modify.

Note:  Style previews are divided into different areas.  You may want to experiment with
several just to learn how style elements are grouped.  For example, highlight the word
“Banner” (dotted lines appear) and double-click on the box.  The Banner Style dialog box
appears.

3. From the dialog box that appears, choose the options you wish to change.

Note:  There are several dialog boxes that might open depending upon what style elements
you select.  These include Background, Banners, NavBars, Horizontal Rules, Paragraphs
(Headings, Normal or Special Paragraphs), Phrase Font Styles, Link Colors, Bullets and
Numbering.  To change a style, you may need to play with the various options used with
each to see how they work.

4. When you are done, click OK.  Your change is now reflected in the preview area.

Note:  If you want to use a custom image for a banner, bullet, or other graphic object, you
can insert new images into one of the several image libraries.  You can do this by selecting
on Library > Edit Image Library.  The Edit Library dialog box appears.  Use the drop down

Figure 6.1 – Site Manager–Styles
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menu in the Library Type box to select the library.  Then locate the image that you want to
add in the top most Look In box.  Highlight the image file that you want and click Add.  When
done, click OK.  When you go back to insert the graphic image, the image will be there.

You can customize all of the different sections of the Style sheet using the above procedure.
The parts of the Style sheet that can be edited include Banners, NavBars, Horizontal Rules,
Headings, Phrase Fonts, Link Colors, Bullets, and Numbering.  When done, you might want to
set one of your customized Site Styles as the Default Style.

To set one of the styles as the default style
1. Highlight the style that you want to be the default and right-click.  A pop-up menu appears.

2. Select Set as Site Default Style .  A red check mark appears next to the icon for that
style sheet.  This indicates that it is the default style.

Note:  You do not have to use the style name “default,” however it is recommended that you
do.  To rename your style Default_Style, delete the old Default_Style before trying to rename
the new one.

Once you have imported and/or created one or more styles, you can then go to a Web page and
assign the styles to specific pages.  By assigning a style, all of the graphic elements of that style
become available.  To use them, either insert a graphic element such as a Banner or a NavBar,
or assign a text format such as a Head1 style using the Style  list box on the Formatting toolbar.

Assigning a Style Sheet to a Web Page

When you first open a Web site, the Site Style Default_Style  is the default style unless you have
set a different style as the default.  Styles can be assigned to all types of pages, although they
can be assigned in different ways.  There are three ways that you can assign a style to a page: by
default, by assigning a specific style, or by assigning a specific style and then customizing the
style at the page level.  You can assign styles to pages either from Site Manager–Logical or
Physical Layout  or from Page Editor once you open a Web page.  In Logical or Physical
Layout , you can assign the same style to a number of pages at the same time.

To begin assigning styles to a page
1. Open WebShop.  By default, a blank project file appears.
2. Select File > New  if you wish to use a Web site template or select File > Open  if you have

already created a file.  The Site Manager–Logical Layout  window appears.

To assign a style to a page from the Site Manager–Logical Layout window
1. From Site Manager–Logical Layout,  highlight the page icon to which you want to assign a

style.
2. Right-click on the page icon.  A pop-up menu appears.
3. Select Style .  The Page Style  dialog box appears.
4. Decide what you want to do:

• To accept the default, click Default (Or Inherited Style)  radio button.
• To assign a specific style, click Specific Style  radio button and use the drop-down

arrow to select a style.
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• To customize a specific style
for use with this page (and
any default pages below it),
click Specific Style  radio
button and use the drop-down
arrow to select a style, and
then click Custom  radio
button.  You are now ready to
customize this style.  See the
procedure “To modify (or
customize) a style” described
earlier.

5. When done, click OK.

To assign a style to a page from
Page Editor once you open the
Web page
1. From Site Manager–Logical

Layout,  double-click on the page icon you want to open.  The Page Editor  window
appears.

2. Right-click anywhere on the page and select Style.  The Page Style  dialog box appears.
3. Decide what you want to do:

• To accept the default, click Default (Or Inherited Style)  radio button.
• To assign a specific style, click Specific Style  radio button and use the drop-down

arrow to select a style.
• To customize a specific style for use with this page (and any default pages below it),

click Specific Style  radio button and use the drop-down arrow to select a style, and
then click Custom  radio button.  You are now ready to customize this style.  See the
procedure “To modify (or customize) a style” above.

4. When done, click OK.

Applying Style Sheet Elements
Once you have assigned a style to a Plain Page, apply the style elements by inserting or format-
ting objects on the page.

• To insert a banner, select Insert > Banner  or click Insert Banner  on the Insert Objects
toolbar.

• To insert a NavBar, select Insert > Navigation Bar  or click Insert NavBar  on the Insert
Objects toolbar.

• To assign a font style, select Format > Paragraph  or click Style  drop-down list box on the
Formatting toolbar.

• To assign bullets, select Format > Paragraph  or click Bullet  on the Formatting toolbar.

• To assign numbering, select Format > Paragraph  or click Numbering  on the Formatting
toolbar.

Figure 6.2 – Page Style Dialog Box
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To modify a style object on a page (by double-clicking)
1. Double-click the Banner, NavBar, or Horizontal Rule object that you want to modify.  A

dialog box appears.

Note:  Not all style elements can be directly modified by double-clicking.  Use the Page Style
dialog box for those that cannot be updated directly.

2. Using the dialog box fields and buttons, select the options you wish to change.
3. When done, click OK.  The style element, as displayed on the Web page, is updated.

To modify a style element on a page (using a Style dialog box)
1. Right-click in the white area of the page.  A pop-up menu appears.
2. Select Style .  The Page Style  dialog box appears.

Note:  When working with a Free Page, use Object > Modify Style.  The Free-Form Page
Style dialog box appears.  When working with a Frame, rather than a Frame Content
Overlay, the Frame Style dialog box appears.

3. Click the Specific Style  radio button and use the drop-down arrow to select a style, and
then click the Custom  radio button.  The Edit button becomes active.  You are now ready
to customize a style element.

4. In the preview area, double-click the style element that you want to modify.  A dialog box
appears.

Note:  Style previews are divided into different areas.  You may want to experiment with
several just to learn how style elements are grouped.  If you want, you can select the style
element using the drop-down list box next to the Edit button.

5. Using the dialog box fields and buttons, select the options you wish to change.
6. When done, click OK.  The style element preview is updated.
7. To apply the style, click OK.  The style element, as displayed on the Web page, is updated.

To change the page background
1. Right-click in the white area of the page.  A pop-up menu appears.
2. Select Style .  The Page Style  dialog box appears.

Note:  When working with a Free Page, use Object > Modify Style.  The Free-Form Page
Style dialog box appears.  When working with a Frame, rather than a Frame Content
Overlay, the Frame Style dialog box appears.

3. Click the Specific Style  radio button and use the drop-down arrow to select a style, and
then click the Custom  radio button.  You are now ready to customize a style element.

4. In the preview area, double-click the style element that you want to modify. A dialog box
appears.

Note:  Style previews are divided into different areas.  You may want to experiment with
several just to learn how style elements are grouped.

5. Using the dialog box fields and buttons, select the options you wish to change.
6. When done, click OK.  The style element preview is updated.
7. To apply the style, click OK.  The style element, as displayed on the Web page, is updated.
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Creating Web Pages

Introduction
Ultimately all the work that goes into creating Web pages serves one purpose: to have an
efficiently designed and modern looking Web site.  To write code in HTML for some of the
modern features of today’s Web sites, even the HTML experts encounter problems.  This
challenge will continue to get tougher, as the Internet evolves and advances.  This program is
the result of many years of work, by groups of high-level software engineers.  It’s main goal is
to deliver an easy to use, yet comprehensive, program that provides the average PC-user, who
has no knowledge of programming or HTML, the able to design and maintain a robust and
powerful Web site.  It has a number of pioneering features such as the single secure file and the
Frame Manager.

This chapter will describe other important aspects of the program regarding the different types
of Web pages you can create.  Some of the features, such as the Free Pages, described in this
chapter, are quite new to the market and not available with most other programs.

Topics covered in this chapter include:
• Web Page Overview
• Plain Pages, Free Pages, Dynamic Pages, Frame Pages and others.

Web Page Overview
Each page of your Web site can be treated as a separate entity.  This program has the unique
feature of maintaining your entire site in one single contiguous file structure.  Nevertheless, it
creates all the individual files needed for every element of your site as it generates and places
your site on internet servers.  During the design process, each time you add a new page to the
site, the program provides you with a set of choices for types of Web pages you can insert.
Each type of Web page has its characteristics.

Adding Pages to Your Web Project
You can add a new page to your Web site project from either the Logical Layout or Physical
Layout screens of the Site Manager.  It is not recommended that you add pages in the Physical
Layout.  You must add them first in the Logical Layout.  The program will assign the page to
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the proper parent and also add it in the Physical
Layout.

To add a new page from Logical Layout
• In the Logical Layout window, click on a page

you want to add a page to, then from the menus
select Logical Layout > New Page  or click on
the Create Page  button  from the
toolbar.

• You can also right-click the mouse on
the page you want to add a new page to.
From the pop-up menu, select New.

When you create or insert a new page, the
program displays the Add Logical Page
dialog box.

The Create New Resource  tab of the dialog
box includes a number of different types of
Web pages you can insert.  Select the type
you want and click OK.  The Use Existing
Resource tab lists all the existing type of
pages you already have in your project.
Instead of creating and designing a new
page, you can select one that you had
designed before and use it now.  The
following sections describe the different
types of pages you can insert.

To add a new page from Physical Layout
• In the Physical Layout window, click on the main folder of your project to open it.  Select

the Physical Layout option from the main menu.  The list of choices displays different
types of Web pages you can insert.  Choose one of the Create options you want.

• In the Physical Layout window, right click the mouse on the main root folder (or any folder
that you want).  The pop-up menu displays different types of Web pages you can insert.
Choose one of the Create options you want.

Figure 7.2 – Add Logical Page Dialog Box
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Figure 7.1 – Logical Layout Toolbar

new
folder

new frame
set

new
page

new free
page

new dynamic
page

import
java

new
image

import
shortcut

import
multimedia

import
database

small icons details

import
custom

delete style

rename properties large icons list

Figure 7.3 – Physical Layout Toolbar
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Plain Page

The Plain Page is the normal simple Web page that you are most accustomed to.  It is based on a
word processor-like page layout.  You enter the text on a line by line basis.  You can insert
graphic, frames, tables, and all other objects on such a page.  The main limitation of a Plain
Page is its text line-by-line structure.  You cannot drag a graphic object or a table by a pixel-by-
pixel drag method in a Plain Page.  You can drag objects and place them in different parts of the
page.  However, the object will be placed at the nearest character and line position on the page.
You cannot overlap or layer objects on the Plain Page.  You can only do that in a Free Page.

Frame Set Page
The Frame Set Page is a page pre-configured with frames.  Use this when you want nested
frame sets.  In other words when you want to insert a set of frames inside another frame.  The
page inserted will be given the name FrameSet with a number.  It will be blank at first.  You can
divide it into more frames and add more content.

Free Page
Use this when you want to place graphic or text objects anywhere on the page.  This is the more
versatile page style where you are not limited by the text line limitations of Plain Pages.  If you
want to be artistic, place objects on the page where you want, drag them with your mouse pixel-
by-pixel for accurate positioning, then use a Free Page.

In a Free Page, the program provides you with a Grid  pattern and Snap to Grid  options.  The
Grid makes it visually easy for you to
position and drag objects on the page.  The
Snap to Grid is like magnet lines.  It helps
you to line up your objects across certain
grid lines.  To access these two functions,
while in a Free Page, from the main menu
select View > Grid  or View > Snap to
Grid.

Objects you can place on a Free Page can
be text, graphic, and others.  You can place
links on these objects just like you would on a Plain Page.  To insert objects on the Free Page
click on one of the buttons from the New Object toolbar.

The program enables you to group and ungroup objects on a Free Page.  This is useful, in cases,
when you place and design only few objects and when you want to re-size or move them all as
one group.  To group a set of objects, click once on each object while holding down the Shift
key.  Then click the Group button  from the toolbar.  A bounding box will surround all of the
objects.  You can now resize all of them together proportionately by dragging the handles of the
bounding box.  You can reposition the group by simply dragging it to a new location.

free-form navigation
bar

image multimedia align &
size

text box banner java

Figure 7.4 – New Object Toolbar

group /
ungroup

style
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Note:  Objects on a Free Page can have transparent backgrounds.  This enables you to
(completely or partially) overlap few objects on one another to achieve designs that other-
wise would have been almost impossible.

There are a number of significant advantages in using Free Pages.  Some of these are:
1. The artistic freedom that you get by being able to position objects on the page and drag

them almost in a pixel-by-pixel accuracy.
2. The ability to group (and ungroup) objects together and resize them together proportion-

ately or move them together.
3. The Free object oriented nature of the Free Page enables you to place objects in a columnar

and row layout on the page.  This was partly done by using tables in earlier versions of
Web publishing programs.  However, tables were not created for this purpose.  The Web
pages that used tables to do this are hard to manage, since everything resided in cells, as
opposed to being separate objects that you can manage freely.

4. The generated HTML files for Free Pages are much cleaner, smaller and more efficient for
internet transmission and faster for browsers to view.  This means your Free Pages created
by this program will come up on viewer’s browsers faster and cleaner than most other
table-based Web pages.

Figure 7.5 – Example of Overlapping Objects
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Dynamic Page
If the server you are placing your Web site on has Active Server Page (ASP) functionality, then
you can use Dynamic Pages.  This is a special type of a page.  All the other pages we have
described up to this point were static or fixed pages.  Even if you place animated GIFs, AVI
files or Java Applets on the other pages, they are ultimately fixed in the format, layout and what
they can display.

In contrast a dynamic page is one that changes and displays different set of items or objects
based on certain conditions.  This is especially useful in having your site to generate and display
specific information or data tailored to specific type of visitors or based on certain interaction
between your Web site and the visitor to your site.

Use Dynamic Pages when you want to create a page that displays text or form elements that
contain instructions executed by your ISP-server.  The Dynamic Page will contain instructions
that are executed by your ISP or Web-hosting server.  The dynamic pages that you create in
your Web site, can only run and operate properly on servers or ISP computers that are running
NT-based operating systems with ASP functionality.  The ASP standard is part of the Microsoft
NT system.  Recently other companies have also adopted this ASP standard.  In some cases you
may find ASP functionality running on UNIX servers such as Solaris from SUN, Netscape and
others.  Please check with your ISP or Web-hosting company if they are running ASP function-
ality modules.  Such ASP functionality should be 100% compatible with NT ASP functionality.
The Boomerang Web and E-commerce hosting services provide NT-based ASP functionality.
You may host your Dynamic Page Web sites or E-commerce sites on the Boomerang Web-
hosting services if you want.  You can reach Boomerang’s Web-hosting services for more
details by going to the site www.boomerangsoftware.com or by sending an email to
webhosting@boomerangsoftware.com.

Image Page
A Web page can have a set of different text, frames, and other objects.  Browsers also support a
special feature for displaying pages which are them selves image files.  These are called Image
Pages.  This program enables you to insert or create a Web page which itself is an image or
graphics.  When you create and insert an Image Page, and place a single image on the page, the
generated site will not have an HTML file.  Instead there will simply be one image file in *.JPG
or *.GIF format.

Insert an Image Page if you want to keep the page simple.  If you later wanted to change the
image on that page, you do not need to open an HTML file and edit it.  You can simply replace
that image on the server or in your generated site.

An image page is also useful in performing slide show-type displays on your Web site.  You can
place a set of buttons in one frame of the screen, and in the other frame of the screen you can
insert many image pages.  Link each button to a corresponding image in the image page frame.
Refer to the chapter on Frame and Frame-Content Overlays for more details on how to do this.
When a viewer clicks on the buttons in one frame, the corresponding images in the other frame
are displayed in the other frame similar to a slide show.
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Page Names

Each page has four different names.  They include:
• Physical File Name .  Displays in Physical Layout.  It identifies the name of the resource

file.
• Logical Name .  Displays in Logical Layout, Navigate Layout, and Frame Manager.  It

identifies the name of the logical resource.

Note:  Resources that are never used with project (that is, placed in the project either as a
Logical page, a FrameSet resource, or as an object on a page) are considered to be
physical resources only. Logical resources only display in Logical and Navigate Layout once
they are placed into the project.

• HTML Title .  Displays in the browser window title bar when the site is uploaded.  The
HTML title also displays in the title bar of WebShop’s Page Editor window to help you
identify the resource that you are looking at.

• Alias .  Displays the alternate name for the page that is used by Banners and Navigation
Bars.  The page Alias can be different for all of the above names if necessary.  This name
can only be displayed and updated from the Properties dialog box.   Alias is most often
used when a multi-line name needs to be inserted rather than a single line name.

These names can viewed together from the Properties dialog box.  However, only Alias and
HTML Title can be changed from this dialog box.  Physical File Name and Logical Name must
be changed from the Site Manager Layouts where these resources are defined.

Naming Defaults.  When you create a page resource four default names are created.  To change
these defaults you must go the Site Manager Layout where these names are defined.  When

Figure 7.6 – Properties Dialog Box and Page Naming

Physical File Name

Alias

Logical Name
HTML Title
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created, the Physical File and Alias default together and the Logical Name and HTML Title
default together.  While initially, it appears that the names default as a group.  They do not.
This has significant implications when you start renaming a page resource and then go to create
a new resource.  The default naming convention is as follows:

Page Type Physical Name Logical Name HTML Title Alias

Plain Page Page1.htm Page1 Page1 Page1

Free Page FreePage1.htm FreePage1 FreePage1 FreePage1

Frame Set Page FrameSet1.htm FrameSet1 FrameSet1 FrameSet1

Dynamic Page DynPage1.asp DynPage1 DynPage1 DynPage1

Image Page Image1.gif Image1 N/A Image1

Default Names and Renaming.  When you change a default name, that default name becomes
available again.  If you change only one of the four default names, the automatic defaults
assigned will, as a group, fall out of synch. When created, the Physical File and Alias default
together and the Logical Name and HTML Title default together.  While initially, it appears that
the names default as a group.  They do not.

For example:  A Plain Page is created and only the Physical name is changed.  The next time a
Plain Page is created, that resource will have default names that, as a group, appear to be out of
synch.

Physical Name Logical Name HTML Title Alias

First time resource Page1.htm Page1 Page1 Page1

Renamed New Page Page1 Page1 Page1

Next time resource Page1.htm Page2 Page2 Page1

For example:  If a Logical Name is changed, then the following will result:

Physical Name Logical Name HTML Title Alias

First time resource Page1.htm Page1 Page1 Page1

Renamed Page1.htm New Page Page1 Page1

Next time resource Page2.htm Page1 Page1 Page2

Physical Names and Logical Names are mutually exclusive (that is, every physical name must
be unique and every logical name must be unique).  HTML title and default Alias do not need to
be unique. You can have more than one resource with the same HTML title and Alias.

Window Naming Convention.  The naming convention used in the Page Editor title bar to
identify the content of an open window is “WebShop <CNQ file name> - Web Site - [<Logical
page name> - <HTML Title>] ”  If more than one copy is open “: <Copy #> ” is added to the
Logical Name and HTML Title.



Chapter 8.
Page Editor–Features and
Procedures

Introduction

WebShop’s Page Editor module is where you will design your Web pages.  From Page Editor
you will design all of your Web pages including Dynamic Pages, Free Pages, FrameSet Pages
and Plain Pages.

Topics covered in this chapter include:
• Launching Page Editor
• Page Editor Functions
• Inserting New Pages
• Page Editor Windows
• Procedures for Using Page Editor
• Features included with Page Editor

Launching Page Editor
To launch the WebShop’s Page Editor module you must specify which page resource file you
want to open.  There are two ways to open the Page Editor:  (1) from the Site Manager—
Physical Layout window (where you select the page resource file from the resource tree), or  (2)
from Site Manager—Logical Layout window  (where you select the Page icon that represents
the page resource file).

To open Page Editor from Site Manager—Physical Layout
• Double-click on an Page File icon from the resource tree.  Page Editor opens and the Web

page contents are displayed.  The page is now ready to be edited.

To open Page Editor from Site Manager—Logical Layout

1. Double-click on a Web Page icon.  Page Editor opens and the Web page contents are
displayed.  The page is now ready to be edited.
Note:  The Page Editor Window uses the title: “WebShop <CNQ file name> - Web Site -
<page resource file name>.”  This naming convention emphasizes that pages are resources
to the overall project file.
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Page Editor Functions

Use Page Editor insert or edit the following Internet objects:

For a Plain Page:  Navigation Bar  (or NavBar), Banner , Form , Table , Image , Horizontal
Rule, Java Applet,  Embedded Object (or Multimedia object), and Text .  You can also use
Page Editor to create links or bookmarks, import text, insert HTML code, create custom scripts
or convert text and graphic objects into template slots.

Note: For more information about template slots, see the chapter titled “Graphic Editor.”

For a Free Page:  Free-Form Object, Text Box, Navigation Bar  (or NavBar), Banner , Border ,
Table , Image , Horizontal Rule, Java Applet,  Embedded Object (or Multimedia object), and
Text .  You can also use Page Editor to group and ungroup objects, align and size objects or
convert text and graphic objects into template slots.

For a FrameSet Page:  Any object available with either Free, Plain, or Dynamic Page by
assigning a FrameSet resource (or what is also called a “Frame Content Overlay”) that is
defined as a Free, Plain, or Dynamic Page.  With FrameSet Pages, you are using Page Editor to
manage and design FrameSet resources that display as independent resource files within one or
more frames.  For more information see the chapter titled “WebShop Frames.”

For a Dynamic Page:  Any object available with Plain Page by creating a Feedback section
that acts just like a Plain page, except that dynamic elements can be displayed in place of text.
With Dynamic Pages, you are using Page Editor to manage and design Dynamic operations that
access a database for communication with your Web site visitor, a third party, or your Web
Master.  Dynamic Pages use specifically designed programming operations that searches,
updates, and displays information contained on a database.  This is the one resource unavail-
able with any of the other Web Page formats.  For more information see the chapter titled
“WebShop Frames.”

Graphic Objects:  You can also use Page Editor to insert or edit the following graphic objects
by creating and editing an image resource file:  Text Line  (or Artistic Text), Image , Fill Pat-
tern , Border , Paragraph Text , Calendar , Chart , OLE, and Drawing .  You also use Graphic
Editor to assign image map links and convert graphic objects or images into template slots.

Note: For more information about these graphic objects and how to insert them, see the
chapter titled “Graphic Editor.”

Inserting New Pages

There are two ways to insert a new page:  (1) from the Site Manager—Physical Layout window,
or  (2) from Site Manager—Logical Layout window.

To create a new page resource from Physical Layout
1. Click on the resource folder that will store the resource file to be created.
2. Right-click and select Create <resource type>  or click one of the page icons on the

Physical Layout toolbar.  The selected resource file is created.
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Note:  The default file names are Page1.htm (for a Plain Page), FreePage1.htm (for a Free
Page), FrameSet1.htm (for a FrameSet Page), and DynPage1.asp (for a Dynamic Page).
You can rename these.  The assigned numbers increment up if a resource file with the same
name exists.

To create a new page from Logical Layout
1. Click on the page icon that will serve as the parent page.
2. Right-click and select New or click one of the page icons on the Physical Layout toolbar.

The selected resource file is created.

Note:  The default file names are Page1.htm (for a Plain Page), FreePage1.htm (for a Free
Page), FrameSet1.htm (for a FrameSet Page), and DynPage1.asp (for a Dynamic Page).
You can rename these.  The assigned numbers increment up if a resource file with the same
name exists.

Page Editor Windows

There are several Page Editor windows that you will use depending upon what type of page you
are editing.

Window Naming Convention.  The naming convention used in the title bar to identify the
content of a open window is “WebShop <CNQ file name> - Web Site - [<Logical page name>
- <HTML Title>] ”  If more than one copy is open “: <Copy #> ” is added to the Logical name
and HTML Title.

Window elements.  Depending upon the window opened the following elements can be seen:

••••• Title bar .  Indicates the CNQ file that is open and the Logical name and HTML Title for the
Page.

••••• Menu bar .  Page Editor menu options are replaced with Page Editor menu options.  Page
Editor options are object sensitive.  Depending upon the object inserted some options
become available while others become unavailable.

••••• Main toolbar .  Appears across the top of the Page Editor window below the Menu bar.

••••• Frames and Page Editor toolbar .  Appears across the top of the Page Editor window
below the Main toolbar.

••••• Window toolbar .  Appears near the bottom of the screen and indicates each of the various
project windows currently open.  This toolbar is unchanged.

••••• Help/Status bar .  Appears at the bottom of the Page Editor window displays a Help tip for
any toolbar button or menu option.  This toolbar is unchanged.

••••• Header and Footer areas .  Appears in the Page Editor window where ever a header or
footer has been specified.  Only appears with Plain Pages.  To assign a Header or Footer to
a page, click Properties and click the Page tab.

••••• New Object toolbar .  Appears across the top of the Page Editor window below the Main
toolbar.

••••• Frame Manager window .  Appears on any Page Editor window when you click on the
Frame Manager button.  Use this area to determine the Frame resources that is currently
active.  When working with a Frame Set Page, more than one Frame resource maybe listed.
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For Plain Page, Free Pages, and Dynamic Page, only one Frame resource will be listed.  To
identify the various Frame resources associated with a Frame Set Page, the Frame Manager
window displays several icons.  Use these icons to access the Frame resource files that will
display within individually defined frames.  For more information about the Frame Man-
ager window, see the chapter titled “WebShop Frames.”

••••• Frame Set toolbar .  Appears only when you click on a Frame Set Page icon or a Frame
icon in the Frame Manager window.  Use this toolbar to assign Visual Settings to a Frame
or a Frame Set, or to access Properties for either a Frame or a Frame Set.  Frames and
Frame Sets  are different from Frame resources.  Frame resources act like Web pages and
display information within a Frame that is defined as part of a Frame Set.  For more
information about the Frame Set toolbar, see the chapter titled “WebShop Frames.”

••••• Page Editor area .  Displays the content of a currently selected Frame resource or Feedback
Section (Feedback Sections only apply to Dynamic Pages or to Frame resource that are
defined as a Dynamic Page).  When no Frame resource or Feedback Section is selected the
area is filled with a crosshatch pattern.  This indicates that the Page Editor area is not
active.  The Page Editor area can be enlarged by toggling off the Frame Manager window.
The Dynamic Page Manager window cannot be toggled on and off.

••••• Dynamic Page Manager window .  Appears only in the Page Editor window when a
Dynamic Page open or when a Frame resources that is defined as a Dynamic Page is
opened on a Frame Set Page.  Use this area to specify the Dynamic operations that will
access a database and display specific data values to a Web site visitor, third party (via
email), or your Web Master (via email).  Unlike the Frame Manager window, the Dynamic
Page Manager window cannot be toggled on and off.
Dynamic Pages use specifically designed programming operations that search, update, and
display information contained on a database.  When using the Dynamic Page Manager
window, programming icons display in the Dynamic Page Manager window to indicate the
dynamic operation that the server will perform and the order in which those operations are
to be performed.  Use these icons to access the dialog boxes necessary to program your
database operations.  For more information about the Dynamic Page Manager window, see
the chapter titled “Dynamic Page Manager.”

••••• Dynamic Page toolbar .  Appears only when a Dynamic Page is open and only becomes
active when a Feedback section is displayed in the Page Editor area.  Icon or a Frame icon
in the Frame Manager window.  Use this toolbar to assign Visual Settings to a Frame or a
Frame Set, or to access Properties for either a Frame or a Frame Set.  Frames and Frame
Sets  are different from Frame resources.  Frame resources act like Web pages and display
information within a Frame that is defined as part of a Frame Set.  For more information
about the Frame Set toolbar, see the chapter titled “WebShop Frames.”

Procedures for Using Page Editor
WebShop is one of the most useful tools on the market for non-programmers and advanced
Web designers who want to create and maintain E-commerce Web sites.  The program is
capable of handling both simple and complex Web sites and E-commerce sites.
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Figure 8.1 – Page  Editor Window for a Plain Page
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Figure 8.3 – Page  Editor Window for a FrameSet Page with Frame Manager Open
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Figure 8.4 – Page  Editor Window for  a Dynamic Page with Frame Manager Open
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Creating, Saving, and Opening
To start a new Web site
1. After you launch WebShop, select File > New .  The New dialog box appears.

Note:  The default Web Site library and templates are displayed.  The first template (the box
with an “X”) is a blank template (that is, without content).

2. To select a library, click the down arrow to the left of the library name.
3. To open a template, double-click on it or select it and click OK.

Important!  All E-commerce projects must start with a template from the E-commerce
category.  A template from another category will not contain “shopping cart” functionality or
“catalog” functionality.  These are hard-coded into the E-commerce templates.  Furthermore,
E-Commerce functionality cannot be added into a non-E-Commerce template at a later
date.  You may achieve similar functionality if you are an expert programmer, know Dynamic
Pages and ASP, and want to program the entire E-Commerce back-end on your own.  This
is not recommended for most users and it is beyond the scope of this documentation.  To
build an E-Commerce site, it is suggested that you start with one of the E-Commerce
Templates provided.

When the new Web site opens, WebShop displays the Site Manager window with the tabs for
the Site Manager–Physical Layout window, the Logical Layout , the Site Manager–Navigate
Layout window , Common Objects , and the Styles windows.  They provide different views of
your site and manage global site characteristics.

To save a project
1. To save a Web site project, select  File > Save or click Save on the Main toolbar.
2. Select the path (that is, drive and folder location) where you want to save the file.
3. In the Save as Type  list box, click the WebShop Files  option.
4. Click Save.  The file is now saved.

You can save the current project as a template.  Project files that you want to save as a template
must placeholders or “slots.”  Creating “slots” will be covered later in this manual.

To save a project as a template
1. Select  File > Save .
2. Click the path (that is, drive and folder location) where you want to save the file.
3. In the Save as Type  drop-down list, click the WebShop Templates  option.
4. Type a file name in the File Name  input line.
5. Click Save.  The project file is saved as a template.

To open an existing project
1. Select  File > Open .  The Open dialog box appears.
2. Select the path (that is, drive and folder location) where the project file is stored.
3. In the Files of Type  drop-down list, click the WebShop Files  option to open a WebShop

file.
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4. Click the WebShop Templates  option to open a WebShop template.
5. Click the file that you want to open.
6. Click OK.   The selected file is opened.

WebShop stores Web sites in a consolidated single file that includes all of the pages and
resources needed to create the Web site.  You only need to open, edit and save one file.

Generating, Viewing, and Specifying a Browser
To generate a Web site

You are not required to physically generate the files and folders traditionally associated with a
Web project.  In fact it is not recommended that you generate the site while you are developing
it.  Instead, open and work with the unified single files (*.CNQ or *.CNT) files which are
created by the program.  This will protect the integrity of your site and keep the graphic
characteristics of all the site elements.  When you have completed designing or editing the site
and are ready to upload it to the server then generate the site.  You can also use the Site Upload
option which automatically generates and uploads the site in a single step.  Follow these steps to
generate the site:
1. Create a folder or directory on your hard drive where you want the site folders and files to

reside.
2. Select  File > Generate Site or click Generate Site  on the Main toolbar.  The Browser for

Folder  dialog box appears.
3. Select the folder where you want to store the generated Web site files.
4. Click OK.   Your Web site files are generated.

Note:  When the “Successfully Generated” message appears, you will have two versions of
your Web project on your hard drive: the special WebShop CNQ file and the traditional
HTML files and folders that other HTML editors use.

WebShop keeps the entire Web site in a unified single file until you use the Generate Site
function.  You cannot open this single file in a browser.  However you can always preview and
test your site with WebShop’s internal browser or the one you set in the preferences.  In
addition, WebShop lets you set other browsers, such as Netscape Navigator and Microsoft
Internet Explorer in the preferences and display the pages without having to generate the site.

Note:  When you generate the site, all graphic objects, overlapped images and other key
elements are converted to GIF or JPEG for browser compatibility.  However, this makes
them lose important characteristics.  For this reason, do not import or read in your gener-
ated site to make changes.  When making changes, always open the unified single file
(*.CNQ or *.CNT) by selecting File > Open, make your changes, and generate the site.

To view a page in a browser
• Select File > Preview  or click Preview  on the Main toolbar.

The browser used in the Preview feature is set in the user Preferences  dialog box.  You can add
or remove different browsers to the list to give you greater flexibility in testing your Web pages.
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To set the browser preference
1. Select  File > Preferences  or click Preferences  on the Main toolbar.  The Preferences

dialog box appears.
2. Click the Browsers  tab on the Preferences  dialog box.
3. In the Browsers list box , click Add  to add a new browser.
4. To modify a browser entry, click the browser in the list and then click Modify.

5. To remove a browser entry, click the browser in the list and then click Delete  to remove the
browser from the list.

6. If you wish to set a particular browser as the default browser, click the browser in the list
and click Default .

7. Click OK.   The browser preferences are set.

Features included with Page Editor
There are several key features that come with Page Editor that you need to learn how to use.
These include:
• Inserting Images and Graphic Objects
• Inserting Horizontal Rules
• Importing Text
• Editing Documents before Importing
• Viewing HTML Code
• Inserting Date, Mail to, and Copyright
• Inserting Embedded Objects
• Inserting Java Applets

Inserting Images and Graphic Objects
Because WebShop offers three different types of Web pages, the process of importing images
will vary slightly depending on the type of page you are working in.  Nevertheless, WebShop’s
Graphic Editor is a consistent tool that is available for all your graphic images on any WebShop
page.

WebShop includes an Acquire feature that lets you add images from peripheral devices (such as
scanners, digital cameras, and others).  This feature lets you create images without first import-
ing the image files into your hard disk.  Depending upon the project, this can save you a lot of
time.

To use this feature, you must have a Twain compliant device installed on your computer.  File >
Acquire  and File > Select Source  are available from either Site Manager or Graphic Editor.
To use Acquire from Page Editor, you must first select the source from which you will be
importing the image.  Once a source device has been selected, the Acquire button found on
Image Properties dialog box becomes active.  As you will see, the Image Properties dialog
box is the principle tool used to insert images on to a Web page.  All images are resource files
which can be generated through different methods.  You can import, use preexisting clipart
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images, use Graphic editor to create an image file, or use Acquire.

To drag and drop an image file from Windows Explorer into Page Editor

This procedure allows you to transport an image directly onto a Web Page.
1. Open Windows Explorer and locate the file you want to bring in.
2. Tile Windows Explorer and WebShop so that both windows are visible.
3. Position the cursor in Page Editor where you want to insert the image.

Note: For Plain Pages, the image is placed whereever you position your cursor.  For Free
Pages, the image is placed in the center.

4. Click and drag the file from Windows Explorer to the currently open Page Editor window.
5. Release the mouse.  The file is inserted into Page Editor and the Physical resource is copied

into Physical Layout.

To drag and drop an open image from a Windows graphic application into Page
Editor

This procedure allows you to transport an image directly onto a Web Page from an open graphic
application.
1. Open the Windows graphic application and open or create an image.
2. Tile the Windows graphic application and WebShop so that Page Editor window and the

application design window are both visible.
3. Position the cursor in Page Editor where you want to insert the image.

Note: For Plain Pages, the image is placed whereever you position your cursor.  For Free
Pages, the image is placed in the center.

4. Select all or part of the open image using the graphic application tools.
5. Click and drag the image selection from the graphic application to the currently open Page

Editor window.
6. Release the mouse.  The image selection is copied into a default image file.

To import a graphic image and place it in a Free Page

This procedure allows you to import an image from disk using the Image Attributes dialog
box.
1. Select  Object > Add > Image  or click Insert Image  on the Insert Objects toolbar.  The

Image Attributes  dialog box appears.
2. Click to place a check mark in the Preview Image  check box if it is not already checked.

In the Image Resources  section, select Import .  The Import  dialog box appears.
3. Use the Look in  section to select a drive or folder where the desired images are stored.

Double-click to import the desired image.  The Image Attributes  dialog box reactivates,
with the desired image previewed.

4. Click OK.  The image is placed in the center of the page.  You may drag the image to any
location.
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To acquire an image using the
Acquire button

This procedure allows you to import an
image using a peripheral device, such as a
scanner or digital camera to create an
image file directly.  To select a data
source, be sure that the data driver
associated with the device has been
installed.
1. Select  Object > Add > Image  or

click Insert Image  on the Insert
Objects toolbar.  The Image At-
tributes  dialog box appears.

2. Click Acquire.   If the selected source
device is open, the device driver
dialog box appears.  If the source
device is unopened or unavailable,
the Acquire dialog box appears.
Select the desired source and click
Acquire .  The device driver dialog
box appears.

Note:  When more than one Twain
device is active (that is, selected and
open on your computer) you are prompted with an error message.  To avoid this, close any
currently opened dialog boxes and close the currently open Twain device driver dialog box.
Begin the acquire procedure again.

3. Using the device driver dialog box, transfer the image to the Boomerang Scanning Utility.
The Name dialog box appears.  Type an image resource file name and click OK.  The
image is imported into WebShop.

Note:  If you selected Acquire Multiple Images, the device driver dialog box remains open.

The Image Attributes  dialog box is one of the most heavily used of WebShop’s various dialog
boxes.  It contains several sections, which combine to control every aspect of the image
placement process:

••••• Existing Resources  tab .  Lets you import an image once and then use it multiple times in
your Web site.  Significantly conserves space on your hard drive since only one image file
is created.

••••• Library  tab .  Displays the library of fast-loading WebShop Clipart images which are
included with the program.

••••• URL tab .  Type in the exact URL of an image located on a remote Web server and it will be
displayed in your Web site with the dimensions defined in the Size section.

••••• Import  button .  Creates a resource file in the Images  folder using the Import dialog box.
Use this dialog box to navigate to image file on your hard disk.  A copy is inserted into the
project file.

Figure 6.2 – Acquire Dialog Box

Figure 6.3 – Name Dialog Box
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••••• Create  button .  Creates a blank resource file in the Images  folder.  When inserted into a
Web page, you must update this file using Graphic Editor to create an GIF or JPEG image
of your own design.

••••• Acquire button .  Creates a resource file in the Images  folder using a Twain compliant
device as the selected data source.  The device driver dialog box appears.  Use the device
driver dialog box to select the image that you want and click OK.

Note:  The device driver dialog box is part of the software that comes with a Twain compliant
device.  For instructions on how to use this dialog box, see the product documentation that
comes with the selected device.

••••• Horizontal  and Vertical size section .  Lets you predetermine the size (in pixels) of the
image to be imported or created.

••••• Preview window .  Lets you display the image before placing it on the page.

••••• Alignment  and Space sections .  They are only activated when images are being imported
to Plain Web pages.

••••• Border  section .  Lets you specify border settings in pixels.

To insert a graphic image in a Plain Page
1. Place the cursor anywhere on the Plain Page workspace where you want to insert the

graphic.
2. Select Insert > Image  or click Insert Image  in the Insert Object toolbar.  The Image

Attributes  dialog box appears.

Note:  The Image Attributes dialog box offers the same functionality as described above,
with the following difference: Alignment and Space sections – for Plain Pages, use the
Alignment and Space options to place the image approximately where you want it.  For
exact placement of imported images, use a Free Page with a free form object box.

Figure 8.5 – Image Attributes Dialog Box
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Uses for Image Attributes Dialog Box
The following section describes how to use the Image Attributes dialog box.

Using the Existing Resources tab

The Existing  Resource  tab lists all the graphic resources that you have in your current project,
enabling you to reuse an image multiple times.  Click the (+) plus sign on the Images folder to
show all of the existing image file names.  With the Preview check box checked, select any
existing image and it will be previewed.  To create a new image file name and assign an image
to that file name later, see “Using the Create button” later in this chapter.

Note:  When you import, create, or use an image from the Existing Resources Library, it is
automatically listed in the Existing Resources tab as well as in the Site Manager–Physical
Layout window.  It becomes part of the resources of your current project.

Using the Library tab

The Library  tab lets you insert an image from one of WebShop’s image libraries.

To insert an image from a library
1. Click the Library  tab.
2. Click the library drop down arrow and select a library.  The library’s images appear.
3. Select a graphic image and click OK.  The library image is inserted.

Using the URL tab

The URL tab gives you the option of placing a graphic using its URL address.  You can do this
only if you know the exact URL address of a graphic image and you want your Web page to
show that image.

To place the URL address for an image
1. Click the URL tab.
2. Type the exact URL and file name of the graphic image in the URL input line.

Note:  You must use the proper URL format.  These include http:// and ftp:// (for example:
http://www.graphicworld.com/animals/ lion.jpg).

3. Click OK and the program will insert a square labeled URL in your Web page.  If you click
Preview , the program goes to that URL and places the image on the page.

Using the Import button

The Import button lets you import a graphic image and place it on the page.

To import a graphic image
1. Click Import .  The Import  dialog box appears.
2. Select the drive and folder where the desired image is stored.
3. Click the image file you want to import.
4. Click OK.  The Image is now listed in the Image Resources  tab of the Image Resources

window.
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5. Check the Preview Image  check box and click the image name.  An image preview
appears.  You may change any of the images other settings such as alignment, size or other
attributes.

6. When done, click OK.  The image is inserted.

Using the Acquire button

The Acquire button lets you Acquire a graphic image from a Twain compliant device.  This
button initiates the acquire operation and if a device driver is currently open, the device driver
dialog box appears.  Use this dialog box to specify the image you want to bring in.  When done,
click OK.  The image is added to Images folder.  To add this image to your Web page, select
the resource and click OK.

Note:  If a device driver is not currently open, the Acquire button is inactive.  To select a
source, go to Site Manager and select File > Select Source.  The Select Source dialog box
appears.  Select a data source and decide if you want to acquire multiple images, and click
OK.  The Acquire feature is now active.

Using the Create button

The Create  button lets you create and compose your own graphic image.

To create and compose your own graphic image
1. From the Image Attributes  dialog box, select the Existing Resources  tab and double-

click the Image  folder.
2. Click Create  and a new file name is added to the folder.  If you like, you can change the

name of this file later in the Site Manager–Physical  Layout  window.  For now you must
accept the default name.

Note: The default file names are Image.gif, Image1.gif, Image2.gif, etc.

3. Click OK.  A Blank Image  box 100 x 100 pixels appears on the Web page.
4. Double-click the blank image box to launch Graphic Editor  and initiate an “in-place” edit.

Note:  To launch Graphic Editor and initiate a full edit, click on the blank image box once,
right-click and select Object > Edit.

5. Click Page Setup  on the Main toolbar.  The Image Properties  dialog box appears.

Image Properties Dialog Box

Use the Image Properties  dialog box to define the size of the image (and the image worksheet
area), the format of the image and the background color.  This dialog box also appears under the
Image tab on the Properties dialog box when an image resource is selected.   In the Size
section, the current default size appears.  You may change the size if you wish.  In the File
Format  section, GIF is selected by default by WebShop with a color count of 256.  This is the
highest value for a GIF, which can be expected to load quickly for most browsers.  The Back-
ground Section  provides three choices, one of which is “Make it transparent .”  If you were
using a photograph or a detailed artwork, you may want to use JPEG format instead.  JPEG files
provide crisper and cleaner images on the Web page.  However, they are larger in size and take
longer to be viewed by the viewer.
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To specify an image in JPEG format
1. In File Format, click the JPEG radio button.

The JPEG Control fields become active.
2. Click the Encoding Method radio button.
3. Decide what you want to do:

• For smaller files that load all at once, select
Sequential (quality may be affected).

• For progressive files that load progres-
sively, select Progressive (quality should
not be affected).

Note:  Not all browsers can display progressive
images.

• For files saved in optimal standard format,
select Optimize.

4. To control the file size, specify a Quality
Factor from 1–100.

Note:  The lower the setting the smaller the file.
Smaller files result in lower image quality and
vice versa.

5. When done, click OK.  The image properties are set.

To complete the Create Image process
1. For this example, select Make it transparent  and click OK.  Use the Graphics Editor to

create your new image file.  (See the chapter titled “Using Graphic Editor” for more
information).

2. When you are done creating the image, click once outside the boundary of the new image
(when completing an “in-place” edit), or click close the Graphic Editor window (when
completing a “full” edit).  The Web page reappears.  The new image is in place.

Note:  Rather than closing the graphic window (when completing a “full” edit), you can
minimize the window if you like.

3. Click on the image once to select it.  Select Format > Object > Properties  or right-click
and select Object > Properties.   The Image Attributes  dialog box reappears.  If Preview
image  is enabled, the new image you created appears in the preview layout.  The new
image file name is listed as a resource in the Existing Resources  tab.

4. Check the Preview Layout  check box to view the alignment of the image and the text of
the page.

5. Check the Size check box if you want to stretch the image.  Type the new size in pixels.

Note:  It is not recommended that you do this.  Usually stretching raster graphic images after
placing them on the Web page degrades the image quality.

6. If you want to add transparent padding or spacing around the image that separates the
image from the text, then check the Space  check box.  Type  the spacing in pixels in the
Horizontal  and Vertical  fields.

Figure 8.6 – Image Properties Dialog Box
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7. To add a border around the image, check the Border  check box.  Type  the size in pixels
for the border.

8. The default alignment for the image is Baseline .  To select a different alignment click
Alignment  check box and select the type of alignment you want.

9. You may insert alternate text.  This is the text that a browser will display in place of the
image if the image is missing.  Check the Alternate Text  check box and enter the text you
want.

10. Click OK to continue.

Inserting Horizontal Rules
You can insert a Horizontal Rule, or divider line, into a Web page.  They are often used to
divide the Web page into sections and improve the visual look of the page.  With WebShop, you
can insert simple rules, three dimensional rules, and graphic image rules.

To insert a horizontal rule
1. Place the cursor on your Web page where you want to place the horizontal rule.
2. Click Horizontal Rule  in the Insert Objects toolbar or select  Insert > Horizontal  Rule .  A

Horizontal Rule is inserted in the page.  To change the style of the rule, double-click on it.
A bounding box is placed around the rule drag one of the center handles and make it
thicker.  Double-click inside
the rule.  The Horizontal
Rule Style  dialog box
appears.

3. Check the Custom  radio
button, and click Edit .  The
Horizontal Rule  dialog box
appears.

Note:  The Style section
gives you the three options
for horizontal rules: Simple,
3D Shade, and Image.

4. Click the style option for the
type of Horizontal Rule you
want to insert.

5. To insert a graphic image as
a rule, click the Image
Option  button.  The Window on the right displays different tabs and the dialog box adds
the Import  and Create  buttons.  You may use any graphic image from the set of available
resources in your current Web project, choose from the many libraries included with the
program.  You may also import or create an image.  This window operates exactly like the
Graphic Image  dialog box.

6. In the Align  section of the dialog box, check and set one of the Alignment  radio buttons.
This will align and justify the graphic image horizontally on the line of the Web page.

7. The Width Style  and Size sections enable you to specify the width and thickness of the

Figure 8.7 – Horizontal Rule Style Dialog Box
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horizontal rule.  They also
set the units of measurement
used, such as pixels or a
percentage of the page
width.

8. To select a color for the
horizontal rule, check the
Color  check box.  The Color
dialog box displays the color
options and color libraries in
the sample window.

9. Choose one of the colors
displayed.  If you had
installed the color libraries
during the initial program
installation on your PC, then
the program will list many
groups of pre-made color
palettes.  To use any of the
color libraries, click the drop
down box and choose from
one of the listed color libraries.

Remember!  There are safe color libraries that you can use.  These are special color
palettes created by us and built into the program.  They take into account the Netscape
Navigator and Internet Explorer color palettes.  If you use one of these color safe palettes,
your pages will have a better chance of being displayed on these browsers without color
dithering.

10. When you have made all your selections, click OK to continue.  The horizontal rule is
inserted in the Web page.

11. If you want to edit a it and change its width or other attributes, select it on the Web page
then double-click on it.  The Horizontal Rule Style  dialog box appears.  Make your
changes and click OK to continue.

Importing Text
You may import text and place them on the Web pages.  The program supports a number of
data formats.  It can import ASCII, Notepad, Windows Write, and Rich Text Format (RTF) file
documents.  It can also import any document in Microsoft Word if you have the corresponding
version of Word installed on your computer.  If you would like to import a text document,
which is not in one of the supported formats, you must convert it to one of the supported
formats in another application.

You can import text documents from any Web page.  The imported text is placed in your
current page.

To import a document
1. Place the cursor in the Web page where you want to import the document.

Figure 8.8 – Horizontal Rule Dialog Box
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2. Select Insert > Text  or click Text  on the Insert Object toolbar.  The Text Import  dialog box
appears.

3. Click Files of type  drop-down arrow.
4. Choose the format you want to import.
5. Type the name of the file in the File name field or search and find the file using the Look

in  window and the File Explorer  tool of the dialog box.
6. You may view or edit the contents of a file before you import it.  Refer to the next section

for more detail.
7. Use the scroll bars to scroll and view the file.  Use the Find  button to search for items in the

file.  When you are ready, click OK to import the file.

Editing Documents Before Importing
The program lets you edit the document before you import it.  This useful feature is very
important in case you are working with a large document or archive.  Most of the time you may
not want to import all the document but only certain parts of it.

To edit a document before importing it
1. Find the document and click it to enter the name in the File Name  field of the Import  Text

dialog box.
2. Check the View and Edit  check boxes in the File Contents  section.
3. Scroll and use the Find and Replace  buttons to edit the document.  You may also select

text and delete it.  You may also enter new text right in the File Contents  window.
4. When you have selected parts of the document or edited it, click OK to continue.  The

document is placed in the current Web page.

Search and Replace
You can search or search and replace words or text in your Web page.  To do this, place the
cursor in the beginning of the page and select Tools > Find .  To replace text, select Tools >
Replace .

The search operation includes a number of options that you can choose.  These include:

••••• Match Whole Word

••••• Match Case

••••• Search Direction  (up or down from cursor position)

Viewing HTML Code
To view the HTML source code of a page
1. Click Preview  on the Main toolbar.
2. When the browser displays the current Web page, right-click anywhere in the page area.
3. Click View Source  from the drop-down menu.  The HTML source code of this page is

placed in a Notepad  window.  You may view and print it if you want.

Any changes you make to the HTML code in the Notepad  window are not inserted in the
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WebShop file.  If you want to edit HTML source and perhaps write your own special HTML
code, you must use the Insert HTML feature in WebShop.

Inserting HTML Code
Insert your own HTML code in any Web page.  This is useful if you know HTML language and
you want to write special HTML code for a special feature that WebShop does not have.

To insert your own HTML code
1. Place the mouse on the Web page where you want to insert the HTML code.
2. Click Insert HTML  on the Insert Objects toolbar.  The Insert HTML  dialog box appears.
3. Type the HTML code that you like.
4. Click OK to continue.  The HTML source code you entered is inserted in the Web page at

the cursor position.  The program places the HTML symbol at the location on the page
where the code is inserted.

When you save this project, all HTML source code sections that you have entered are saved as
well.  When you open a project that has such additional HTML source code, the code is opened
as well.  You can view and edit it if you want.

To view the Web page, click Preview  on the Main toolbar.  The browser will open the page and
display the page and the results of the HTML source code you inserted.

When you generate the site, the program inserts your special HTML source code sections in the
overall source code pages that it generates for the entire Web site.

It is important to note that the automated system that WebShop provides helps to eliminate
errors.  The program generates all the code necessary instead of you having to create it.  It is not
uncommon to find Web pages on the Internet that have errors in the HTML source code.  These
errors can create problems to viewers and may prevent a page from displaying properly.
WebShop creates exact HTML code compliant with HTML 4 standard every time it creates or
generates your site.

Inserting Date, Mail to, and Copyright
While creating or editing Web pages, you may want to insert the current date, insert a mail-to
address, and add a copyright notice.  You can either type these in manually or use the insert
special text tool.  To use the tool, place the cursor where you want to insert the text or mail to
item.  Select Insert > Copyright or Mail to or Date or, alternatively, click Special Text on the
Insert Object toolbar.  The Special Text  dialog box appears.

To insert the current date
1. Click Date tab and select the date from the list of available formats listed.
2. Click OK to insert the current date in the page.

When you create Web pages, you may want to place your Internet address on the Web page.  A
typical example is when you explain certain choices to the viewer and ask that the viewer
respond to this information (with feedback, questions, or requests for more information) via
electronic mail letters.  You may use the mail to feature in such cases.
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To insert a mail-to feature
1. Click the Mail  tab in the Special Text  dialog box.
2. Type the address you want the email responses to be sent to in the Email address field.
3. Type the text that is the link to this email in the Enter Link  text field.
4. Click OK to continue.  The mail-to linked text is inserted in your Web page.

To insert a copyright notice

Placing Web pages on the Internet for the public to read and view is a kind of publishing.  To
protect your designs and documents from copyright infringement or from free duplication and
use by unauthorized personnel, you may want to place a copyright statement on your Web
pages.  Copyright statements are in the form of: © 1998 Copyright Company Name, Inc.

1. Click the Copyright  tab in the Special Text  dialog box.
2. Type the copyright text that you want.
3. Click OK to continue.  The copyright statement is inserted in the page.

Note:  This dialog box will use the last text you entered as the default for the copyright text.

Inserting Embedded Objects
You can insert Video (*.AVI), Sound (*.WAV, *.MID, and *.RMI), Animated GIF (*.GIF) and
other user defined resources in your Web pages.  These are referred to as embedded objects
since they are embedded in the Web page.

To insert an embedded object in a
Web page
1. Place the cursor where you want to

insert the object.
2. Select Insert > Embedded Object or

click Embedded  on the Insert Object
toolbar.  The Embedded Object
Properties  dialog box appears.

3. In the Type  section, check one of the
radio buttons to select the type of
embedded object you want.

Note:  If your current Web site project
has any embedded objects, they are
listed in the Site Manager–Physical
Layout window or in the Select Embed-
ded Object section of the Embedded
Objects Properties dialog box.

4. Select one of the objects listed in the window or click Import to import another object.
5. To place a border around the embedded object, check the Border  check box and enter the

values in pixels for the border thickness.
6. For sound (*.WAV, *.MID, and *.RMI) objects, you can enter the volume level in the

Figure 8.9 – Embedded Object Properties
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Value  field.
7. If you do not check the Size check box, the embedded object appears in the browser in its

original size.  If you want to change this size, check the Size check box, and enter the
Width and Height  (in pixels) that you want.

8. Any embedded object may be surrounded with a padding of transparent space if desired.
The surrounding text of the page is separated from the embedded object by this padding.
To insert a spacing amount, click Spacing  check box and enter the Horizontal  and Vertical
padding spaces in pixels.

9. If you want the embedded object to have a certain alignment or justification, click the
Alignment  check box and select the alignment options.

10. Click the Autostart  check box to set the embedded object to start automatically as soon as
the page appears in the browser.

11. Click the Loop  check box to set the object to play continuously.
12. Click the Hidden  check box to hide the embedded object symbol or control in the browser.

The browser will not display the object’s hidden controls.  If you want the embedded object
to start playing automatically when the page appears in the browser then you must also
click the Autostart  check box.

13. Click Import  to import from disk the multimedia files that you want.
14. If you are using a user defined resource and you need to insert a parameter string, then

check the User Defined  radio button and the Parameter List  check box and enter the
string.

Inserting Java Applets
Java Applets are script codes that you can insert directly in your Web pages.  They provide
functions that standard HTML code does not.  You can use Java Applets to display animation
files and produce sound.  You must have the code for the Java Applet to use this feature.

To insert a Java Applet object in a Web page
1.  Select Insert > Java Applet

or click Java  on the Insert
Object toolbar.  The Java
Applet Properties dialog
box appears.

Note:  If your current Web
site project has any Java
objects, they are listed in the
Site Manager–Physical
Layout window or in the
Class File section of Java
Applet Properties dialog box.

2. Select one of the Java
Classes  listed in the
window and click Import .

3. Type the values for the
Figure 8.10 – Java Applet Properties Dialog Box
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horizontal and vertical sizes (in pixels) of the Applet.
4. Type  all the name-value pairs needed or used by the Applet in the Parameters  window.

Note:  If you do not enter these parameters, the default values are used.  If you want to
create your own Java Applet, you must first write a “*.JAVA” file, then translate it into a
“*.CLASS” file with a Java translator, then you can include your Java Applet in the Web
page.

5. A Java object may be surrounded with a padding of empty space.  The surrounding text of
the page is separated from the Java object by this padding.  To insert a spacing amount
check the Spacing  checkbox and enter the Horizontal  and Vertical  padding spaces in
pixels.

6. If you want the Java object to have a certain
alignment or justification, click the Alignment
check box and select the alignment you want.

7. You can insert a string of text for the Java object.  If
the browser cannot find the Java object, it will
display the string instead of the Java object.  It is
also displayed as quick tips help when the viewer
using the browser places the mouse on the Java
object.  To insert a string text, enter it in the
Alternate String  field.

Inserting Java Scripts
To insert Java Scripts
1. Place the cursor on the page where you want.
2. Select Insert > Java Script or click Insert Script  on

the Insert Object toolbar.  The Insert Script  dialog box
appears.

3. Type the parameters of the script
4. When done, click OK.  The Java Script object is

inserted.

Remember!  You can always use the Insert HTML
menu option to insert other types of scripts such as VB
(Visual Basic) scripts.

Inserting Banners
Banners are context-sensitive objects, as are NavBars.
That means that when you insert them they “pick-up” their
text from the page on which they are inserted.  Specifically,
these Banners and NavBars display the Logical page name.
To change the display text associated with a banner or a
NavBar button, you can either (1) change the Logical
Name or (2) change the page Alias .

Figure 8.12 – Banner Style Dialog Box

Figure 8.11 – Insert Script Dialog Box



Chapter 8. Page Editor–Features and Procedures

WebShop 2000 User Guide ◆   ◆   ◆         8–23

BASIC FEATURES

To insert a horizontal banner
1. Place the cursor on the page

where you want to insert the
banner

2. Select Insert > Banner  or
click Insert Banner  on the
Insert Object toolbar.  A
default text banner is placed
on the page.

3. Double-click on the default
banner to change it.  The
Banner Style  dialog box
appears.

4. Make your edits as you like.
5. When done, click OK.

To insert a graphic or customized banner
1. Double-click on the banner to wish to change.  The Banner Style (1)  dialog box appears.
2. Check the Custom  radio button and click Edit .  The Banner Style (2)   dialog box appears.
3. Select the Only Text  or Image With Label  radio buttons.
4. Make your design changes as you like.
5. When done, click OK.

Inserting Navigation Bars, Forms, Tables, Links and other major WebShop objects are de-
scribed in later chapters.  Please refer to these corresponding chapters for more details.

Inserting Component Objects
Components Objects are special objects that contain several files and perform complex func-
tions.  WebShop comes with several ready-to use components.  These include: clocks, counters,
and rolling text.

Note:  Not all components are compatible with all browsers.  Be sure to test the components
in the browsers that you expect your target audience to be using.

••••• Clock .  Lets you display the current time as using the visitor’s computer time settings.  You
can adjust the size of the object by resizing the Java Applet that is inserted.  You can also
adjust the background color and the text color.

••••• Counter .  Lets you display the current page / site visitor count. Every time a visitor opens a
page (or refreshes the screen display), the counter increases by one. You can adjust the size
of the object by resizing the Java Applet that is inserted.  You can also adjust the number of
digits that appear and the delay time associated with refreshing the counter display once the
page is open.

••••• Rolling text .  Lets you display rolling text that you specify.  You can adjust the following
variables: font size, space between text lines, speed (in pixels per second), and Fade Zone
the top and bottom areas where the text fades out as it “rolls” through the stationary display
box.

Figure 8.13 – Banner Style Dialog Box
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Note:  Component objects use resource files that when inserted are stored in the CGI-Bin
folder.  Be sure not to delete
these objects by accident.

To insert a component
object
1. Place the cursor on the

page where you want to
insert the component
object.

2. Select Site > Insert
Component .  The Insert
Component dialog box
appears.

3. Select a Component
Library  using the drop-
down arrow.

4. Double-click on the Site
Component that you want
to insert.  A Java object
appears.

5. To adjust the component
operation, double-click Java object.   The Java Applet Properties  dialog box appears.

6. Click on the parameter value that you want to adjust and enter a new value.

Note:  Only Advanced users will want to adjust a component’s parameters.  Most users can
insert these objects without significantly adjusting the parameters.  For scrolling text objects,
double-click the Java Object to insert text.

7. When done, click OK.  The component object is inserted.

Figure 8.14 – Insert Component Dialog Box



Chapter 9.
Web Site Wizard

Introduction

WebShop 2000’s Web Site Wizard  helps you create Web sites easily.  These sites are automati-
cally generated using a step-by step dialog box procedure.  Once created, you add the specific
content that you want to display using the Web pages generated by the Wizard.  These Web
pages make use of many powerful features, such as cascading style sheets, banners, navigation
bars, and frames.

Topics covered in this chapter include:
• Using the Web Site Wizard
• What did the Wizard Create?
• Investigating the Frame Resources Created
• Saving Your Work
• Completing the Web Site

Using the Web Site Wizard

The Web Site Wizard is a special feature that can only be launched by creating a new project
file.  To use the Web Site Wizard, start a new project using the New dialog box.

To start a new Web site project using the Wizard
1. After launching the program, select the File > New  menu options, or click the New button

on the Main toolbar.  The New dialog box appears with the “Web Site” tab already se-
lected.

2. Click Wizard .  The first dialog box for the Web Site Wizard appears.

To run the wizard, complete each of the six required dialog boxes.  To cancel out of the Wizard,
click Cancel at any time.  To access online Help with any of the dialog boxes, click Help .

Step 1.  Select the type of the site to be constructed.
When first launched, the dialog box Step 1 of 6  appears.  In Step 1, select the type of the site to
be constructed.
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Your options are:

••••• Personal.   Use this option to present information about yourself on the Web.

••••• Corporate.  Use this option to present information about a company’s products and
services.

••••• Photo Gallery.   Use this option to create a Web site dedicated primarily to photographs.

••••• Article.  Use this option to create a Web site for an article that includes a table of contents
and page enabling navigation.

To select the type of the site to be constructed
1. Click the radio button for the site that you want.
2. Click Next .  Dialog box Step 2 of 6  appears.

Step 2.  Select the pages to be constructed.
In Step 2, select the pages for the site to be constructed from a list of available pages.  Make
sure there are check marks in boxes next to the pages you want to include.  Clear the check
marks for pages you do not want created.

The list of available pages depends upon type of site selected.

••••• Personal site contains pages suitable for an individual Web site, such as Interests, Photos,
and Resume.

••••• Corporate sites contains pages such as, Guest Book, News, Products, and Job Openings.

••••• Photo Gallery  sites contains a Photo List page followed by pages for photos (one page per
photo).  Specify number of the photos (and pages, respectively) in the site.  These pages are
generated but are not listed in the dialog box.

••••• Article sites contains the following optional pages: Contents, Glossary, and pages with
chapters of the article.  Specify number of the chapters (and pages, respectively) in the site.
These pages are generated always, and are not listed in the dialog box.

Note: The Home Page is automatically generated for all sites in addition to the listed pages.

To select the pages to be constructed
1. Click the pages that you do not want to have generated.  The default check mark is re-

moved.
2. Click Next .  Dialog box Step 3 of 6  appears.

Step 3.  Decide if you want to use frames.
In Step 3, decide if you want to use frames in the site.  Frames divide browser’s window into
separate areas.  Each frame can display different content.

For example, you can have a menu list of links that point to one frame and have it’s content
change, leaving the other frame that contains the menu list of links unchanged so a viewer can
make additional selections.  Frames are very useful, and make sites look nicer, but some people
do not like frames because they may have older browsers which do not display frame-enabled
content.   Frames require additional HTML files, which are generated when you choose to use
frames.
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Figure 9.1 – Web Site Wizard Dialog Box (Steps 1 and 2)

Figure 9.2 – Web Site Wizard Dialog Box (Steps 3 and 4)
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To turn on or off the Frame feature
1. Decide if you want to use frames.

To turn off the frame feature, click the No (without frames) radio button.
To turn on the frame feature, click the Yes (with frames) radio button.

2. If you selected frames, decide if you want to use frames that have visible or invisible
borders by placing or clearing the check mark from the Visible borders  check box.

3. When done, click Next .  Dialog box Step 4 of 6  appears.

Step 4.  Select the design elements you want.
In Step 4, select the Web design elements you want to be created with your Web site.  Your
options are:

••••• Banners. Use this option if you want a banner placed at the top of each page.  Banners are
context-sensitive elements (that is, their text display depends upon the page where they are
inserted).  Most often banners include an image and the name of the page.  The name is set
automatically when the pages are placed into the site.

••••• Navigation Bars.  Use this option if you want a Navigation Bar placed at the bottom of
each page.  Navigation Bars are context-sensitive elements providing navigation through
the individual pages of your Web site.  When added to your Web site, navigation bars are

Figure 9.3 – Web Site Wizard Dialog Box (Steps 5 and 6)
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automatically updated.  When you add a page, it’s associated link is automatically added to
all existing Navigation Bars that are defined for that type of page.

Note:  Navigation bars can be set to provide links to only certain types of pages. For more
information, see the procedure on inserting Navigation Bars.

••••• Headers and Footers. Use this option if you want to generate placeholders for information
at the top or bottom of the pages created.  Headers and Footers can contain context-
sensitive elements (such as, banners, navigation bars) that automatically change depending
upon the page where they are inserted.

Once you have selected your design elements, select one or more of the layout options.  Unless
specifically instructed otherwise, the Wizard places the Banner inside the Header and NavBar
inside the Footer of the Web page.  All of your design elements and layout selections are
graphically previewed in the Preview area.

To select the design elements you want
1. Decide if you want to exclude the use of any design elements listed by clearing the check

mark from the check box next to each.

Note: By default, all four design elements are selected.  If you make a change, the preview
area is updated.

2. Decide if you want to exclude the use of any layout options listed by clearing the check
mark from the check box next to each.

Note: By default, both of the layout options are selected.   If you make a change, the preview
area is updated.

3. When done, click Next .  Dialog box Step 5 of 6  appears.

Step 5.  Select the site style.
In Step 5, select the cascading style sheet that you want to use with your Web site.  This
selection defines the visual appearance of your Web site and many of its associated elements.
The specified site style predefines elements such as banners, navigation bars, text font, color,
size, background color and/or image.

To select a site style
1. Select a Library from the Library drop-down list.  Library listing is updated.
2. Select a Style from the library listing.  The selected style is displayed in the preview area.
3. When done, click Next .  Dialog box Step 6 of 6  appears.

Note:  To customize the selected style, go to Site Manager–Styles after the Wizard has
completed your Web pages.  The Wizard places the style you select into Site Style with the
name “Default.”

Step 6.  Review the page listing.
In Step 6, you can review the page list and decide if you want to include the specified pages, or
you can change the default page name associated with each page created.
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••••• Modify name  field displays the name of the Logical and HTML page name that will be
generated for the selected page.  This is the name that will appear in your Banner or
NavBar.

••••• Corresponding File name  field displays the name of the physical file name that will be
generated for the selected page.

Note:  The Index file is a special case.  The physical file name must be “index,” which is not
useful as a logical name.  In this case the Wizard prevents the physical file name “index”
from being updated.  Also, when you create a frame-enabled Web site, the Home Page
becomes a FrameSet page and the assigned page name does not appear in the Banner or
in the Navigation bar.  To specify a new name for the automatically generated  “Main Page”
(which is the Home Page that displays in the browser), see the topic “Investigating the
Frame Resource Created” later in this chapter.

To add or remove a page
1. Click Back and go to the dialog box for Step 2 to insert your corrections.

• To exclude the use of any page listed, clear the check mark from the check box next to
each.

• To include the use of any page listed, place the check mark into the check box next to
each.

2. When done, click Next until dialog box Step 6 of 6  reappears.

To change the page name assigned to a page
1. Select a page from the list.  The Modify name  field and the Corresponding File  name field

are updated.
2. Type a new name in the Modify name  field.  The Corresponding File  name is updated

simultaneously.
3. When done, click Finish .

What did the Web Site Wizard Create?

In its simplest form, the Web Site Wizard generated a Web page for each page you specified.
These pages do not have content other than the design elements you asked to have inserted
(such as, a banner, NavBar, header or footer).   You will still need to enter the content that you
want displayed using Page Editor as you would with any Page.  More specifically, the Web Site
Wizard creates a series of resources that, depending upon whether Frames were used, appear in
Logical Layout in one of two ways.

When done
When done, the default screen display appears.  If you accept the all defaults, including no
frames and no specifically assigned style, your screen display will appear as seen in Figure 9.4.
If you specify frames (without a border) and assign a style from the style library, the screen
display appears as shown in Figure 9.5.

Note:  Depending upon the specific style you select, your screen may look different.
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Figure 9.5 – Default Window Display for a Web Site with Frames

Figure 9.4 – Default Window Display for a Web Site without Frames
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Figure 9.7 – Default Window Display for a Web Site with Frames (Frame Manager Open)

Figure 9.6 – Default Window Display for a Web Site without Frames (Frame Manager Open)
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Page Defaults
For a Web site without Frames, Logical Layout displays a two-tier site, including one Home
Page and several sibling pages.  Each page created is in Plain Page format.

The Logical name, Physical File name (without the extension), and HTML title are the same.
The Alias field defaults to blank for all sibling pages.

••••• Logical name  is used with navigation bars, banners, and in the window title bars during
site design.  These names are displayed in Logical Layout .

••••• Physical File name  is the name of the physical resource file that will be generated and
placed on the Web-server.  These names are displayed in Physical Layout .

••••• HTML title  is the name that will appear in the browser title bar when the page is opened.
This title is displayed in the Properties dialog box.

••••• Alias  is the alternative name that will appear in navigation bars and banners, only when the
Alias feature is enabled. This Alias name is displayed in the Properties dialog box.

 For a Web site with Frames, Logical Layout displays a single page site that includes individual
frame resources for each of the individual pages requested.  The Home Page is a FrameSet page
that includes two frame areas “Navigation” and “Main.”

The Logical name, Physical File name (without the extension), and HTML title are the same for
all resources created.   The Alias field defaults to “Page1” for all FrameSet page resources
except “Main Page.”

Frame Page Defaults
If you specify frames, the Navigation bar inserted into the left side frame uses a default style
Navigation Bar no matter what style you specified for the entire site.  By using Frames, the
Wizard automatically creates two additional pages not listed in your page list: Navigation  and
Main Page .  Navigation is the left side of the screen display.  By default, the Wizard inserts a
navigation bar that links all of your pages together whether or not you choose to have a naviga-
tion bar appear on any of the other pages.  This default Navigation Bar always uses Navigation
style, which is specifically created for this Frame Page resource.

To change the style for the default Navigation Bar created by the Wizard
1. Double-click on the default navigation bar.  The Insert Navigation Bar dialog box appears

with the Specific Style Navigation selected.
2. Click the Specific Style  drop-down arrow and select Default .
3. When done, click OK.  The navigation bar is updated.

The orientation applied to the default style navigation bar is horizontal.  When placed into the
left side frame, much of the navigation bar disappears and is visible only when the scroll bar is
used.  Most people will want change its orientation to vertical, so that the entire navigation bar
can be seen.

To change the orientation of the Navigation Bar created by the Wizard
1. Double-click on the default navigation bar.  The Insert Navigation Bar dialog box appears

with the Specific Style Default selected.
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2. Click the Custom radio button.  The Edit button becomes active.
3. Click the Edit button.  The Navigation Bar Style dialog box appears.
4. Under NavBar Button Groups , select Sibling buttons .  The item is highlighted and the

check mark remains in the check box.
5. Under NavBar Orientation , select Vertical  and click OK.  The Insert Navigation Bar

dialog box reactivates.
4. Click OK again.  The navigation bar is displayed with a vertical orientation.

Investigating the Frame Resources Created

By selecting Frames, the Wizard creates one FrameSet page with a separate Frame Resource
Page for each page requested.  To understand this, click Frame Manager on the Frame and
Page Editor toolbar.

For a Web site without frames, the screen display appears as shown in Figure 9.4.  For a Web
site with frames, the screen display appears as shown in Figure 9.5.

By choosing a Web site with frames, two additional Frame Resources are created:  Navigation
and Main Page .

For a FrameSet page to work, two things must be specified: A frame area and something to
display in that area.  As generated, two frame areas were
created:  “Navigation” and “Main.”

Frame Manager Icons
Frame Manager displays different kinds of icons and to
“read” the Frame Manager window display, each icon
must be interpreted.  Frame Manager operates like
Windows Explorer; frame resources can be collapsed
into their associated frames, just as files can be collapsed
into their associated folders.

When collapsed to just its frame elements, the FrameSet
page generated by the Wizard appears as shown in
Figure 9.8.  This is the Frame Manager representation of
the Frame Page structure.  No presentation “content” is
defined by any of these elements.  By right-clicking on a
frame icon and selecting Properties , you can define
scrolling and resizing attributes for a frame.  By default,
Frames inherit their page style from the FrameSet Page,
in the same way that Sibling pages inherit their style
from a Parent page.  These are important defaults to
keep in mind.

When expanded individually (as shown in Figure 9.9),
each frame has at least one “display page.”  These
Frame Resource pages are used to display content.

Figure 9.8 – Collapsed Frame Manager

Figure 9.9 – Expanded Frame Manager
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When the Wizard generates a Frame-enabled Web site, it creates a default window with two
frames and then creates the necessary frame resources to display your content.  However, two
additional frame resources are created: Navigation and Main Page .  These were not specified
when you completed the Wizard.

••••• Navigation .  This is the Frame Resource displayed in the Frame area “Navigation.”  And,
like any other page resource, it  has a Logical name, a Physical File name, an HTML title
and an Alias.

••••• Main Page .  This is the Frame Resource displayed in the Frame area “Main.”  And, like
any other page resource, it too has a Logical name, a Physical File name, an HTML title
and an Alias.

Both Main Page and Navigation are Plain Pages.  You can add content to each of these pages
using the standard tools available with a Plain Page.

Context-Sensitive Banners and NavBars
When inserted, Banners and NavBars “pick-up” their text from the name of the page in which
they are inserted.  Specifically, these elements display the Logical page name.  To change the
display text associated with a banner or a navigation bar button, you can either (1) change the
Logical Name for the page from Logical Layout, (2) change the Logical Name for the frame
resource from Frame Manager, or (3) change the page Alias .  When the Wizard generates a
frame-enabled Web site, it generates Frame Resources that do not display in Logical Layout.
(Only Page resources display, not frame resources associated with a FrameSet Page.)  Therefore
to change the display text associated with a banner or a navigation bar you must change the
Logical Name from Frame Manager, or the page Alias .  Alias is most often used when a multi-
line name needs to be inserted rather than a single line name.

To change the display text associated with a banner or a navigation bar using the
Alias name feature

From a FrameSet Page with the Frame Manager window open:
1. Click the page icon for the page you want to change.
2. Right-click and select Properties .
3. Click the Alias check box to turn on this feature.  The associated input box becomes active.
4. Click the input box and type the text that you want to appear in the Banner or NavBar

button.
5. When done, click OK.  The Alias feature is turned on and the context-sensitive display text

is updated.

Saving Your Web Site

Be sure to save your work, by selecting File > Save .  The Save As  dialog box appears.  Save
your file as an Internet Design Shop Gold File.



Part 3
SPECIFIC FEATURES

This part of the User Guide examines some specific features of WebShop that you might want
to use.  These feature require somewhat more advanced expertise; however, even a novice Web
site designer will be able to master these features given sufficient time and practice.

Part 3 includes:
• Links, Image Map Links, Bookmarks, and NavBars
• WebShop Tables
• WebShop Frames
• WebShop Forms
• Dynamic HYML and Free Page Design
• Graphic Editor
• Dynamic Page Pages and ASP Technology



Chapter 10.
Links, Image Map Links,
Bookmarks, and NavBars

Introduction
Topics covered in this chapter include:
• Inserting and Deleting Links
• Internal and External Links
• Inserting Bookmarks
• Navigation Bars (NavBars)
• Linking NavBars to Frames in Other Windows

Inserting and Deleting Links
You can insert links in your pages to enable the user to navigate to other pages of your Web
site.  You can place links on text, graphic images, and Multimedia objects.  The method is the
same for all objects.

The following example describes how you can place a link on a text in your Web page.  We will
use one of the example files on your program CD.

To insert a text link in a page
1. Click New.   The New dialog box appears.
2. Click Wizard .  The Web Site Wizard  begins.
3. Complete the Wizard accepting all  defaults.  Site Manager  opens on the left and the Home

Page opens on the right.  This is the default screen display.
4. Maximize the Home Page  window on the right.
5. Type words “ our company”  and select them.
6. Click Insert  Link  in the Insert Objects toolbar or select Insert  > Link .  The Link  dialog box

appears.

The Link  dialog box has four tabs.  Each one is dedicated for a set of different link type.  By
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default the To Page tab is open.  It includes a Page window.  This window lists the names of all
logical pages.  These are all the Logical pages to which you can make link.  The Link Text  field
displays the text from the Web page that will carry the link.  To link the selected text to Page1,
click the Logical name Page1 from the page list to select it.  Click Assign  URL to set the link.

When the Link dialog box is open, you may change your mind about the text you have chosen
for linking.  The dialog box displays the text in the link text field.  If at this time you want to
replace the text with another one, simply type over or replace it in the link text field and click
Replace  Link .  The text you entered is placed in the Web page as a link instead of the text you
had selected.

If you want to insert many links in your Web pages, you may want to use the faster method of
entering the actual text of the links right in the link dialog box.  This applies if you do not select
text or objects on the Web page.  To do this, place the cursor on the page where you want the
link inserted, and without selecting any text on the page click Insert  Link  to open the Link
dialog box.  In the Link  dialog box, enter the actual text you want in the Link  Text  field.  Click
Insert  Link  to insert the link text.

Use the same procedure to place a link on an object other than text.  For example, to make a
logo graphic link to another page, insert the graphic, click once on the image to select it, and
select Insert  > Link .  The To Page tab is open.  Select the page from the list and click Assign
URL.

Figure 10.1 – Link Dialog Box
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Modifying Link Colors
One of the Cascading Style Sheet elements is Link Colors.
Use this style sheet element to specify the color you want to
assign to your links under various conditions.  The Link
Colors  dialog box has four link conditions that can each have
a separate color.  These link conditions include:

••••• Link .  This is the text color that displays on the page prior
to a visitor clicking on the link.  By tradition, this color
normally is blue.

••••• Visited Link .  This is the text color that displays on the
page once a visitor has visited the link destination.  By
tradition, this color normally is magenta.

••••• Hover Link .   This is the text color that displays when a
page visitor points his mouse to a link that has a
onMouseOver effect.  By tradition, this color normally is light blue.

••••• Active Link .    This is the text color that displays on the page once a visitor has clicked on
the link but prior to the opening of the link destination.  An active link is a link currently in
process.  By tradition, this color normally is red.

To modify the link colors

Modify the link colors from Site Manager since your settings should apply to your entire site.
However you can change the link colors from Page Style or Site Style, by selecting Site  >
Style , or right-clicking on an open Web page and selecting Styles  from the pop-up menu.
1. Open Site Manager–Styles.  The Site  Manger–Styles  window appears.
2. From the Site  Styles  list, select the Style Sheet you want to modify.
3. Double-click the link colors in the preview area.  The Link  Colors  dialog box appears.
4. Click the color box for the link condition that you want to change.  The Choose  Color

dialog box appears.
5. Select a color from the default color palette or click on the Color Library drop-down arrow

to change the color palette.
6. Double-click on the color that you want.  The Link  Colors  dialog box is reactivated.
7. To accept your color selections, click OK.  The Site  Manger–Styles  window  is reacti-

vated.

To Insert a Link to a Bookmark
If the page you are linking to has a bookmark, then you can set the link to go to the bookmark
location on that page.  To do this, you must first place a bookmark on any page.  Select the text
or object you want to link.  Select Insert  > Link  from the menus.  Click the name of the page
that includes the bookmark you want to link to.  In the Link  dialog box, click the Bookmark
pull down box.  The list displays the list of bookmarks in that page.  Select the bookmark you
want to link to.  To learn more about how to set bookmarks, refer to the topic titled,  “Inserting
Bookmarks” later in this chapter.

Figure 10.2 – Link Colors Dialog



Chapter 10. Links, NavBars, and Bookmarks

WebShop 2000 User Guide10–4        ◆   ◆   ◆

SPECIFIC FEATURES

To Delete a Link (Remove a Link)
You can always delete the text or object that has the link.  This will delete the link as well, but
you will loose the text or object that had the link.  To delete an existing link without loosing the
text or object, select it in the Web page and click Insert  Link  from the Insert Objects toolbar.
Click Delete  Link  to remove the link from the selected object.  This will remove the link yet
leave the text or object on the page.  It is important that when you select the link to remove, you
must be accurate in selecting the exact characters or text that had the link before you click on
Insert  Link  icon.  If you select part of the text, which had the link then delete the link, the part
of the text you had not selected will remain as a link.

Insert a Link to Open a New Browser Session
Besides the regular link previously described, you can also insert a special type of a link, which
will force the browser to open a new session and display the linked page.  Usually, when a user
clicks a hypertext link (a link to a URL outside your Web site), the browser changes to display
the new page called by the link.  However, you can set the link to activate a new browser
session.  In such a case, the old (current) page remains on the screen and a new browser window
opens up with the new page.

To insert a link to activate a new browser session
1. Select the text or object in the Web page you want to use for the link.
2. Select Insert  > Link  from the menu.
3. In the Link  dialog box, click the Open  in  New Browser  check box.
4. Click Assign  URL button to complete the link.  Now when a viewer clicks on the link, the

browser will open a new window and place the referenced page in the new window.

Type in Link Mode Selection
Instead of entering your text first in the Web page and then selecting it, you can type in link
mode.  Everything you type becomes a link.

To type in link mode
1. Place the cursor in the page where you want to start entering text.
2. Click Insert  link  in the Insert Objects toolbar.
3. Select the page you want to link to and click Lock  Link  Mode  to continue.
4. Enter the text you want to use as a link.  Whatever you type in will be one long link-text.

Notice that while you are in this mode the Insert  Link  button stays depressed.
5. When you want to switch back to normal mode and disable the lock-link mode, simply

click Insert  Link  in the Insert Objects toolbar.

Note:  When you insert a link to another page, the browser displays the linked page in its
window with all its resources including any frames or frame-content overlays that the page
contains.
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Linking to any other Frame or Frame-Content Overlay
In the previous section, we described how to insert a link from one location to another page.
Since pages can have different frames, and frames can have many Frame-Content Overlays,
WebShop enables you to insert links to any of these resources.

To link text (or an object) to another frame on the same page
1. Select the text or object you want.
2. Click Insert  Link  in the Insert Objects toolbar.
3. Click To Resource  tab to continue.
4. From the resources tree, select the resource.

• If the resource you selected to link to is an HTML resource, such as page, frame set,
dynamic or free page, select a specific frame set, frame, or frame-content overlay.

• If the selected resource is an image, multimedia object, or any other type of resource
(not HTML), simply click the Assign Link  button.

More about Links to Multimedia Objects
1. Click New.   The New dialog box appears.
2. Click Wizard .  The Web Site Wizard  begins.
3. Complete the Wizard accepting all  defaults.  Site Manager  opens on the left and the Home

Page opens on the right.  This is the default screen display.
4. Maximize the Home Page  window on the right.
5. Type words “ Nationwide”  and select them.
6. Click Insert  Link  in the Insert Objects toolbar or select Insert  > Link .  The Link  dialog box

appears.
7. In the Link  dialog box, click To Resource  tab.
8. The Resources  window displays the Site  Manager–Physical  Layout  window of all your

resources.  CGI scripts, NavBars, images and other components are placed in separate
folders by the program and are considered resources of your project.  To link to one of the
images double-click the Images  folder in the list.  Click on one of the image names to
select it.

9. Click Assign  URL button.  The link is now set to point to that Image file.
10. To really see what this does, click Preview  in the Main toolbar.  This will bring up the

browser and display the current page.
11. Click the text “Nationwide”  which is a link to the image.  The browser will launch what-

ever application is needed to run or display the graphic image.  The application is usually
preset by windows on your PC and the viewer can reset it.  Had this been a .WAV file the
MIDI player would have been launched and you would have heard the music play.

Relative Links
Sometimes you may want to place a link on one page to another point in your site where the
destination point should not be a fixed location.  This is called a relative link.  If you add or
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delete pages, or change the location of pages, a normal fixed link becomes invalid, in such a
case you may want to use the relative link.  The logical layout in the site manager is the basis
that defines the relative links path.

For example, you want to place a link in the current page where the destination of the link is the
parent page of the current page.  In this case, do not select the linked page by name, rather
select it by its relative position in the logical layout.  If, later, you want to add another page in-
between the current page and the parent page, the link will point to the new parent page rather
than to the original parent page.

The program provides many categories and options for relative linking.  These include home,
parent, first sibling, content overlays and others.

To insert a relative link
1. Using the same project as earlier, click Site Manager–Logical Layout .
2. Double-click a page other than the Home Page.
3. Type word “Our”
4. Select the word Our .
5. Select Insert  > Link  menu.  The Link  dialog box appears.
6. Click the Relative  tab and select the Home  Page option from the list.

Note:  You are not selecting a Web page by its actual page name.  That would be a normal
fixed-link to a specific page by name.  Instead, you are linking to a type of a page, in this
case a Home Page.

7. Click Assign  URL.

The word “Our” is now a relative link to the Home Page.  If later, you assigned another page as
the Home Page, this link will point to the new Home Page automatically.  This is one of the
benefits of using a WYSIWYG program like Gold 2000 which does all this automatically.
Otherwise, such as in HTML editor programs, this would have been a very difficult and tedious
task to remember and edit all the specific HTML codes for such changes.

Inserting External Links
You can insert a link to another site.  Links to external URL locations are also known as
hyperlinks.

To insert a link to an external resource
1. Using the same project as earlier, click Site Manager–Logical Layout .
2. Double-click the Home Page.
3. Type word “Weather”
4. Select the word Weather .
5. Select Insert  > Link  menu.
6. Click External  tab.
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7. In the URL field either choose the URL prefix or enter it, and enter the exact address of the
external URL.

For example: www.weather.com.  If you have entered external links before, the program
keeps them in an internal database and lists them in the External links window.  You may
click any one and select it.

8. Click Assign  URL to complete linking to the external URL.

Image Map Links

Just as you can select text and make it a link, you can also select any graphic image.  Select
Insert  > Link  from the menus and insert a link that uses the entire graphic.  Furthermore, you
can assign links to different parts of the same graphic image. This is called assigning an Image
Map link.

To assign Image Map links
1. Place a graphic image on a Web page.
2. Double-click on it.  The image shifts to “in-place” edit.
3. Select Object  > Map Link  or click Map Link  on the New Object toolbar.  The Image Map

toolbar appears.

Figure 10.5 – Example of Image Mapping
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Note:  This toolbar has three buttons.  Each button
defines a different area shape.  Choose between square,
circle or polygon.

4. Select one of the tools and drag the mouse over part of
the image.  This defines the link area.

4. Release the mouse.  The Link  dialog box appears.
5. Specify the link for this part of the image and click OK.

The image reappears.

Note:  Once you have assigned a URL link to a mapped area of the image, you can resize
the area or change its attributes.

6. When done assigning links, click outside the image.  The image returns to normal.

To resize the image map area or change the link attributes
1. Double-click on the image that has the image map links.  The image shifts to “in-place”

edit.  The link areas are displayed.
2. Click once on the area you want to select.
3. Click on it one more time.  The Image  Map Editing

toolbar appears.  The resize handles appear.

Note:  This toolbar has three buttons.  Each button
performs a different edit function.  Choose between
edit nodes, edit object, or edit link.  Once selected
the object is ready to be resized.

4. Click and drag one of the resize handles and resize
the image map accordingly.

Note:  If you click Edit Object, the resize handles are
replaced with the object node bullets.  Do not resize
the object by clicking and dragging the object nodes.

5. When done editing, click outside the image.  The image returns to normal.

Inserting Bookmarks
When you insert a link from one page of your Web site to another, the person viewing your
Web site is sent to the top of the page being linked.  However, bookmarks give you the added
advantage of sending the visitor to a specific location on a page.  After you set a bookmark on
one page, you can link to it from any of your other pages, or from other parts of the same page.
The beauty and main purpose of a bookmark is that it directs the viewer to a specific location on
a page (where the bookmark is) and not to the top of that page.  By default, when you place a
link to another page and the viewer clicks on that link, the browser places on the viewer’s
window the new page.  The browser’s window will open with the top of the page visible on the
screen.  However, if the specific information you would like the viewer to see is somewhere
else on the same page, then the user needs to scroll down or right to find it.  Bookmarks enable
you to take the user directly to the location on the Web page that you want them to see first.

Figure 10.4 – Image Map Editing Toolbar
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Note:  A well-designed Web site should not require the viewer to scroll horizontally.  You
should design your Web pages to display properly without scrolling on 800 by 600 resolution
screens.  It is recommended that you set the resolution of your computer to 800 by 600 and
design your site accordingly for optimum results.

To make this work you must first set a bookmark on a page.  After you set a bookmark, you can
link to it from any other location in your Web site.

To create a bookmark

1. Open the page you and place the cursor exactly where you want to insert a bookmark.
2. Select Insert  > Bookmark  menu or click Bookmark  in the Insert Objects toolbar.  The

Bookmark  dialog box is displayed.
3. Enter an alphanumeric name for the Bookmark in the Bookmark  Name field.

Note:  This will not be visible on the page.  It is used by the browser to identify the different
bookmarks of your site.  Make sure you enter a different bookmark for every new bookmark
you create.  Do not use spaces or \ / : “ < > + # characters to avoid possible problems with
browsers.

4. If you had entered other bookmarks before, the program will list them in the Bookmark
List  window.  If you want to use any one of the bookmarks listed, click it from the Book-
mark List.  Note that you cannot have two bookmarks with the same name.

5. Click OK to continue.  The program will place a Bookmark icon on the page.
6. To insert links that point to this bookmark, select the text, graphic or media object on the

page, and click Bookmark  in the Insert Objects toolbar.  Click the To Page tab.  You can
also apply the link to bookmark on another frame.  To select a frame where the bookmark
is, click the To Resource  tab.

7. Click and select the Web page you want to link to.  Click Bookmark  drop-down menu and
select the bookmark you want.  Click Assign  URL to complete the link.  This will insert a
link, which is a link to this bookmark.  When the viewer using a browser clicks on this link,
the browser will display the page the bookmark is on, and will place the bookmark area at
the top of the visible screen window.

Navigation Bars (NavBars)
The program’s Navigation Bar (referred to as NavBar for short) feature enables you to insert
navigation bars with text or buttons.  NavBars are context-sensitive objects, as are Banners.
That means that when you insert them they “pick-up” their text from the page on which they are
inserted.  Without this feature you have to insert objects or text in your pages and link them
manually.  The main purpose of NavBars is to provide links to the different pages or parts of
your Web site, where the placement of such NavBars and the management of assigning accurate
links to the buttons of the NavBars are done automatically by the program.  You can place
NavBars in horizontal or vertical orientations.  They are perhaps one of the easiest and the
fastest methods to automatically place links in your pages.  The NavBar feature makes the
problem of broken links a thing of the past.  You can place NavBars on any page that you want.
You can also place them in Web page Headers or Footers.  If you place them in a Header or
Footer, the NavBar is automatically replicated and placed on all appropriate pages.
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To create and insert a NavBar
1. Click Navigation  Bar  in the Insert Objects toolbar or select the Insert  > Navigation  Bar

menu options to open the Insert  Navigation  Bar  dialog box.
2. By default, the NavBar is inserted with the style inherited from the higher level of the site

hierarchy of the Logical Layout.  You may check the Specific  Style  radio button to apply
any other specific style from the site styles (see Styles Layout).  For this example check the
Custom  button to specify custom visual settings for the NavBar being inserted.  Notice that
the Edit button is no longer grayed out.

3. Select To Other  Pages  option in the Navigation  section.  This will create links in the
NavBar  to the other pages of the site.

4. In the Style  – NavBar  buttons  (links)  will  point  to  section, select the Home  and  First
Level  pages  option.  This will insert a NavBar that has enough buttons to include links to
the Home Page (from each page) and to every page of the first level.  First level Web pages
are defined as all the pages directly below (or children of) the Home Page in your Logical
Layout.

5. Click on Edit  button.  The Navigation  Bar  Style  dialog box is displayed.  It enables you to

Figure 10.6 – Insert Navigation Bar Dialog Box
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insert NavBars that can be alphanumeric text or graphic images.  Text NavBars are the
simple type and can be separated by spaces or dividers.  They have the names of the Web
pages in the bar as text only.  Graphical images can be separated by spaces.  You can
control the amount of space between the graphical buttons.  Each button or label is a link to
a corresponding page.  The Image type NavBars are more interesting as they can be images
or pictures.  To change the font, color and other attributes of the text NavBars, click on the
name of the NavBar from the list of NavBar button groups and select the options you want.

6. To change the position of a particular button in the order of the NavBar, click and select it
from the list of NavBar button groups.  Use the Up and Down  arrow buttons to move its
location in the NavBar.

7. Check the Image  radio button to place graphical NavBars in your Web pages.  The
program includes a library of buttons with hundreds of graphical images especially made
for NavBars.  If you did not install this library during the initial program installation then
the program provides you with a few to work with.

8. In the NavBar  Orientation  section, check the Horizontal check box.  You can set NavBars
to appear horizontally or vertically on your Web pages.

9. Click Baseline  radio button in the Alignment  section.
10. The groups of Web pages listed in the NavBar  Button  Groups  window have check boxes.

Use this window to select the groups you want and assign different settings for each group
of Web pages.  For example: all First level Web pages can have a certain font and color.
Or you can select all the groups in the list and apply your settings globally to all of them.

Figure 10.7 – Navigation Bar Style Dialog Box
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For this example we will create NavBars which are consistent in all pages.  Make sure the
check boxes for all the Web page groups listed are checked.

11. To make it interesting, make the button that links to the Home Page a different color or
image.  To do this use the shift key and click every group name in the list to select all the
groups except the one that says Home  Page button.

12. Click Font  button.  In the Font  dialog box choose the font style, size and color for the font.
This font is used for the text of the button label.  These labels are placed on each button of
the NavBar.  You can choose from any of the fonts installed on your PC.  Choose Times
Roman , click Bold  and select size 10.

13. Click the rectangular button next to the Image.  You can choose from many button images.
If you have installed the button library during your installation, you should have many
groups of predesigned, colorful buttons to choose from.

14. Click Wide  Rectangle  from the pull down menu.  Select one of the buttons you like.
These buttons are placed, one next to the other, in the NavBar.  If you had selected a
Vertical NavBar these buttons would have been placed vertically one above the other.
Each button is a link to another page.  Click OK to continue.

15. The buttons with text labels are placed in the sample window of the dialog box.  If you do
not like the size of the text, click Font  on the Formatting toolbar and change the font size.
Remember some of your link names are longer than one word.  They are the names for the
Web pages you set up in Logical Layout.  If the page has an Alias  (different from the
logical name), it is used instead of the logical name.  An Alias  can consist of more than one
line of text and can contains symbols not allowed for a logical name.

16. The program places the text label right in the center of each button.  You can change the
position of the labels with respect to each button.  In the Font  section of the dialog box, the
two pull down menus give you options to position the text on or around the buttons.

17. Now click the Home  Page button group in the list and select it.  Make sure that the check
box is also checked.  Select only this group from the list.

18. Click Font  in the formatting toolbar and select Arial  for this button.  Click Image  in the
Insert Objects toolbar and choose another image for the Home  Page button.

19. The Spacing  option enables you to move the buttons closer to each other or push them
farther apart.  Enter zero for spacing if you want the buttons touching each other with no
space in between.

20. Click OK to continue.  The NavBar you created is placed in the Web page.

You can insert NavBars in Headers or Footers in Web pages.  When you insert a NavBar in a
Header or a Footer, it is inserted wherever you insert that header or footer.  If you make that
header or footer the default for all pages, then the NavBar is automatically placed on all pages.
If you want to insert the NavBar in the Header or the Footer, you must make sure that the

Figure 10.8 – Example Navigation Bar
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preferences settings are set accordingly.  If the preference settings are not set to insert Headers/
Footers by default, then you must manually insert the header or footer in any particular page.
Changing this setting will only apply to the pages created after you reset your preferences.

To place a Header or Footer in a page

1. Place the cursor in a page where you want to insert the Header or Footer.
2. Click Frame  Manager  on the Page Editor toolbar.  The Frame Manager tree appears with

the current page highlighted.
3. Right-click and select Properties .  The Properties  dialog box appears.
4. Click the Page tab.  Separate Header  and Footer  fields appear.
5. Select the Header and Footer that you want from the drop-down list.  Click OK.  The

specified Header / Footer is inserted.

Note:  To select a Header / Footer from the Properties dialog box it must first be defined in
Site Manager–Common Objects.  Select <NONE> to turn off the Header / Footer display in
Page Editor.

The program enables you to add other items to NavBars to make them fancy.  These could be
other graphic images such as logos, pictures, animated GIF’s or other objects.  You can place
them at the front or end of the NavBar.  Simply create or import an image and place it in the
Footer or the Header where the NavBar is.

Once you insert the NavBars throughout your Web site, the program inserts the corresponding
links in the pages.  Click Site  Manager  button at the bottom of the window.  Click the Site
Manager–Navigate  Layout  tab.  The program displays the graphical picture of the entire site.
You can zoom in and zoom out to see certain parts of the site in more detail.  The arrows
between the pages indicate links between them.  These are the links of the NavBars you
inserted.

Linking NavBars to Frames in Other Windows
This section describes how you can create and insert a NavBar in one frame with buttons that
link to the Frame Content Overlays of another frame.  This is used by many Web sites espe-
cially with Home Pages that have two frames.  The left frame includes a set or list of options
and links, and the right frame displays whatever the viewer clicks on in the left frame.  You can
certainly achieve the same result doing it all manually without the program’s NavBar feature.
To do it manually, you have to insert a list of items in the left frame, then create separate HTML
pages to be displayed in the right frame.  To do this, carefully link each item in the left frame to
display its corresponding page in the right frame.  If you add more pages in the right frame, you
have to go back and manually edit the left frame and its contents.  Otherwise the two-frame
screen will not display properly.

Instead of this long and tedious process, you can use this program’s NavBar and Frame Man-
ager features together to get the equivalent result.  Furthermore, when you use the NavBar
method, the program keeps track of the links.  When you delete a page, its respective links (or
buttons) are removed from the NavBars.  When you add a page or FCO, the program automati-
cally adds a corresponding link or button to all the NavBars in all the appropriate pages or
frames.
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To add a NavBar in one frame with buttons that link to the other frame

This example will describe how you can place a NavBar in the left frame, with buttons that link
to different Frame Content Overlays (FCOs) in the right frame.
1. Start with a new blank Web site, and double click on the Home Page to open it.  Place two

vertical frames on the page.  One on the left and another on the right.  See the chapter on
Frames for more details on how to create frames and FCOs.

2. Add three FCOs in the right frame.  To do this:
A. Click on the Frame  Manager  icon and click on the name of the right frame, Frame , to

select it.
B. Right-click on Frame , and from the pop-up menu, select New Frame  Content  Overlay .

Select Plain  Page and click OK.  This will add Page2 to the list of FCOs.
C. Right-click on Frame  and repeat this step two more times to add two more FCOs.
D. Click once on the Index  FCO of Frame  FCO.  The corresponding FCO will be displayed

in the right frame window (which is not displayed in the graphic).
E. Place the cursor in that frame and type “This is the first FCO.”
F. Click on the other FCO names in the Frame  Manager  window and type different text in

the other FCOs, which are displayed in the right frame.  Now all three FCOs of the right
frame have different contents.

3. In Page Editor, place the cursor in the left frame and select Insert  > Navigation  Bar .  The
Insert  Navigation  Bar  dialog box displays.  The default style NavBar is previewed.

Note:  Since we want to link these NavBar buttons to Frame Content Overlays and not to the
other pages, select “To Frame Content-Overlays in same page” from the Navigation section.

4. Customize your NavBar.  To do this:
A. Select the Custom  option.
B. From the Target  Frame  drop-down box, select the frame that has your three FCOs.
C. In the Style  section, select the Siblings  of  the  same  parent  option.
D. Either double-click on the sample NavBar or click on Edit  button.
E. In the Type  of  NavBar , select Image  with  label .
F. In the NavBar  Orientation , select Vertical .
G. In the NavBars  Button  Groups , select Siblings  buttons .
H. Click on Font  and Choose  Image  buttons to make your choices for the style of button

labels and the button graphics.
I. Click OK twice. The vertical NavBar you designed is placed in the left frame.

Note:  As you can see, it has three buttons. Each button is a link to its corresponding FCO in
the right frame.

5. To test the links, click on F7, or select File  > Preview  in  Browser . After the browser
displays the page with the two frames, click on the buttons in the left frame. The FCOs in
the right frame will change.

Note:  If you change the names of the Frame Content Overlays or add new ones, the
buttons on the NavBar in Frame1 are automatically updated.



Chapter 11.
WebShop Tables

Introduction
Tables are a good way to organize data in a Web page in a columnar fashion.  Since an HTML
Web page does not work exactly like a word processor screen, the normal tabs and paragraph
indentation of a word processor are not fully available for you to use.  Instead, a table is used to
achieve the same or similar purpose.  Nevertheless, this program’s advanced features such as
Cascading Style Sheets and Free Pages have added a whole new dimension to Web page design.
Using this program you can now place an object anywhere on the page, and even drag it for
exact positioning.  You can place a number of objects, such as text, or graphic, and line them up
in a columnar form.  The generated HTML file (as produced from the Free Page) is much more
efficient in the usage of HTML commands, than in the case of tables, usually smaller in size
than those produced by tables, and loads much faster than tables on the viewer’s browser.  Free
Pages are described in the Creating Web Pages chapter of this User Guide.

In certain situations, the use of tables may provide certain advantages.  In this chapter, we will
explain the table features of this program, and how you can use them.

Topics covered in this chapter include:
• Table cells and dimensions
• Table rows and columns and resizing
• Deleting and joining cells and setting other cell attributes.
• Setting different background colors to different cells.

Inserting Tables
You can insert a table anywhere in a Web page.  Because tables require additional memory
resources, they should be used with care to avoid slowing the page download.  Place only the
number of rows and columns that you need.  Do not create tables where some of the rows or
columns are empty.  Tables can have different dimensions, captions, vertical and horizontal
border lines and may include text or graphics depending on the program.  The program allows
you to create a nested table, which is a table inserted into a single cell of another table.
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To insert a table in your Web page
1. Place the cursor on the page where you want to

insert a table.
2. Click Table  in the Insert Object toolbar or

select the Table > Insert Table  menu.  The
Table Properties  dialog box appears.

Table Size
The program enables you to specify the size of the
table in rows and columns.  To specify the size of
the main body of the table, enter the numbers that
you want for the Rows and Columns in the Cells
section.  Note that tables consume additional
computer memory resources.  Do not create a table
larger than the size you need.  Each table can be no
more than 50 rows.  You can, however, place more
than one table on a page.

Note:  Make sure that you save your work often
when you are inserting tables in a Web page.
Tables are very memory intensive.  It is also
recommended that you close all other Windows
applications when working with tables to free
as much memory as possible.

Table Header and Footer Cells
You can assign a Header and/or Footer attribute to a number of top and bottom rows of the
table.  By definition, a header cell in a table is defined as a row in which the text is bold and
centered in the cell.  Another important point about table headers is that you may have as many
headers in a table as you like.  A header does not have to be a complete row of cells.  You can
set a single cell of a table to be a header.  You can even select a single cell in the middle of the
table and set it to be a header.  Setting the cells to be headers is simply a matter of convenience.
You can select any cell of a table, and manually set the text inside to be bold or left justified.
However, instead of doing this manually one by one, you can select the cell and set it to be a
header.

The program enables you to specify which rows in the table are Headers or Footers.  The
Header rows are always at the top most part of the table.  The Footer rows are at the bottom of
the table.  Headers and Footers are not a separate set of cells.  They are part of the main body of
the table, but are designated to be either Headers or Footers.

To insert a table with Header and Footer rows

1. Place the cursor where you want to insert a table.  Click Table  in the Insert Object toolbar
or select Insert > Table from the menu.  The Table  dialog box appears.

2. Enter the numbers of rows and columns you want for the table in the Number of Rows  and
Number of Columns  fields.

Figure 11.1 – Link Properties Dialog Box
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3. To specify which of the top rows of the table are Headers, enter the number in the Header
Rows  field of the Cells  section.

4. To specify which of the bottom rows of the table are Footers, enter the number in the
Footer Rows  field of the Cells  section.

5. The number you enter for the rows of the table should include the rows for the following
three sections of the table: (1) the header section, (2) the main body of the table, and (3) the
footer section.

6. For example if you specify the number of rows to be the same as that of the header rows
plus the footer rows, the main body part of the table will have zero rows.

Any text that you enter in the Caption and Header parts of the table are centered by default.
Header and Footer text are bold by default.  However, you can change these attributes after you
enter the text.  For example, if you want to left justify the text in the Header , select the header
cell and click Justify Left  in the Text Format toolbar.

Note:  To change the attributes of a table, select the table on the page, place the mouse on
the table and right-click.  From the pop-up menu select the Object Properties to display the
Table dialog box.

Table Dimensions
You can set the units of measure for a table to be in pixels or as a
percent of the browser window size.  This is the dimension of the
entire width or height of the table.  The default setting is Auto.
This means that after you set the table on the page, you cannot
change the width or the height.  It is changed automatically by the
program, based on the amount of text or other objects you insert
in the cells.

Dragging Table Boundaries to Resize
You can set the dimension of the table to be re-sizable and not automatic.  This will enable you
to drag the borders of the table by dragging them on the Web page.  To set the dimensions for
variable resizing, check the Pixels radio buttons for the Width and Height of the table in the
Table dialog box.  Now when you insert this table on the Web page select it to resize the
borders.  The program places an outline with dragging handles around the table.

To resize a table

• Using your mouse, drag any of the handles to resize the table.

Borders, Cell Padding, and Cell Spacing
Table cells have border, cell padding and cell spacing.  The border of a table is the outermost
frame or four bounding sides of the table.  You can enter any number in pixels to be the
thickness of this border in the Border Size  field of the Table dialog box.

Figure 11.2 – Example Cells
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The padding of a cell is the extra space added inside each cell.  It forces the text or objects in
the cell to be positioned away from the border of the cell.  The more padding you specify for the
cells, the farther apart the contents of the cells will be from the boundaries of the cells.

To specify the padding size, enter the number of pixels in the Cell Padding  field of the Table
dialog box.

The spacing of the cell is the actual width of the bounding box surrounding each cell.
• If you want the border of each cell to be thick, then enter a high number in the Cell Spac-

ing  field of the Sizes section in the Table  dialog box.
• If you do not want the table borders and paddings to show, enter 0 in these fields.  The

program will display temporary dotted lines instead of actual borders.  This will help you
change the sizes of the columns or rows and work with the table.  However, the browser
does not show the dotted line borders.

Table Caption
You can also place a caption for a table.  You can insert the caption either on the top of the table
or below it (but not both).  To insert a caption check the Create  check box in the Caption
section of the Table  properties dialog box.  Select one of the radio buttons for Top  or Bottom
caption.  The caption is placed at the top or bottom of the table.

Only the cell padding size applies to captions.  The same cell padding you enter in the Sizes
section will apply for the caption.  Captions do not have visible borders or cell spacing.

Note:  To change the attributes of a table, click once on the table to select it.  The bounding
box will surround the table.  Place the mouse on the table and right-click.  From the pop-up

Figure 11.4 – Example of Cell Borders

Figure 11.3 – Example of Cell Padding
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menu select the Object Properties to display the Table dialog box.  You can also click on
Object Properties button from the Standard toolbar after you select the table.  Enter your
changes in the Table dialog box.

Table Justification or Alignment
You can justify the table horizontally in the page.  Due to the special table characteristics as
defined by the HTML language or browsers, the normal text justify icons in the toolbar are not
used to justify tables.  Instead, the justification or alignment of tables is done with settings
inside the Table  dialog box.  To do this,  select your choices in the Alignment  section of the
Table  properties dialog box.

To justify the table click the Left, Center  or Right  option buttons.  You can also set the table to
be in float mode.  This mode allows the text (not the table) to wrap around the table.  If you
check the Float  check box, you can also check the table to be aligned left or right.  If you want
the table to be aligned left and have text wrapped around it, then check the Float  and the Left
check boxes.

If you check the Float  check box and the Right Align  radio button, the table is aligned to the
right side of the screen and the text is wrapped around the top, left and bottom sides of the table.

Note:  When you left, center or right align a table it does not stay fixed at these locations.  It
will move according to the browser visible screen window.  For example, if the browser
screen window is made narrower, then a right aligned table will not fall out of the screen but
is moved to the left along with all the wrapped text.

Moving a Table
In a plain page you can always select a table and drag it to a new location on the page.  As you
select the table and start dragging the mouse, the program will display a small square at the edge
of the mouse designating the table move.  You can drag the table to any other location on the
page where there is a text or an object line already inserted.  If you want to drag the table
beyond the last line limits, you must add more lines or enter spaces first.

After you drag and drop the table, it may not be placed exactly where you dropped it.  It is
placed as close as possible to the point where you dropped it.  The final position is controlled by
the justification and alignment options that are set for the table.  You can change these settings
in the Table dialog box.  Remember that you can also use the program’s Free Page feature to
insert a table and position it more accurately on the page.  Refer to the chapter titled “Creating
Web Pages” for more details on Free Pages.

Editing Tables
To change the text inside the cells of the table, click in the cell and delete or add text.  To
modify the attributes of a table itself, double-click in the table and select the Format > Object >
Properties  menu options.  You may also right-click the table to open the drop-down menu.  In
the menu, click Object > Properties  to open the Table dialog box.  You may also click on the
table once to select it, then click the Object Properties  button in the Standard toolbar.

In the Table  dialog box, you may change the table options.  There are certain rules you should
remember when you change the attributes of a table.  These include:
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• If there is no caption and you check the caption check box in the dialog box, the caption is
added to the table.

• When you change the number of rows and columns, the new cells are added or removed at
the right and bottom of the table.

Note:  To change the attributes of a table, select the table on the page, place the mouse on
the table and right-click.  From the pop-up menu select the Object > Properties to display
the Table dialog box.

Changing the Size of Tables and Cells
You can change the size of cells from the Cell Properties  dialog box.  To change the size of
any cell:
1. Click the mouse on the cell to select the table,

then click inside the cell to place the cursor
inside the cell.

2. Right-click on the cell.  The pop-up menu
appears.

3. Select Table > Cell  Properties.  The Cell
Properties  dialog box appears.  Make the
changes as you want.

Different columns of the same table can have
different widths.  However, not all browsers support
individual column sizes.  These features are part of
HTML 3 and 4 specification.  If you want to create
tables that are viewed properly on earlier version
browsers, then you must keep the sizes of all the
columns in your Web page the same width.

You can insert text and other objects in the table
cells.  The cell height for that row of cells is automatically adjusted to fit the larger sizes of the
objects you insert.  Similarly, when you delete objects from the cell the cell height for that row
of cells is adjusted automatically.

Changing the Background Color of a Cell
You can use all the text editing and formatting features on any cell including setting different
background colors for each cell.  The program enables you to set the cell background to be
transparent or any color you want.  To change the background color of a specific cell, place the
cursor inside that cell, then right-click the mouse on the cell.  From the pop-up menu, select
Table > Cell  Properties .  Choose the color you want in the Cell Properties  dialog box.

Joining Cells, Setting Heights, Widths, and Attributes
After you create and insert a table, you can join cells and change the cell attributes.

To join and change cell attributes
1. Place the cursor inside the cell you want and right-click the mouse on the cell.

Figure 11.5 – Cell Properties Dialog Box
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2. Select Table > Cell  Properties menu from the pop-up menu.  The Cell Properties  dialog
box appears.

3. To make this cell a header cell, click Header Cell  check box.
4. You can join cells, which are either vertically or horizontally adjacent to one another.  To

join two cells in a row where the cells are one next to the other, place the cursor in the left
most cell.  Right-click the table.  Select the Table > Cell Properties  menu options.  In the
Cell Properties  dialog box enter the number 1 in the Columnspan field and click OK to
continue.  The two cells are joined.  The contents of the first cell will remain but the
contents of the other cell are deleted.

5. To join two cells in a column where the cells are above one another, place the cursor in the
upper cell and right-click on it.  Select the Table > Cell Properties  menu options.  In the
Cell Properties  dialog box, enter the number 1 in the Rowspan field.  Click OK to con-
tinue.  The two cells are joined.  The contents of the uppermost cell will remain but the
contents of the other cell are deleted.

6. To join more than two cells, follow the same steps as described earlier.  Enter the appropri-
ate number for the cells you want to join.

Setting Heights and Widths in Rows or Columns
To change the dimensions of a specific column or row
1. Right-click inside the cell you want to change.
2. Select the Table > Cell Properties  menu options.
3. In the Cell Properties  dialog box, enter the new size of the row or column in pixels.
4. Click OK to continue.

Note:  For this feature to work, you must have the table dimensions set to pixels or percent
in the Table dialog box.  You must do this first before you change the size of each row or
column.

Inserting, Deleting Cells, and Justifying Cells
After you place a table on the page, you can insert more rows or columns or delete rows or
columns.

To do this, click and place the cursor in the cell you want to delete or where you want to insert
new cells.  The pop-up menu appears.  Select Table  then the option you want.  A row is inserted
in the cell above the cursor’s location.  A column is inserted to the left of the cell that has the
cursor.

If you want to insert a column at the right most edge of the table, or a row at the bottom most
edge of the table, you must increase the number of columns or rows in the Table  Properties
dialog box.

To justify the contents of the cells
1. Place the cursor in the cell you want and right-click on the cell.
2. Select Table  then one of the alignment options you want.



Chapter 11. WebShop Tables

WebShop 2000 User Guide11–8        ◆   ◆   ◆

SPECIFIC FEATURES

Note:  Sometimes when you are performing intricate cell operations, you may need to
refresh or redraw the screen to see the updates and changes you make.  For example
scrolling the page, or minimizing then maximizing the page or window will by default redraw
or refresh the screen.  You can always click on the preview icon and view the change in the
browser.



Chapter 12 .
WebShop Frames

Introduction
Frames have become one of the best ways to manage Web page spaces on the Internet.  Frames
enable companies to place different types of information in different windows on their Web
pages.  This program provides you with extensive frame functionality.  It also includes the
Frames Manager that helps you work with the frames and the contents in the frames.

In this chapter we will explain what frames are and how you can place information inside the
frames.

Topics covered in this chapter include:
• Horizontal and Vertical Frames
• Renaming, Deleting Frames and Frame Properties
• Frame Content Overlays (FCO)
• Linking Navigation Bars to Frame Content Overlays

Using Frames

You can divide a Web page into separate windows or frames.  Each frame is independent of the
other frames of the page.  A frame is the name given to the actual area on the screen defined
inside a bordered area.  The contents that the program displays inside a frame can be larger in
size than the frame itself.  In such a case, the program provides scroll bars to enable the viewer
to scroll vertically or horizontally to view the entire content of that frame.

The program treats all the frames placed on one page as part of one logical page.  However,
each frame (and its contents) is treated as a separate and distinct physical resource or page.
Each frame has specific properties and can be re-sized and re-named.  Separate HTML files are
eventually created for each frame content as you generate the site.

It is recommended that you do not use too many frames in a single page due to the difficulty in
viewing such a page.

The Frame-Content Overlay (FCO) is the name given to the content of a particular frame.
Throughout this section on frames, the abbreviation FCO may be used to denote “Frame-
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Content Overlay.” When a menu choice or dialog box by that title is being referenced, the full
name for FCO may be used to avoid confusion.

Important!  You can place more than one Frame-Content Overlay in any one frame.  This is
the reason why they are named “Overlays.”  Each different Content Overlay is another
resource for the same Frame.  The program enables you to create these FCOs, see them in
a physical layout list, access them, and edit them.  Without this frame management capabil-
ity, this would require sophisticated programming capability.  With WebShop, this is easily
done without programming.

When you create a frame, you can simply place the mouse inside that frame and start compos-
ing and editing that Web page.  You can create or insert one of many types of pages in the
frames these include: Plain, Free, Dynamic, FrameSet, and Image pages.

To create frames for a page

The program enables you to place vertical and horizontal frames on the page.  When you place
a vertical frame on the page, this means the screen or the page will be divided vertically and you
will have two frames, one on the left and another on the right.  In reality, it seems as though the
screen or page is being divided into two frames.  However, when you create a frame, the
program inserts a new frame on the page, and shows the borders of the frames with scroll bars.

1. To insert a horizontally divided frame on the page, select Frames > Split Horizontal  or
click Split Horizontal  on the Page Editor toolbar.  The screen will be horizontally split in
the middle, and you will see one frame at the top and another at the bottom, with the new
frame you inserted being placed above the current one you were in.

Note:  The drop-down arrow next to the Insert Split Horizontal frame button gives you two
options.  You can either insert a new frame above the current one your cursor is in, or below
it.  After you insert a new frame on the page, you can simply click inside any of the frames
visible and create or edit that frame’s content.

2. To insert a vertically divided frame, select Frames > Split Vertical or click on the drop-
down arrow next to the Split Vertical  button on the Page Editor toolbar.  Choose which
side you want to insert the new frame (that is, to the left or right).

3. To delete a frame from the page place the cursor inside the frame you want to delete, and
from the menus select Frame > Delete .

Renaming a Frame
Each frame should have a unique name.  Since a frame also contains at least one FCO, then that
FCO should also be named.  Furthermore, if frames have more than one FCOs, then each FCO
should also be uniquely named.  This is important such that when you want to access a specific
frame and a specific FCO, you can do so easily from the list of available frames and FCOs.  The
program by default gives unique names to all of the frames and FCOs as soon as you create
them.  It keeps them in its internal database, and manages them properly so that you can access
them or link to them from any part of your Web site.

When you place two frames on a page, one on the left and another on the right, the program
creates or assigns three files.  The calling page which is referred to as the Frame Set page, the



Chapter 12. WebShop Frames

WebShop 2000 User Guide ◆   ◆   ◆         12–3

SPECIFIC FEATURES

left frame, and the right
frame.  When a viewer clicks
on a link that brings up this
page, the browser opens the
calling (or the Frame Set)
page first.  Then it loads the
left and right frames in the
page.

You can rename the Frame
and FCO names that the
program automatically
assigns.  You may want to
do this to provide a more
descriptive name for your
development.

To rename a frame

1. Click Frame Manager
on the Frames and Page Editor toolbar.

The physical layout of the frames and the FCOs is displayed on the left.  In this example the
frame manager displays the following:

FrameSet1 –is the name of the entire Web page.  It
contains two frames.

Frame–is the name of the first frame.

Index –is the name of the Frame Content Overlay
(FCO) in the frame called “Frame.”

Frame1– is then name of the second frame.

Page1–is the name of the Frame Content Overlay
(FCO) in the frame called “Frame1.”

2. Click Frame1 , then click it once more.  A box around
the frame name appears.

3. Edit the name and press the RETURN key.

Note:  You can achieve the same result by right-clicking on any frame named in the list, and
selecting the option Rename.

You can also rename any of the items listed in the Frame Manager window including Frame
Content Overlays (FCOs).  For example, to rename the FCO, called Frame1 , right-click on it
and enter the new name you want.

Frame Properties
You can pre-define how your frame can be viewed in the browser.  For example you can
configure how the frame will scroll and whether it will be a resizable frame or fixed.

Figure 12.1 – Example Frame Set Window

Figure 12.2
FrameSet1 FCO Listing
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This applies mostly to frames that contain more than one
frames.  To set the properties of a frame:
1. Place the cursor in the frame page you want and

click on the Frame Manager button.  The Frame
Manager  window will list the Frame Set and the
different frames in that Frame Set.

2. In the Frame Manager  window, select the Frame
you want.

3. Right-click on the selected frame and from the pop-
up menu select Properties , or from the menus select
Frame > Frame Properties .  The Frame Properties
dialog box is displayed.

4. Select the options that you want.
• Scrolling .  Scroll bars in a frame allow the

viewer to scroll up or down and left or right, to view the contents of the frame.  The
Automatic option enables you to set the scroll bars to be displayed only when needed.
In this case the browser decides whether to display or not display the scroll bars.  The
Yes option forces scroll bars to be always displayed.  The No option forces scroll bars
not to be displayed.

• No Resize .  This option enables the frame to be resizable by the viewer or be fixed.
Check this box if you want it to be fixed in size.

Changing the FrameSet Properties
You can change the properties of FrameSets that are on
the Web page.  As explained earlier, a FrameSet
includes a number of frames.  You can change some of
the visual settings of frame sets, such as the divider
thickness between two adjacent frames.  To do this
select the Frame Set page from the Frame pull down
box, or in the Frames Manager window click on and
select the Frame Set you want.  From the menu select
Frames > Frame Set Properties .  The FrameSet
Properties dialog box is displayed.  Make the changes
you want and click OK.

Frame Styles
Each frame on a page can have its own style.  Further-
more, the styles of frames on one page can be different
than the styles of the page itself.  You can set the style
for each frame and page.  The Style includes a number
of different elements that could have pre-defined
characteristics.  When you apply a style to a frame the
different objects of that frame inherit the settings of the
style.  The objects of a frame that could be controlled by

Figure 12.3
Frame Properties Dialog Box

Figure 12.4
Frameset Properties Dialog Box
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styles include: Backgrounds, Banners, NavBars, Horizontal Rules, Paragraphs, Phrases,
Bulleted Lists, and Numbered Lists.

To change the frame style
1. Click anywhere inside the frame you want to modify or apply a style to.
2. Click Frame Style  in the Frame and Page Editor toolbar or select the Frames > Frame

Style  menu options.
3. Check the Specific Style  radio button and select a style from the Site Styles  combo box.

You can also check the Custom  radio button and edit style to create your own custom
style.

Adding Frame Content Overlays (FCO)
You can add as many FCOs to a frame as you like.  Each one will be another layer displayed
inside that frame.  The different FCOs are displayed to the viewer when the viewer clicks on the
corresponding links inside another frame.

To add a new FCO inside a frame
1. Click on the Frame Manager icon.
2. The Frame Manager window displays the list of frames and

FCOs.  Right-click on one of the frames you want to add a
new FCO.  From the pop-up menu select New Frame-
Content Overlay .

From the Add Frame-Content Overlay  dialog box, choose one of
the types of frame (FCO) pages you want to add and click OK.
The Add Frame-Content Overlay  dialog box provides you with
the choice of adding new resource frames, or even using one of
your existing frame resources.

To add a new frame resource, select the Use New Resource
Frame  tab.  The different types of page styles you can create or
add are:

••••• Plain Page .  Use this when you want a plain simple Web page
with a line by line structure.

••••• Frame Set .  Use this when you want nested frame sets (that is, when you want to insert a
set of frames inside another frame).

••••• Free Page .  Use this when you want to place graphic or text objects anywhere on the page.
This is the most versatile page style—you are not limited by the text line limitations of
Plain pages.  If you want to be artistic, place objects on the page, using absolute position-
ing, or even create transparent overlaps, then use this page type.

••••• Image .  Use this when you want to create graphic image file for your page.  This is page.
You can insert an image inside a Web page or FCO, but that is not the same as using an
“Image” page.  An Image page is converted to one graphic image file in your site.  Brows-
ers support this special feature whereby when the viewer clicks on the appropriate link the
browser displays the complete image in that frame.  This page will not generate into an

Figure 12.5
Frame Manager Pop-Up

Menu
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HTML page in your site.  It will exist as an image file.
One common use of this feature is to place many image
pages inside a frame, and their corresponding links in
another frame.  As the viewer clicks on the links one
after the other, the images are successively displayed in
the other frame like a slide show.

••••• Dynamic Page .  Use this when you want to create a page
that displays text or form elements that contain instruc-
tions executed by your ISP-server.  This is not a tradi-
tional page with text or graphics objects, instead this
page contains instructions that are executed by your ISP-
server and which display data, interactively.  These pages
perform dynamic actions based on different parameters.
Active Server Pages (ASP) is the technology used to
perform dynamic page instructions.

This example displays a frame with many different types of
Frame Content Overlays added.  Frame1  has eight Frame
Content Overlays.

If you have previously created frame resources in your Web
project, you may use it instead of adding a new one.  To do this, click on the Use Existing
Resource  tab in the Add Frame-Content Overlay  dialog box.  The window will display the list
of page and image resources you currently have in your project.  Select the one you want and
click OK.

To delete a Frame Content Overlay, click inside the frame where the overlay is, and from the
Frame Content overlay pull down box, select the FCO you want to delete.  From the menus,
select Frame > Delete .

Adding Content to a Frame-Content Overlay
This simply means you need to display the specific Frame Content Overlay on the screen of the
program and add or edit the information.  In a frame that includes many Frame Content over-
lays, you need to first move the FCO you want to the top of the layers of FCOs then make your
edits or changes to that FCO.

To access (or display a specific FCO)
1. Click on the Frame Content Overlay you want in the Frame Manager  window.
2. Move the cursor into that frame and click to activate the frame.  Now you can start compos-

ing or editing information.

You can also access Frame Content Overlay from the toolbar.  Click on the current frame listed,
click on the down arrow and from the list of available FCOs select the one you want.

Linking to Frame Content Overlays

To use FCOs for the right purpose, you must provide links in one frame of your page, which
correspond to the FCOs that you want displayed in another frame of the page.

Figure 12.6
Example Frame Manager Window
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To link a text line or object in one frame to
a specific FCO in the other frame
1. Select the text line or object you want to link,

then select Insert > Link  menu option.  The
Link  dialog box appears.

2. Click To Resource  tab.
3. From the FrameSet  drop-down box, select

“ index .htm .”  In the event that you have more
than one frame set, you can choose the frame
set you want.

4. From the Frame  drop-down box, select the
frame (which contains the specific FCO) you
want.

5. From the Frame Content Overlays  drop-
down box, select the name of the Frame
Content Overlay to which you want to link.

6. Click Assign URL .
7. Press F7 to test your links.  The browser is launched and you can test your links by clicking

on them.

Navigation Bars and Linking to FCOs
The Navigation Bar feature is a powerful method to create links between frames.  You can do
this manually with your own links.  This was described in the previous section.  However, the
Navigation bar feature—also known as NavBar —provides a more automated method for
creating and placing your links.  When you use the NavBar method, the program keeps track of
the links.  When you delete a page, its respective links (or buttons) are removed.  When you add
a page or FCO, the program automatically adds a corresponding link  or button to all the
appropriate pages or FCOs.

To add a NavBar in one frame, which will create buttons that link to the Frame
Content Overlays of another frame
1. Follow previous instructions to place two vertical frames on your page.  You should have a

left frame and a right frame.  See the procedure “Adding a Frame Content Overlay.”

Note:  This example will describe how you can place a NavBar in the left frame, which will
link to different FCOs in the right frame.

2. Add three FCOs in the right frame.  To do this:
A. Click on the Frame Manager  icon and click on the name of the right frame, Frame  to

select it.
B. Right-click on Frame , and from the pop-up menu, select New Frame Content Overlay .

Select Plain Page  and click OK.  This adds Page2 to the list of FCOs.
C. Right-click on Frame  and repeat this step two more times to add two more FCOs.
D. Click once on the Index FCO of Frame FCO.  The corresponding FCO will be displayed

Figure 12.7 – FrameSet Drop-Down List
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in the right frame window (which is not displayed
in the graphic).

E. Place the cursor in that frame and type “This is the
first FCO.”

F. Click on the other FCO names in the Frame
Manager  window and type different text in the
other FCOs, which are displayed in the right frame.
Now all three FCOs of the right frame have
different contents.

3. In Page Editor, place the cursor in the left frame and
select Insert > Navigation Bar .  The Insert Naviga-
tion Bar  dialog box displays.  The default style
NavBar is previewed.

Note:  Since we want to link these NavBar buttons to Frame Content Overlays and not to the
other pages, select To Frame Content-Overlays in same page from the Navigation section.

4. Customize your NavBar.  To do this:
A. Select the Custom  option.
B. From the Target Frame  drop-down box, select the frame that has your three FCOs.
C. In the Style  section, select the Siblings of the same parent  option.
D. Either double-click on the sample NavBar or click on Edit  button.
E. In the Type of NavBar , select Image with label .
F. In NavBar Orientation , select Vertical .
G. In the NavBars Button Groups , select Siblings buttons .
H. Click on Font  and Choose Image  buttons to make your choices for the style of button

labels and the button graphics.
I. Click OK twice.  The vertical NavBar you designed is placed in the left frame.

Note:  As you can see, it has three buttons.  Each button is a link to its corresponding FCO
in the right frame.

5. To test the links, click on F7, or select File > Preview in Browser .  After the browser
displays the page with the two frames, click on the buttons in the left frame.  The FCOs in
the right frame will change.

Note:  If you change the names of the Frame Content Overlays or add new ones, the
buttons on the NavBar in Frame1 are automatically updated.

Figure 12.8 – Index FCO
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Figure 12.9 – Example NavBars

Frame Manager Expanded View

The Frame Manager provides an easy way to design and manage frames of your site.  Whenever
you create and use frames, make sure you always use the Frame Manager to avoid mistakes.
When you remove or add frames or FCOs, first check the Frame Manager listing.  Do not add or
remove frames and FCOs from outside your CNQ file.  This will create confusion.  For ex-
ample, by deleting a file directly from your server, your CNQ project file becomes outdated.
Using Frame Manager with your CNQ file open, avoids errors–especially when your site gets
large.

Figure 12.10 – Frame Manager Expanded View



Chapter 13 .
WebShop Forms

Introduction
Web pages use forms to receive a response from your Web site visitor.  The response can then
be used to achieve a specific purpose or function.  This second part requires a corresponding
script on the Web-server to execute the desired function.  The user response may be as simple as
a guest book recording user visits to your Web site or as complex as a questionnaire that helps
you do market research.

Topics covered in this chapter include:

••••• Creating Forms

••••• Generating Email from Forms

••••• Linking Forms to Dynamic pages

Note:  Make sure you create a Dynamic page before creating your WebShop form.  The
Dynamic page can be empty (that is, existing in name alone).  Part of the form creation
process requires you to tell WebShop exactly where the form input should be sent.

The Form Fields discussed in this chapter include:

••••• Text line  – a single text box for collecting a piece of text such as a first or last name

••••• Push button  – the element used to “submit” a form for processing or to clear all fields

••••• Check box  – to enable the simple selection of one item instead of another
••••• Radio button  – to enable a single selection from a specific group

••••• Combo box  – enables a drop-down item list, one of which is then selected

••••• List box  – an open list of items, from which one or more items can be selected

••••• Text box  – allows long comments to be entered in a “suggestion box” format.

For more information about how dynamic pages and forms are used together, see the chapter
titled, “Dynamic Pages—Sending Emails from a Form.”
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Creating Forms
A WebShop Form collects data through the use of specific form fields.  Active Server Page
(ASP) scripts on the Web-server hosting your site then take over and process the data submitted
via the form.  Since WebShop has automated to a considerable degree the programming steps
involved with designing forms and processing the form input, you can concentrate on simply
designing Web page forms that will:
• Perform a product inventory or other database query
• Store, mail, or display a formatted document
• Perform some other custom action (that is, use an ASP script to handle the input data)

To create a form, first open the form and then insert the form elements.

To open a form
1. In Site Manager, open a Plain Page.  The Page Editor window appears.
2. Move the cursor to the point where you want the form to begin.

3. Select the Insert > Form menu option or select the Insert Form button from the  Insert
Object toolbar.  Automatically, two separate functions are carried out:
• The Form Fields  toolbar is immediately activated.

• The cursor is moved down the workspace by one carriage return.  The form (still
empty) is started.  Now you may place the cursor wherever you want to place a form
field.  Select the Show/Hide  button in the Standard toolbar.  This will show you where
the form begins and ends.

To insert a form field into a form
1. Move the cursor to the point where you want to

insert the new form field.
2. Click the appropriate form field button from the

Form Field toolbar or select one of the Insert >
Form Field  menu options from the main menu.

To edit the properties of a form field

If you wish to change the properties of any field type
in a form after placing it on your Web page, double-click the form field to open the Properties
dialog box for that field.

Form Properties
Just as WebShop features dialog boxes for each form field element, the Form Properties  dialog
box lets you manage each form.  Before opening the Form Properties dialog box, the cursor
must be inside the form that you wish to edit.  Select the Format > Form  options from the main
menu or right-click and select Form  from the drop-down menu.

The Form Properties  dialog box contains four sections:

••••• Action Section

• Form Method

push
button

radio
button

list
box

text
line

check
box

combo
box

text
box

Figure 13.1 – From Fields Toolbar



Chapter 13. WebShop Forms

WebShop 2000 User Guide ◆   ◆   ◆         13–3

SPECIFIC FEATURES

• Encode Type

• Hidden Variables

Action Section
The Action section has three parts—No Action , Local  and Remote .

••••• No Action  means the form is intended to do nothing.  This is not the normal selection –
most people go to the trouble of creating forms to actually do something with the input.

••••• Local  means the form is being used to call an Active Server Page script created by Web-
Shop.  (For the vast majority of WebShop users, this is the correct selection.) When the
Local  radio button is selected, the Windows Explorer-like folder box is activated.  Select
the CGI_Bin  folder “plus ”  sign icon or double-click the CGI_Bin  folder.  Select the
Dynamic page, which will be linked to the form.

••••• Remote  means that the form is activating an external script located on a remote Web-

server.  When the Remote  radio button is selected, the Remote  text line is activated.  Enter
the entire pathname of the remote script to be called, including the protocol, which is
usually http:// .

Form Method Section
Post  and Get are the two methods a Web-server uses to activate a WebShop CGI script.  The
Web-server then gets instructions from the CGI script, and displays Web pages to the browser
accordingly.

••••• Post  calls for the fill-in form input data to be sent from the browser to the server and
straight to the CGI script via standard input.  The server tells the script how much form

Figure 13.2 – Form Properties Dialog Box
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input data to expect by using an additional variable, “CONTENT_LENGTH .”

••••• Get causes the environment variable “REQUEST_METHOD” to equal “GET.”  The environ-
ment variable “QUERY_STRING”  is created by the server and will contain all the form data
input sent by the browser.

We recommend using Post  for your form methods since some browsers can experience
performance problems if you create a large form asking for lots of input, causing the GET query
string to get fairly long.

Encode Type Section
The Encode Type  section contains default syntax which should remain unchanged.

Hidden Variables Section
The Hidden Variables  section lets you manage the hidden variables in a form.  These variables
may be any type of form field used by the script that processed the form.  As the name implies,
the Hidden Variables fields are not visible to the Web viewer and cannot be changed by the
Web viewer.

To add a hidden variable to a form
1. Select Add  in the Hidden Variables  section.
2. Enter the name for the variable and the default value in the fields provided.
3. Select OK to add the new hidden variable.

To modify a hidden variable to a form
1. In the Hidden Variables  section, select the variable that you wish to modify.
2. Select Modify  next to the Hidden Variable  dialog box.
3. Edit the name and value as you wish.
4. Select OK to save the edits to the hidden variable.

To delete a hidden variable to a form
1. In the Hidden Variables  section, select the variable that you wish to delete.
2. Select Remove in the Hidden Variable  dialog box.
3. Select OK to confirm.

Form Field Dialog Boxes
There are several dialog boxes used to set up a form.  You can use different Form Fields in one
Form.  Each has its own purpose.  When you select to insert a Form Field, the program displays
one of the following dialog boxes:

Text Line Properties Dialog Box
The Text Line Properties  dialog box includes the following sections: form field Name (Each
field in a form must have a unique name for the form to function correctly), Value  (default text
content for the text line), Field Size  (the length in characters the text line field will display), the
Text  Max.  Length  (the maximum number of characters the user is permitted to enter), and
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Hidden Input (Password)  which will hide any text that the visitors enter in that text line as they
type.

Combo Box Properties Dialog Box
A Combo Box offers your Web site visitors a drop-down listing of items that you create.  Only
one item can be “selected” by a visitor.  The Combo Box Properties  dialog box has two
sections: Name (a required input) and Items .  The Items  list displays the Labels  and the Values
of the items that are included in the combo list.

For each item, Label  is what is shown in the drop-down menu.  The labels are optional, but each
item must have a value.  If you have no label, then the Value  for that item is used as the label.
The Value  may be numerical or text.  The longest individual item Value determines the width of
the Combo Box.  The designated Value  is sent to the Web-server ASP script to process the
combo box input.

To add a new item, click Add  and enter the necessary information.

To modify an item, select it, then select Edit .  The Item Properties dialog box appears, enabling
you to make the necessary edits.  For each item, the Item Properties  dialog box offers a check
box to make that item the Initially Selected  item (that is, that item appears before the Web
visitor selects the drop down menu).

If you wish to delete an item, select that item in the Items  list box, then select Remove Item .  If
you wish to change the order of the items in the list, select the item that you wish to move and
then select Move Up  or Move Down .

List Box Properties Dialog Box
A list box offers your Web site visitors
a list of items to choose from, and you
can decide how many items can be
selected, how many are initially
visible, and which item is initially
selected.  More than one item can be
“selected” by a visitor.

The List Box Properties  dialog box
works similarly to the Combo Box
Properties  dialog box.  At the top, a
Name field is required.  You must
specify the number of visible items in
the list using the Number of Visible
Items  selector.  The number of visible
items determines the vertical size of
the list box in rows.  In addition, the
List Box  feature enables the user to
select more than one item from the list
if you select Allow Multiple Selection .
(The Combo Box allows the user to
select only one item).  In the Items Figure 13.3 – List Box Properties Dialog Box
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section, the labels are optional, but each item must have a value.  If you omit a label, then the
value for that item is used as the label.  The designated Value  is sent to the Web-server ASP
script to process the list box input.

To add a new item, click Add  and enter the necessary information.

To modify or delete an item, click it to select it and then click Edit  or Remove Item .  If you
wish to change the order of the items in the list, you may click the item that you wish to move
and then click Move Up  or Move Down .

Text Box Properties Dialog Box
A Text Box  form field inserts a text box in the form that enables the user to enter more than one
line of text.  The Text Box Properties dialog box requests a Name of the field as well as the
Default Text  that the visitor will initially see.  Since a text box can contain multiple lines, you
must indicate the Horizontal Size  (that is, the width of the box in characters) and the Vertical
Size (that is, the number of lines to display in the box).

Check Box Properties Dialog Box
A Check Box  form field provides the viewer with a square check box in the form.  In the
Check Box Properties  dialog box, a Name is required.  The designated Value  is sent to the
Web-server ASP script to process the check box input.  The Checked  option lets you indicate
whether or not the box is checked when the viewer first views the form.

Radio Button Group Properties Dialog Box
The most common use of radio buttons is when two or more radio buttons are placed in a group
and the visitor is allowed to select only one radio button in the group.  More than one group of
radio buttons can be employed in one form, but in the Radio Button Group Properties  dialog
box, you must enter a unique “Group Name” for each group.

Two groups of radio buttons may not have the same  “Group Name.”  Within each button
group, each individual button must have a unique Member Value .  For each group, you may
choose one radio button to be selected by default using the Selected Member  check box.

Push Button Properties Dialog Box
The Push Button  form field provides the viewer with a standard push button in the form.  To
set up a Push button, use the Push Button Properties  dialog box.  You must enter a Name for
the push button and a Value (or label)  field.  The text that you enter in the Value (or label)  field
is displayed as the button label on the Web page.  To create advanced operations with HTML
coding and scripting, use the Advanced button.  The Advanced Web Operations  dialog box
appears.  There are three different types of push buttons: Submit , Reset , and Button .

••••• Submit .  This button sends all values of the form fields to the specified server.  When the
viewer clicks on this button, a message is issued through the browser to activate the
button’s CGI script.

••••• Reset .  This button resets all values of the form fields in the current form.   When the
viewer clicks on this button, all fields are returned to their original value.

Note: The actions of Reset and Submit cannot be changed, regardless of the Value (that is,
label) that you enter for the button.
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••••• Button .  This button does not perform any standard action.   Use this button type to assign
a custom action performed by a script.  First describe the script using the Value (or label)
field. To assign an action, click the Advanced button and go to the Script Mapping  tab in
the Advanced Web Operations  dialog box. The most common use for this type of button
is to assign a function to the onClick Event .



Chapter 14.
Dynamic HTML and Free Page
Design

Introduction
Dynamic HTML is an exciting feature that allows for the dynamic presentation of Web page
formatting, Web graphics and predesigned Web interactions.  The basic principle behind
Dynamic HTML is the use of three different dynamic programming principles:
(1) Cascading Style Sheets (CSS);  (2) Visual Basic (VB) scripts;  and (3) JAVA scripts.

The Cascading Style Sheet Standard (CSS1) is a standard that was created by the World Wide
Web Consortium.  It provides for the use of Style Sheets and absolute positioning of objects on
a page.  Absolute positioning of objects are handled through WebShop’s Free Page feature.
Cascading Style sheets are handled through Site Manager–Styles  window.  Use VB and JAVA
scripts to alter the content of Web pages after the page has been loaded, or to create specific
actions for an event.  It is important to note that Dynamic HTML (DHTML) works in Internet
Explorer 4.x and Netscape 4.x or higher.

Topics covered in this chapter include:
• What is Dynamic HTML?
• Free Form Pages
• Scripting using VB and JAVA scripts

What is Dynamic HTML?
Traditionally, conventional Web page content was very difficult to manage.  There was very
little control over the presentation of text layout.  Web designers were forced to change the
layout or appearance of a Web page through time-consuming procedures.

Another disadvantage of a conventional Web page is that you cannot place objects anywhere
you want.  Text and object positioning was relative and proportional—not absolute.  Web
designers were forced to use tables to format the layout of the Web page to specify where text
was to be placed.  Not only was this time consuming it also created very slow load time for the
Web page content because it had to load everything inside tables first before any other content
was displayed.  WebShop uses the absolute positioning of elements to place elements and text
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on a Web page.  This feature of absolute positioning is used only with WebShop’s Free Page
feature, not with the Plain Page feature.  Absolute positioning allows for faster and more even
loading of Web page content.  You can also place elements over one another, which is called
“layering.” This level of sophistication has made Boomerang Software, Inc. pioneers in
DHTML WYSIWYG editors.

Designing Free Pages
WebShop’s Free Page feature is unique.  With Free Pages, you can place images or text boxes
anywhere on the Web page.  You can even layer objects over one another.  This is part of the
Cascading Style Sheet Standard (CSS1).  Image boxes or text boxes can be created and placed
anywhere on the page.  The boxes use absolute positioning through drag and drop technology.

Creating a Free Page
Free Pages can be created from either the Site Manager–Physical Layout  window or the Site
Manager–Logical Layout  window.  It is recommended you create your pages from the Logical
Layout and then customize the file structure in Physical Layout.

To create a Free Page from Physical Layout
1. Highlight the root directory (or subfolder) where you want to place the Free Page and right-

click.  A pop-up menu appears.
2. Select Create Free Page .

OR:

1. Highlight the root directory (or subfolder) where you want to place the Free Page and click
Free Page  on the Physical Layout toolbar or select Physical Layout > Create Free Page.

Figure 14.1 – Physical Layout
Creating a Free Page
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Note:  The pages created in Physical Layout will not be visible in Logical Layout.  To make a
page visible in Logical Layout, you must create them in Logical Layout.

To create a Free Page from Logical Layout
1. Highlight the page that you want the new Free Page to be under and right-click.  A pop-up

menu appears.
2. Select New.  The Add Logical Page  dialog box appears.
3. Select Free Page  and click OK.

OR:
1. Highlight the page that you want the new Free Page to be under.

2. Click New Page on the Logical Layout toolbar.  The Add Logical Page  dialog box
appears.

3. Select Free Page  and click OK.

From either Logical or Physical Layout, double-click on the Free Page  icon you have created.
This opens the Page Editor window for that page.  To make your placement of objects easier,
you may want to use the Grid feature or the Snap to Grid  feature.  The Grid feature helps you
line up your objects so that everything is aligned properly.  The Snap-To-Grid will automati-
cally place the box at the nearest grid line.  To do this, select View > Grid  or Snap To Grid .

Inserting Objects on a Free Page
Objects can be inserted by selecting Objects > Add  or by using the New Object toolbar.  Select
from among the following objects:

Figure 14.2 – Logical Layout
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• Free Form Objects
• Text Box
• Navigation Bar
• Banner
• Image
• Java Applet
• Multimedia

Moving and Selecting Objects on a
Free Page

Moving.  When moving an object, click outside the
object area and then click again inside the object
area.  The object bounding box appears.  Click and
drag the object to the desired location.

Selecting.  When selecting an object, you have a
number of options: (1) selecting one or more objects
by clicking on each, (2) selecting one or more
objects by lassoing them with the cursor, or (3)
using Edit > Select All .

Aligning and Sizing Objects on
a Free Page

To resize an object using the mouse
1. Click object (or objects) you want to

resize.  A object bounding box appears
with resize handles on the corners and
sides.

2. Decide how you want to resize the
image.
• To resize the image proportionately, click and drag one of the corner handles.  The

object bounding box gets either bigger or smaller.  Aspect ratio is maintained.
• To resize the image without regard for its proportions, click and drag one of the side

handles.  The object bounding box gets either bigger or smaller.  Aspect ratio is
distorted.

3. When done, release the mouse to set the size.  The object is resized.

To align or resize an object or object group using Align & Size
1. Select one or more objects.

2. Select Object > Align & Size or click Align & Size  on the New Object toolbar.  The Align
& Size  dialog box appears.

Note:  When a single object is selected align and size options are relative to the image

Figure 14.3 – Add Logical Page Dialog Box

free-form navigation
bar

image multimedia

text box banner java

Figure 14.5 – New Object Toolbar

style
group /
ungroup

align &
size
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worksheet area only.  Alignment options are either horizontal or vertical and the resize
options are to worksheet height or width.  When an object group is selected align and size
options are relative to either the image worksheet area or to bounding box created by the
objects selected.  Alignment options include specifications for the entire group or for objects
inside the group.  Use these options to quickly resize and entire group of images relative to
one another or relative to the worksheet area.  For more information, click the dialog box
Help button.

3. Specify the operation of Align & Size using the dialog box fields and buttons as necessary.
4. When done, click OK.

Grouping and Ordering Objects on a Free Page
Ordering Objects.  Objects can be sent forwards or backwards so that you can layer objects over
one another.  This can be done by selecting the object and right-clicking.  A pop-up menu
appears.  Select Order > Send to Front , Send to Back,  Forward One , or Backward One .

Grouping Objects.  To Group one or more objects together, hold the left mouse button down
and lasso the objects that you want to group.  You will notice that all the contents become
highlighted.  Then click Group/Ungroup  on the New Object toolbar.  From this point you can
drag the grouped object around the page and have the contents stay in place.

Note:  To modify the contents, first ungroup the objects by clicking Group/Ungroup again.

Using a Free Form Object on a Free Page
A Free Form Object is a transparent object that you can insert onto a Free Page.  This is a
special object that allows you to group images and text together using absolute positioning.
With a Free Form Object every object can be independently place and grouped together.  Once
grouped, you can move the combination of elements around the page as a single Free Form
Object.  Inside a Free Form Object, you can do everything that you can in a Free Page.

To create a Free Form Object

1. Click Free Form Object  on the New Object toolbar.  An image box is placed on the page.
2. To resize the box, click and drag a resizing handle (one of the small black boxes) to

increase or decrease the size of the object.
3. Double-click inside the box.  You will see a slight change in the object bounding box (the

small black boxes on the outline no longer appear on the inside of the box).

Note:  You do not need to create a Free Form Object to start inserting text or images

To insert text and images into a Free Form Object

1. Click Text Box on the New Object toolbar.  A text box appears in the Free Form Object
bounding box.

2. Resize the Text Box and double-click inside that box.  A blinking cursor appears inside the
Text Box.

3. Begin typing your text.
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4. Click outside the text box (but still inside the Free Form Box) and click back on the Text
Box and drag and drop
the text box to the
desired location.

5. To insert an image
inside the Free Form
Object, click Free
Form Object  and click
Image  on the New
Object toolbar.

6. Select the image that
you want to use, resize
it and click OK.  The
image will appear
inside the Free Form
Object.

7. Click outside the
Image and click back
on it.  Drag and drop
the Image to the desired location.

Using Text Boxes with a Free Page
Text boxes are only available with Free Pages.  Using a Text box, you can add any object that is
available from the Insert Object toolbar (which is used with Plain Pages).  However, objects
within a text box cannot be specifically positioned.  Object positioning within a text box has the
same limitations as object positioning on a Plain Page, with one advantage – objects placed
within the Text box can be moved to any location on a Free Page.

To insert a Text box object

1. Click Text Box  on the New Object toolbar.
A text box appears.

2. Resize the box and double-click inside the
object bounding box.  A blinking cursor
appears inside the box.

Note:  The Insert Object toolbar used with
Plain Pages appears.  You have full control
over the Fonts and Formatting characteristics
as you would in a text editor.

3. Type the contents you want to add.
4. To move the box, click outside the box, then

click once on the box and drag it to the
desired location.

Figure 14.6 – Page Editor
Inserting a Text Box within  a Free Form Object

Figure 14.4 – Page Editor
Inserting a Free-Form Object with the Grid Feature On
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Inserting Images on a Free Page
To insert an image

1. Click Insert Image on the New Object toolbar.  The Image Attributes dialog box appears.
2. Select the image you want to use using the Existing Resource , Library , or URL tabs, or

use the Import , Create , or Acquire buttons.
3. Click OK and the image will appear on the Page.  Move the image to the desired location

by dragging and dropping.

Creating Links on a Free Page 
Links on Free Page objects can only happen with actual text or an actual image (or a blank
image you create).  To create a link on an image, highlight the image once and select Object >
Link .  Select the link and assign the Link.  To assign a Link to text in a text box, simply
highlight the text, right-click and select Link .  Then choose the link and assign the link.

Note:  Free form Objects or text boxes cannot be assigned links.

Using Frames on a Free Page 
Create the Free Page and insert either a vertical or a horizontal frame set by clicking Frame  on
the Frames and Page Editor toolbar.  To create a new frame within a frame, click inside the
frame and choose a vertical or horizontal frame.  You can customize the frame lengths by
placing the mouse on the border and dragging it to the appropriate size.

Scripting–Predefined and Custom 

Scripting in DHTML is an exciting feature that allows for the dynamic presentation of Web
graphics or predesigned Web interactions.  The basic principle behind DHTML is the idea that
VB and JAVA scripts are activated by specific user actions.  For these scripts to work three
variables must be specified: An object, an event that causes the dynamic interaction of the
object, and a script function that specifies what the dynamic interaction is going to be.

WebShop currently comes with two pre-defined scripting effects:
• A double-image effect/mouse-over.
• A slide show effect.

Both of these effects are activated by the mouse-over event (that is, when a Web viewer moves
his/her mouse-over a graphic image the original graphic is automatically replaced with a new
image).  This can be accomplished by using the double image effect.  Once a Web viewer
moves his/her mouse-over a dynamic image, the original graphic is automatically replaced with
a new image until the viewer moves off the image at which point the original image returns.  A
slide show effect is similar except that more then one image will be automatically displayed in a
user-defined sequence.  When creating a slide show effect, you can specify as many images as
you want, as well as the timing between images.  Once the Web viewer triggers the dynamic
effect, each image will be displayed in sequence and then continue to repeat until the viewer
moves off the page.  The slide show effect does not stop by moving off the original image.  It
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only stops once the view leaves the page that it is placed on.  This effect is only slightly more
complex than a double-image effect.

Creating a Double-Image/Mouse-Over Effect
To create a double image effect using a mouse-over trigger
1. Go to the Site Manager and click on the Logical Layout  tab.
2. Double-click on the page that you want.
3. Position the cursor where you want to insert the image file and select Insert > Image .  The

Image Attribute  dialog box appears.
4. Decide how you want to obtain the first image.

• To create an image, click Create  to create an empty image resource file.
• To import an image, click Import  and navigate to an external file.
• To use an existing image that is already a part of current resources, click Existing

Resources  tab, and click the graphic that you want.
• To use an image from one of the libraries, click Library  tab, select the library and

select the image.
• To use an image from the Internet, click URL tab and record the exact location of the

graphic.
5. Click OK.  The image is inserted on the Web page.

Figure 14.7 – Image Attributes Dialog Box
Creating an Image Resoource File for a Double Image Effect
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6. Click once on the image and right-click.  A pop-up menu appears.
7. Select Object > Properties .  The Image Attribute dialog box reappears.
8. Click the Advanced  button to obtain the Advanced Web Operations  dialog box.
9. Click the Dynamic HTML  tab.
10. Click the Double Image  tab.
11. Click the On check box to activate the double-image effect.  The resource selection portion

of the Image Attributes  dialog box appears.
12. Decide how you want to obtain the second image.

• To create an image, click Create  to create an empty image resource file.
• To import an image, click Import  and navigate to an external file.
• To use an existing image that is already a part of current resources, click Existing

Resources  tab, and click the graphic that you want.
• To use an image from one of the libraries, click the Library  tab, select the library and

select the image.
• To use an image from the Internet, click the URL tab and record the exact location of

the graphic.
13. Select what image you want to use and click OK.  This returns you to the Image Attributes

dialog box.
14. Click OK again.  The updated image is inserted on the Web page.

You are now ready to test the image.  Click Preview  on the Standard toolbar to load the page to

Figure 14.8 – Advanced WEB Operations Dialog Box
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a browser.  Place the mouse over the image to see the mouse-over effect.

Creating a Slide Show Effect
To create a slide show effect to display multiple images
1. Go to the Site Manager and click on the Logical Layout  tab.
2. Double-click the page that you want.
3. Position the cursor where you want to insert the image file and select Insert > Image .  The

Image Attribute  dialog box appears.
4. Decide how you want to obtain the first image.

• To create an image, click Create  to create an empty image resource file.
• To import an image, click Import  and navigate to an external file.
• To use an existing image that is already a part of current resources, click Existing

Resources  tab, and click the graphic that you want.
• To use an image from one of the libraries, click the Library  tab, select the library and

select the image.
• To use an image from the Internet, click the URL tab and record the exact location of

the graphic.
5. Click OK.  The image is inserted on the Web page.
6. Highlight the image and right-click on the image and select Object > Properties .  The

Image Attribute  dialog box reappears.
7. Click the Advanced  button to obtain the Advanced Web Operations  dialog box.
8. Click the Dynamic HTML  tab.
9. Click the Slide Show  tab.
10. Click the On check box to activate the slide show effect.  The resource selection portion of

the Image Attributes dialog box appears.
11. Decide how you want to obtain the next image.

• To create an image, click Create  to create an empty image resource file.
• To import an image, click Import  and navigate to an external file.
• To use an existing image that is already a part of current resources, click Existing

Resources  tab, and select the graphic.
• To use an image from one of the libraries, click the Library tab, select the library and

select the image.
• To use an image from the Internet, click the URL tab and record the exact location of

the graphic.
12. Using the increase / decrease arrows next to Duration , specify the length of time that each

image will appear.
13. Click Add.  The image is added to the slide show list.
14. Repeat Steps 11–13 for each additional image you want to use.
15. Click OK.  This returns you to the Image Attributes  dialog box.
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Figure 14.9 – Insert Script Dialog Box

16. Click OK again.  The updated image is inserted on the Web page.

You are now ready to test the image.  Click Preview  on the Standard toolbar to load the page to
a browser.  Place the mouse over the image to start the Slide Show effect.

Creating Custom Effects with Dynamic HTML
The process for creating customized dynamic effects is a two-step process.  First, you must
create the underlying script that executes the effect.  Second, you must map the script to an
object while at the same time specifying the event that triggers the effect.  With double-image
and slide show, the associated script and triggering events were pre-coded.  All you had do to
was string together the requisite images.  With a custom effect, you must write both the script
and then map it to an object.

Note:  Custom scripts work only on Internet Explorer and not Netscape.  The reason is that
IE 4.x follows the World Wide Web Consortium.

When using our predesigned scripts, WebShop considers both browsers and creates alternate
scripts depending on which browser is being used.  Netscape will not understand these scripts
when inserted onto a Free Page.  There are ways around this problem.  They are described at the
end of this section.

Creating a Custom Script

To create a VB or JAVA script that displays “Hello!” and Bye!”
1. In the Site Manager, double-click page where you want to have the script inserted.

2. Click Script  on the Insert Objects
toolbar or select Insert > Java Script .
The Insert Script  dialog box appears.

Note:  Scripts should be placed at the
beginning of the page.

3. Select the type of script–Java or Visual
Basic–from the Script Type  drop-
down menu.  In this case, choose
JAVA script .

4. In the Functions  section, click the
Add  button.  In the Function Name
dialog box, type “Hello” and click OK.

5. Repeat Step 4.  For the function “Bye”
6. Click function name.  This activates

the argument and function body
sections of the dialog box.

7. Write the code for the function Hello .
Type “alert (“Hello!”)”

8. Repeat Step 7 for the Bye  function.
9. Click OK.  A Script  icon appears.  Now you are ready to map this function to an object.



Chapter 14. Dynamic HTML and Cascading Style Sheets

WebShop 2000 User Guide14–12        ◆   ◆   ◆

SPECIFIC FEATURES

Mapping a function to an object and specifying a trigger event
The following mapping procedures specify a mouse-over trigger event for “Hello!” and a
mouse-out trigger event for “Bye!”  Depending upon the browser, these events must be mapped
differently.

To map a function to an object—for Internet Explorer

1. Insert an image by clicking Insert Image  on the Insert Objects toolbar  and choose an
image.  Click OK.

2. Click once on the image, right-click, and select Object > Properties .  The Image At-
tributes  dialog box appears.

3. Click Advanced.  The Advanced Web Operations  dialog box appears.
4. Click Script Mapping  tab.
5. Using the Available Events  list box, select onMouseOver and click Add in the Events

List  section.
6. Highlight “onMouseOver ” in the Event List  section and in the Available Function

section,  highlight “Hello .”
7. Click Add button in the Function List  section.
8. Repeat Steps 6–8 for the event “onMouseOut ” and the function “Bye .”
9. When done, click OK.  This returns you to the Image Attributes  dialog box.
10. Click OK again.  This returns you to the Web page that contains the image.

To map a function to an object—for Netscape

1. Insert an image by selecting Insert Image  on the Insert Objects toolbar and choosing an
image.

2. Highlight the image, right-click, and select Link  to display the Insert Link dialog box.
3. Highlight the same page that the script is on.  Click Advanced .  The Advanced Web

dialog box is displayed.
4. In the Extra HTML  box, type “onMouseClick=return false onMouseOut=Bye” Click

OK.  Click Assign URL .

You are now ready to test the image.  Click Preview  on the Standard toolbar to load the page to
a browser.  Run the mouse-over the image and move the mouse out of the image to start the
custom script.



Chapter 15 .
Using Graphic Editor

Introduction

WebShop’s Graphic Editor module is one of its most important features.  Understanding the
windows, toolbars, and buttons can make using the application quick and efficient.

Topics covered in this chapter include:
• Launching Graphic Editor
• Graphic Editor Functions
• Graphic Editor Window (Full Edit)
• Page Editor Window (“In-Place” Edit)
• Graphic Editor Toolbars
• Procedures for Using Graphic Editor

Launching Graphic Editor
To launch the WebShop’s Graphic Editor module you must specify which image resource file
you want to open.  There are two ways to open the Graphic Editor:  (1) from the Site Manager–
Physical Layout window (where you select the image file from the resource tree), or (2) from an
open Web page in Page Editor (where you select an image that has been placed on the page).

To open Graphic Editor from Site Manager–Physical Layout
• Double-click on an Image File icon from the resource tree.  Graphic Editor opens and the

image is placed in the Image Worksheet.  The image is now ready to be edited.

To open Graphic Editor from a Web page in Page Editor

1. From Site Manager–Logical Layout , double-click on a Web Page that contains a graphic
image.  The selected page opens in Page Editor.
Note:  A graphic image is any image that has been inserted using Insert > Image, or by
clicking the Image button on the Insert Object toolbar.

2. Click on the image that you want to edit and select Format > Object > Edit  or right-click
and select Object > Edit .
Note:  The Graphic Editor Window uses the title: “WebShop <CNQ file name> - Web Site -
<image file name>.”  This naming convention emphasizes that images are resources to
specific project files.
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Graphic Editor Functions

Use Graphic Editor to insert or edit the following graphic objects:  Text Line , Image , Fill
Pattern , Border , Paragraph Text , Calendar , Chart , OLE, and Drawing .  You will also use
Graphic Editor to assign image map links and convert graphic objects or images into template
placeholders.

To perform any of these operations, an image resource file must be created.  Normally, you
create and place an image resource file on your Web page prior to editing or inserting a graphic
object.  When you create an image resource file that is empty and place it on a Web page, you
are inserting a blank image file.

To insert a blank image file onto a Plain Page
1. Double-click on a Plain Page  icon from Site Manager–Logical Layout .  The Page Editor

window appears.
2. Select Insert > Image  or click Image on the New Object toolbar.  The Image Attributes

dialog box appears.
3. Click Create .  A new image file is added to existing resources and is already selected for

you.  Click OK.  The selected blank image file is inserted.  An image bounding box appears
with the words “Blank Image .”

Note:  By default, blank images are created with a height and width of 100 pixels and are
formatted as GIF files with 256 colors.  The background is set to be the same as the Graphic
Editor worksheet (this is not necessarily the same as the Web Page background).  All of
these defaults settings can be changed by selecting the image and clicking the Page Setup
button on the Main toolbar.  The Image Properties dialog box appears.

Graphic Editor Modes
You can open Graphic Editor from either one of two modes:

••••• Full Edit mode .  Makes all Graphic Editor features available and allows you to insert any
graphic object.  When you are in Full Edit Mode the Graphic Editor window opens.  All
Control toolbar options are available and the image pasteboard area is visible.

••••• “In-Place” Edit mode .  Makes available most Graphic Editor features.  In-Place edit allows
you to see the rest of your Web Page content while you update a blank or existing image
file.  The Graphic Editor window does not open.  During “in-place” edits, your screen
display remains in Page Editor.  However, the Menu bar options change, and the Graphic
Editor toolbars become available.  The image pasteboard area is not available.  All objects
must be inserted directly into the Image bounding box.

Normal or Template Placeholder Form
Objects placed either in the Graphic Editor window or on a Web page can be displayed in either
Normal or Template Placeholder form.  Normal objects are displayed as exact images (or
objects).  Template Placeholders are displayed as programming representations that will be
updated later.
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To display a graphic object in placeholder form from Page Editor
1. Right-click a Normal object.  A pop-up menu appears.
2. Select Show > As Placeholder .  The object appears in Placeholder form.

When displayed as a placeholder, an object will have a colored box and a small symbol repre-
senting the type of object.  This small symbol correlates with the Insert Object buttons on the
Insert Object toolbar.  When you convert a Normal object into a placeholder, the representative
symbol is placed in the corner of the bounding box (that is, a box around the object area).  Each
object type has its own color.  The color code for the objects that can be made into placeholders
is as follows:

••••• Text Line - blue

••••• Image - red

••••• Fill Pattern - cyan

••••• Border - yellow

••••• Paragraph Text - bright green

••••• Calendar - pink

••••• Chart - olive

••••• OLE - teal

Note:  For more information about templates and placeholders, see the chapter titled
“Creating WebShop Templates.”

Graphic Editor Window (Full Edit)

In Full Edit mode (Figure 15.1), the Graphic Editor window has several elements:

••••• Title bar .  Indicates the CNQ file that is open and the Image file that is open.  The naming
convention used in the title bar is “WebShop <CNQ file name> - Web Site - <image file
name> .”

••••• Menu bar .  Provides access to WebShop functions.  The menu bar options available in
Graphic Editor are different from those available in Page Editor or Site Manager.  Graphic
Editor Menu options include:  File, Edit, View, Site, Object, Library, Window, and Help.
Additional Menu options become available depending upon the object inserted or selected.
These additional menu options include:

••••• Text Line - Modify, Alignment

••••• Image - Modify

••••• Fill Pattern - Modify

••••• Border - Modify

••••• Paragraph Text - Format, Insert, Effects, Tools

••••• Calendar - Modify

••••• Chart - Modify

••••• OLE - Modify

••••• Drawing - Modify, Create
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Figure 15.1 – Graphic Editor Window – Full Edit Mode
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••••• Main toolbar .  Appears across the top of the Graphic Editor window below the Menu bar.
This toolbar offers quick mouse access to the most basic functions, such as Save, Cut,
Paste, and so forth.  This toolbar is common to all WebShop modules.

Note:  The Page Setup button is only available when an image file is being updated.

••••• Control toolbar .  Appears across the top of the Graphic Editor window and gives you
access to object manipulations (move, rotate, distort) and viewing functions, such as zoom
in and zoom out.

••••• New Objects toolbar .  Appears just below the Main toolbar and is used to insert graphic
objects into the Image Worksheet.  There are separate buttons for each graphic object, for
assigning image map links, for grouping or ungrouping objects, and others.

••••• Clipart toolbar .  Appears on the right side of the Graphic Editor window and displays one
of several images and image libraries included with WebShop.  To use the Clipart toolbar,
specify the Clipart library and scroll through the images available with that library.  Click
and drag a selected image onto the Graphic Editor window.  You can now manipulate the
image as usual.

••••• Window toolbar .  Appears near the bottom of the screen and indicates each of the various



Chapter 15. Using Graphic Editor

WebShop 2000 User Guide ◆   ◆   ◆         15–5

SPECIFIC FEATURES

project windows currently open in WebShop.  Use this toolbar to navigate quickly between
different windows.

••••• Help/Status bar .  Appears at the bottom of the Graphic Editor window and displays a Help
tip for any toolbar button or menu option.

••••• Ruler .  Appears only when the feature is turned on or when you first install the program.

••••• Object Toolbar–Drawing .  Appears only when you insert a Drawing object.  The functions
performed by this toolbar correspond to the Create and Modify menu options, which are
also conditional.

••••• Image Worksheet .  Appears in the center of the Graphic Editor window.  The Image
Worksheet size is controlled by Image Properties which are defined when the image is first
created.  The Image Worksheet and the size of the Image bounding box visible in Page
Editor are the same.  When you define the image size using Image Properties, you also
establish the Image Worksheet.  The default worksheet area color is specified in Prefer-
ences.

WARNING!  Do not use the command Format > Object > Properties to resize an image.
This opens the Image Attributes dialog box.  If you reset the image size from Image At-
tributes you will not be able to access in-place edit.  You can, however, use Image Attributes
to set up some space around the image, create a simple image border, or specify the
alignment of the image on the Web page.

••••• Pasteboard Area .  Appears all around the Image Worksheet.

Page Editor Window (“In-Place” Edit)

From “In-Place” Edit (Figure 15.2), the Page Editor window has several elements:

••••• Title bar .  Indicates the CNQ file that is open and the Logical name for the Page that is
open.  The naming convention used in the title bar is “WebShop <CNQ file name> - Web
Site - <logical page name> ”

••••• Menu bar .  Page Editor menu options are replaced with Graphic Editor menu options.
Graphic Editor options are object-sensitive.  Depending upon the object inserted, some
options become available while others become unavailable.

••••• Main toolbar .  Appears across the top of the Page Editor window below the Menu bar.

••••• Control toolbar .  Appears next to the Main toolbar.  This is a smaller version of the full
Graphic Editor Control toolbar.

••••• Clipart toolbar .  Appears on the right side of the Page Editor window and displays one of
several images and image libraries included with WebShop.

••••• Window toolbar .  Appears near the bottom of the screen and indicates each of the various
project windows currently open.  This toolbar is unchanged.

••••• Help/Status bar .  Appears at the bottom of the Page Editor window and displays a Help tip
for any toolbar button or menu option.  This toolbar is unchanged.

••••• Image Worksheet .  Appears on the Page Editor window wherever an image is placed.  The
Image Worksheet size is controlled by Image Properties which are defined when the image
is first created.  When you define the image size using Image Properties you also establish
the Image Worksheet and the image display area.
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••••• Header and Footer objects .  Appears in the Page Editor window whenever a header or
footer is specified.

Note:  The Pasteboard area and the Ruler are not available during “in-place” edits.

Floating Toolbars
Most of the WebShop toolbars can be made to float or can be placed at different locations in the
Page Editor window or in the Graphic Editor window.  A floating toolbar can be moved to any
location for easier access and convenience.  You can dock a floating toolbar by returning it to its
default location or to one of the toolbar locations at the top, bottom, right, or left of a WebShop
window.

To relocate (or undock) a toolbar, double-click in the toolbar area (not inside one of the toolbar
buttons).  The toolbar is immediately undocked.  Place the mouse pointer on the toolbar title bar
and drag it to the position that you want.

Figure 15.2 – Page  Editor Window – “In-Place” Edit  Mode
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Main Toolbar
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Graphic Editor Toolbars

The following Graphic Editor toolbars are covered:  New Object , Control , each of the seven
Object toolbars, Paragraph Text Formatting , and Clipart .

Note:  All seven of the Object toolbars have the same display name, “Object.”  To identify
them individually, the convention Object Toolbar–“Object Type” is used.  Depending upon the
object selected or inserted, one of the seven Object toolbars appears.

New Object Toolbar
Use the New Object toolbar (Figure 15.3) to initially create a graphic object.  To access this
toolbar, highlight an image on a Web page and select Format > Object > Edit .

Control Toolbar
The Control toolbar (Figure 15.4) is located on
the left side of the Graphic Editor window.  This
toolbar includes object orientation and viewing
controls.  With them, you can view an object at
different magnifications or change an object’s
orientation.

Object Toolbars

Specialized versions of the Object toolbar appear in Graphic Editor depending on what object
you insert from the New Object toolbar or what object you select for editing.  There are seven
different Object toolbars: Text Line , Paragraph Text , Calendar , Charts , Drawing , Map Link
and Map Link Editing .  The Object Toolbar–Drawing also activates a secondary toolbar called
the Node Edit  toolbar.

Note:  All seven of the Object toolbars have the same display name, “Object.”  To identify
them individually, the convention Object Toolbar–“Object Type” is used.  Depending upon the
object selected or inserted, one of the seven Object toolbars appears.

Figure 15.3 – New Object Toolbar
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Object Toolbar–Text Line
The Object Toolbar–Text Line (Figure
15.5) has a number of options for
changing the content and appearance of
a text line object.  All of these functions
access the Text Line  dialog box.  This
dialog box contains four tabs.  Each tab
corresponds to one of the first four
toolbar buttons.  Additional buttons are
provided to align your text within the bounding box.  The Object Toolbar–Text Line  only
appears when you click Text Line on the New Object toolbar or when you click on a Text Line
object to select it.  The operations performed by this toolbar are available from the Modify menu
or from the Alignment menu.

Object Toolbar–Paragraph Text
The Object Toolbar–Paragraph Text (Figure
15.6) has a number of options for changing
the content and appearance of a Paragraph
Text object.  Each function accesses a
different dialog box that is used to complete
the function.  The Object Toolbar–Paragraph
Text only appears when you click Paragraph
Text on the New Object toolbar or when you
click on a Paragraph Text object to select it.
The operations performed by this toolbar are
available from the Format menu or from the Tools menu.

Object Toolbar–Calendar
The Object Toolbar–Calendar (Figure 15.7) has a
number of options for changing the content and
appearance of a calendar.  All of these functions
access the Calendar dialog box.  This box
contains seven tabs.  Each tab corresponds to a
separate toolbar button.  The Object Toolbar–
Calendar only appears when you click Calendar
on the New Object toolbar or when you click on a
calendar object to select it.  The operations
performed by this toolbar are available from the
Modify menu.

Figure 15.6 – Object Toolbar
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Object Toolbar–Charts
The Object Toolbar–Charts (Figure 15.8) has a number
of options for changing the content and appearance of a
chart object.  All of these functions access the Chart
dialog box.  This box contains three tabs.  Each tab
corresponds to a separate toolbar button.  The Object
Toolbar–Chart only appears when you click Chart on
the New Object toolbar or when you click on a chart
object to select it.  The operations performed by this
toolbar are available from the Modify menu.

Object Toolbar–Drawing
The Object Toolbar–Drawing (Figure 15.9)
has a number of options for inserting and
changing the appearance of a Drawing
object.  The Object Toolbar–Drawing only
appears when you click Drawing on the New
Object toolbar or when you click on a
Drawing object to select it.  The operations
performed by this toolbar are available from
either the Create or Modify menu.

Secondary Object Toolbar – Node
Edit
The Node Edit toolbar (Figure 15.10) only appears
when you click the Node Edit Tool .  Use this toolbar
to manipulate a Drawing object’s bounding area
nodes.  Node handles only appear if you click Node
Edit Tool  or Edit Object .  The operations accessed
by the Node Edit toolbar are available from the
Modify menu.

Object Toolbar–Map Link
The Object Toolbar–Map Link (Figure 15.11) has a
number of options for establishing map link areas.
These are the same drawing tools available on the
Object toolbar for drawing objects.  The operations
performed by this toolbar are available from the Create
menu which appears when you click the Map Link
button on the New Object toolbar.

Figure 15.10 – Node Edit Toolbar
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Object Toolbar–Map Link Editing
The Object Toolbar–Map Link Editing (Figure 15.12)
has a number of options for editing map link areas and
map link URL assignments.  Two of the buttons on this
toolbar are the same ones found on the Object toolbar
that appears for drawing objects.  The operations
performed by this toolbar are available from the Modify
menu which appears when you click on an image map
area.

Paragraph Text Formatting
When formatting paragraph text, you could be working with any one of three toolbars: Format-
ting toolbar, Insert Object toolbar, and Object Toolbar–Paragraph Text.  Only the Formatting
toolbar and the Insert Object toolbar are covered here.  (For information about the Object
Toolbar–Paragraph Text, see the topic  “Object Toolbars” earlier in this chapter.)

Formatting Toolbar
The Formatting toolbar (Figure 15.13) has a number of options for changing the appearance of
text contained within a paragraph mark.

Insert Object Toolbar
The Insert Object toolbar (Figure 15.14) has a number of
options for inserting formatting in front of any text con-
tained within a paragraph mark or to import text into a
Paragraph Text object.

Figure 15.13 – Formatting Toolbar
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Clipart Toolbar

WebShop features a Clipart toolbar  (Figure 15.15) on the right side of the Graphic Editor
window and on the right of the Page Editor window during an “in-place” edit.  Unlike other
toolbars in WebShop that access specific functions, the Clipart toolbar provides drag-n-drop
access to various images that are stored in Clipart libraries.  You can access several Clipart
libraries using this toolbar.

To select a Clipart library and scroll through the images
1. Click the button located at the top of the Clipart toolbar.  A list of

available graphic libraries appears.
2. Click the desired library to display it in the Clipart toolbar.
3. To scroll through the library images, click the left or right arrow at

the bottom of the toolbar.

WebShop comes with a variety of Clipart libraries.  These include arrows,
balloons, bullets, signs, and others.  The Clipart libraries available on
your PC will depend on the Clipart options you selected during installa-
tion.

To place a Clipart image on the Image Worksheet
1. Select the Clipart library that you want.
2. Scroll through the images until you find the one you want.
3. Drag-n-drop the image into the Image Worksheet.

You can add or delete Clipart images, or entire Clipart libraries, using Library > Edit Image
Library .

Ruler Set-up

WebShop features a ruler that you turn on (or off) using the Preferences dialog box.  If this
feature is on, the ruler displays across the top and left sides of the Graphic Editor.  The upper
left corner of the ruler (Figure 15.16) contains a box which is used to reset the zero point
locations on the Top and Left rulers.  To use this feature, the ruler option must be turned on.

To reset a zero point on the Ruler
1. Click the box in the corner of the ruler

(where the vertical and horizontal rulers
meet).

2. Click and drag the cursor to the position
on the ruler where you wish the zero point
to be located.

3. Release the mouse button.  The zero point
is reset.

Click the mouse pointer in
the corner and drag it to the
new zero calibration point.

You can change the zero point of the ruler by
dragging the ruler indicator to a new location

Figure 15.16  – Ruler Set-up

Figure 15.15
Clipart Toolbar
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Procedures for Using Graphic Editor

This section covers the following procedure areas:  Basic Procedures , Resetting Image
Properties and Image Attributes , Controlling Inserted Graphic Objects , Rotating and
Reshaping Graphic Objects , Zooming In and Out , Creating and Updating Template
Placeholders , Inserting Graphic Images , Creating Map Link Links , and Inserting OLE
Objects .

Note:  For object specific procedures, see the three chapters immediately following this one.

Basic Procedures
The following are basic procedures to place an image resource file onto a Web page.

 To insert an image onto a Plain Page
1. Position the cursor at the point where you want to insert a picture.
2. Select Object > Insert > Image or click Image on the New Object toolbar.  The Image

Attributes window appears.

Note:  For more information about the Image Attributes dialog box, see the topic “Inserting
Images and Graphic Objects” in the chapter titled “Key Features and Procedures.”

3. Decide how you want to insert (or create) your image:
• To insert an image from existing resources, click the Existing Resource  tab and select

an image from the image folder.
• To insert an image from a graphic library, click the Library tab and select an image

library from the drop-down list and click the image you want.
• To insert an image from using a URL, click the URL tab and enter the exact URL

address for the image you want.

Note:  URL images cannot be edited or displayed in Graphic Editor.  Because they are
linked images, they are not resources that can be edited.

• To import an image from your hard disk, click the Import button.  The Import dialog
box appears.  Select the drive and folder where the desired image is stored.  Click the
image file and click OK.  The selected image file is imported as an image resource.
Select the imported image file from the resource tree.

• To create a new image, click Existing Resource  tab and click Create .  A new image
file is added to existing resources.  Select the newly created image file from the
resource tree.

Note:  By default new images are created with a height and width of 100 pixels and are
formatted as GIF files with 256 colors.  The background is set to be the same as the Graphic
Editor worksheet (this is not necessarily the same as the Web Page background).  All of
these defaults can be changed by selecting the image and clicking the Page Setup button
on the Main toolbar.  The Image Properties dialog box appears.  Change the settings as
necessary.

• To add an image from a Twain compliant device, click Acquire .  The device driver
dialog box appears.  Use this dialog box to specify the image you want to bring in.
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When done, click OK.  A new image file is added to existing resources.  Select the
newly created image file from the resource tree.

Note:  If a device driver is not currently open, the Acquire button is inactive.  To select a
source, go to Site Manager and select File > Select Source.  The Select Source dialog box
appears.  Select a data source and decide if you want to acquire multiple images, and click
OK.  The Acquire button is now active.

4. When done, click OK.  The specified image is inserted onto the Plain Page.

To begin a “full” edit using Graphic Editor
1. Click the image you want to edit.  A grey outline appears around the image area.

Note:  If you have defined your Image Properties using Image Attributes, a graphic bounding
box with sizing handles will appear instead of the grey outline.

2. Right-click and select Object > Edit .  The Page Editor window is replaced with the Graphic
Editor window.

Note:  From a full edit, you have complete access to the pasteboard area of Graphic Editor.

To begin an “in-place” edit in Page Editor
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Double-click the image or right-click and select Object > Inplace Edit .  The graphic is put

into “in-place” edit mode.  The New Object toolbar and the Clipart toolbar appear.  The
Menu bar options are replaced with Graphic Editor selections.

Note:  From “in-place” edit you cannot place objects onto the pasteboard area.  All of your
work must be done in the Image Worksheet defined by Image Properties.  You can change
the Image Worksheet by clicking on the Page Setup button on the Main toolbar.  When
manipulating images, always define your image properties using the Page Setup button.
This insures that you can continue to use In-Place editing.  If you define your Image
Properties using the Image Attributes dialog box, you will no longer be able to use in-place
editing.

To exit Graphic Editor and return to Page Editor
• When you are done making edits, click the Windows Close button or press ALT + X and

specify whether to save or abandon your changes.  Page Editor reappears with the content
of the Plain Page displayed.

To insert a graphic object onto a Plain Page

There are several graphic objects that can be inserted onto a Web page.  These include:  a Text
Line, Graphic Image, Clipart Image, Paragraph Text, Fill, Border, Calendar, or OLE Objects.
To insert any of these graphic objects, a blank image file must be created and inserted before
the graphic object can be inserted.  Once a blank image file has been inserted onto the Web
page, it must be opened in the “in-place” edit mode.  “In-Place” edit allows you to insert
graphic objects directly into the blank image file without opening Graphic Editor.  You will
continue to see your Web page content while you update the blank image file.
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To insert a blank image file onto a Plain Page in Page Editor
1. Select Insert > Image  or click Image on the New Object toolbar.  The Image Attributes

dialog box appears.
2. Click Create .  A new image file is added to existing resources and is already selected for

you.  Click OK.  The selected blank image file is inserted.  An image bounding box appears
with the words “Blank Image .”

Note:  By default blank images are created with a height and width of 100 pixels and are
formatted as GIF files with 256 colors.  The background is set to be the same as the Graphic
Editor worksheet (this is not necessarily the same as the Web Page background).  All of
these defaults can be changed by selecting the image and clicking the Page Setup button
on the Main toolbar.  The Image Properties dialog box appears.  Change the settings as
necessary.

To begin an “in-place” edit of a Blank Image
1. Click once on the “Blank Image ” box.  A grey outline appears around the image bounding

box.
2. Double-click the image or right-click and select Object > Inplace Edit .  The image is put

into “in-place” edit mode.  The words “Blank Image ” disappear and the image background
color changes.  The New Object toolbar and the Clipart toolbar appear.  The Menu bar
selections are replaced with Graphic Editor selections.  You are now ready to insert a
graphic object into the blank image file.

To select a graphic object to insert into a Blank Image file
1. With the Blank Image open, decide what kind of image you want to insert:

• To insert a Text Line, select Object > Add > Text Line  or click Text Line  on the New
Object toolbar.  The Text Line  dialog box appears.  Type your text in the Text field
and click OK.  The text line object is inserted and the Object Toolbar–Text Line
appears.

• To insert a Graphic Image, select Object > Add > Image  or click Image  on the New
Object toolbar.  The Image  dialog box appears.  Select your image and click OK.  The
selected image is inserted.

• To insert Paragraph Text, select Object > Add > Paragraph Text  or click Paragraph
Text  on the New Object toolbar.  The image bounding box handles change and three
toolbars appear:  The Formatting toolbar, the Object Toolbar–Paragraph Text version,
and the Insert Object toolbar.  To insert text, double-click the image box and begin
typing.

• To insert a Fill Pattern, select Object > Add > Fill Pattern or click Fill  Pattern on the
New Object toolbar.  The Fill Pattern  dialog box appears.  Make your specifications as
necessary and click OK.  The fill pattern object is inserted.

• To insert a Border, select Object > Add > Border  or click Border  on the New Object
toolbar.  The Border dialog box appears.  Select your border and click OK.  The
selected border is inserted.

• To insert a Calendar, select Object > Add > Calendar  or click Calendar   on the New
Object toolbar.  The Calender  dialog box appears.  Select the type of calendar you
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want and click OK.  The Calendar object is inserted and the Object Toolbar–Calendar
appears.

• To insert a Chart, select Object > Add > Chart or click Chart on the New Object
toolbar.  The Chart dialog box appears.  Select the type of chart you want and click
OK.  The chart object is inserted and the Object Toolbar–Chart appears.

• To insert an OLE Object, select Object > Add > OLE  or click OLE on the New Object
toolbar.  The Insert New Object  dialog box appears.  Make your application selection
and click OK.  The application is launched.  When done creating the OLE object, select
File > Exit and Return to WebShop .  The OLE object is inserted.

• To insert a Clipart image, select the Clipart library from the Clipart toolbar and click
and drag the image that you want into the Image box.  Release the mouse once it is in
place.  The Clipart image is inserted.

Note:  To insert a manually drawn image you must be in full edit mode.  You cannot insert a
drawing object from “in-place” edit.  For more specific details on how to insert each of these
graphic objects look for its associated procedure later in this chapter.

2. When done, click outside the image box.  The New Object toolbar and the Clipart toolbar
disappear.  The Menu bar selections are replaced with Page Editor selections.  “In-Place”
edit is complete.

3. Continue specifying Web page content as necessary.

Resetting Image Properties and Image Attributes
There are two dialog boxes that control the global features of an image:  Image Properties and
Image Attributes.  Use Image Properties to specify image size, file format and background
color.  Use Image Attributes to specify image spacing, alignment, line borders, and alternate
text.

To reset the Image Worksheet (or Image Size) using Image Properties
1. Click Page Setup  on the Main toolbar.  The Image Properties  dialog box appears.
2. Specify the size, file format and background color for the image.
3. When done, click OK.  The graphic image presentation area is updated.

WARNING!  Do not use the command Format > Object > Properties.  This opens the Image
Attributes dialog box.  If you reset the image presentation area from Image Attributes you
will not be able to access in-place edit.  You can however use Image Attributes to set up
some space around the image, create a simple image border, or specify the alignment of
the image on the Web page.

To set up some space around the image
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Right-click and select Object > Properties .  The Image Attributes  dialog box appears.
3. Click the Space check box and specify the Horizontal and Vertical space desired.

Note:  Space measurements are defined in pixels.

4. When done, click OK.  The grey bounding box indicates the amount of space currently
specified.



Chapter 15. Using Graphic Editor

WebShop 2000 User Guide15–16        ◆   ◆   ◆

SPECIFIC FEATURES

To specify the alignment of the image
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Right-click and select Object > Properties .  The Image Attributes  dialog box appears.
3. Click the Alignment check box and click alignment option desired.

Note:  Alignment options are mutually exclusive.  Select only one.  Left and right alignment
options automatically force existing text to one side.  Vertical selections place the image “in-
line” with text.

4. When done, click OK.  The image bounding box alignment is updated.

To create a simple line border for an image
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Right-click and select Object > Properties .  The Image Attributes  dialog box appears.
3. Click the Border check box and specify the Width desired.

Note:  Width measurements are defined in pixels.

4. When done, click OK.  The image bounding box is updated.

To specify alternate text for an image while it is loading in a browser
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Right-click and select Object > Properties .  The Image Attributes  dialog box appears.
3. Click the Alternate Text check box and

specify the Text desired.
4. When done, click OK.  The image is

updated.

Exporting an Image File to Disk
Once an image file has been updated, you
may want to save the image to disk.  To do
this, open the image you want to export in
Graphic Editor and select File > Export .  The
Save As  dialog box appears.  Using the drop-
down arrow for Save as type , select the
output format you want.  Your options
include: Windows Bitmap, ComuServe GIF,
JPEG Image, Portable Network Graphics
PNG, Paintbrush Image, Targa Image, Tiff
Image, Windows Metafile, and Enhanced
Metafile.  The default option is JPEG Image.

Note:  Bitmap options each have a
specific dialog box (Figure 15.17) where
you control the image settings.

When exporting graphical objects in a
bitmapped format, specify the following:

Figure 15.17 – JPEG Export Dialog Box
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• In the Color Palette  section, set the color resolution. The options available depend on the
type of bitmap you have selected in the previous dialog box.

• In the Size in Pixels  section, set the image size. You can set the following size options: 1x1
actual size, 640x480 pix, 800x600 pix, 1024x768 pix, or Custom.

• In the Background color  section, set the background color. You can set the background
color either same as the Worksheet color, or customize by selecting color from the Choose
Color  dialog box, or set the background to be transparent (available only for CompuServe
bitmaps, or GIF images).

To export an image to disk
1. Click the image you want to edit.  A grey outline appears around the image area.
2. Double-click the image or right-click and select Object > Inplace Edit .  The graphic is put

into “in-place” edit mode.
3. Select File > Export .  The Save As  dialog box appears.
4. Using the drop-down arrow for Save as type , select the output format you want.
5. Type the File Name  you want to use.
6. Click OK.  If the export format is bitmapped or JPEG, a secondary dialog box appears.
7. Specify Color , Size, and Background .

Note:  Depending upon the format you select, some of these options may be inactive.

8. For JPEG images, decide what Encoding Method you want to use:
• For smaller files that load all at once, select Sequential (quality may be affected).
• For progressive files that load progressively, select Progressive (quality should not be

affected).

Note:  Not all browsers can display progressive images.

• For files saved in optimal standard format, select Optimize.

9. To control the file size, specify a Quality Factor from 1–100.

Note:  The lower the setting the smaller the file.  Smaller files result in lower image quality
and vice versa.

10. When done, click OK.  The image is exported to disk.

Controlling Inserted Graphic Objects
Once a graphic object is inserted into the Graphic Editor window, you manipulate them using
the Control toolbar.

Note:  Only selected Control toolbar operations are available from “in-place” edit and some
object manipulations are not available unless the object is placed within the presentation
worksheet area.

To select one or more objects by clicking on each
1. Click the first object that you want.  An object bounding box appears with resize handles

on the corners and sides.
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2. Hold down the SHIFT key and click the second object that you want.  The object bounding
box automatically re-sizes.

3. To deselect an object from the group, click on it again while still holding down the SHIFT
key.  The object is deselected and the object bounding box re-sizes to exclude the object.

To select one or more objects by lassoing them with the cursor
1. Place the cursor outside the image you want to select.
2. Click and drag the cursor until it is on the other side of the image you want to select.  A

dotted line box is created.
3. Release the mouse.  An object bounding box appears with resize handles on the corners and

sides.

To resize an object using the mouse
1. Click object (or objects) you want to resize.  A object bounding box appears with resize

handles on the corners and sides.
2. Decide how you want to resize the image.

• To resize the image proportionately, click and drag one of the corner handles.  The
object bounding box gets either bigger or smaller.  Aspect ratio is maintained.

• To resize the image without regard for its proportions, click and drag one of the side
handles.  The object bounding box gets either bigger or smaller.  Aspect ratio is
distorted.

4. When done, release the mouse to set the size.  The object is resized.

To align or resize an object or object group using Align & Size
1. Select one or more objects.
2. Select Object > Align & Size or click Align & Size on the New Object toolbar.  The Align

& Size  dialog box appears.

Note:  When a single object is selected, the align and size options are relative to the Image
Worksheet only.  Alignment options are either horizontal or vertical and the resize options
are to worksheet height or width.  When an object group is selected, the align and size
options are relative to either the Image Worksheet or to bounding box created by the objects
selected.  Alignment options include specifications for the entire group or for objects inside
the group.  Use these options to quickly resize an entire group of images relative to one
another or relative to the worksheet area.  For more information, click the dialog box Help
button.

3. Specify the operation of Align & Size using the dialog box fields and buttons as necessary.
4. When done, click OK.

Rotating and Reshaping Graphic Objects
Use the following procedures to rotate and reshape graphic objects in Graphic Editor.

To rotate a graphic object using the mouse
1. Click Select Rotate on the Control toolbar.
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2. Click once on the object (or objects) you want to rotate.  The object bounding box appears
with center point bullet.

3. Click and drag the center point to place it anywhere inside or outside the bounding box.
4. Place your mouse on one of the corner handles.  A cross-line cursor appears.
5. Click and drag the corner handle to rotate the object as many degrees as you want.

To rotate a graphic object using the Rotate dialog box
1. Click once on the object (or objects) you want to rotate.  The object bounding box appears.
2. Select Object > Rotate  or click Rotate on the New Object toolbar.  The object bounding

box handles change and a center point bullet appears.  The Rotate dialog box appears.
3. Specify the number of degrees that you want the object to be rotated clockwise or click

increase / decrease buttons.  A preview outline displays the object rotation.
4. When done, click OK.  The object is rotated.

To change an object’s shape using the mouse
1. Click Select Shape  on the Control toolbar.
2. Click once on the object you want to reshape.  The object bounding box appears with bullet

handles.

Note:  The Select Shape button works only with vector graphics, such as Windows Metafiles
(WMF) and Computer Graphic Metafiles (CGM) files, and line text objects in Graphic Editor.
This feature does not work with raster graphics, such as Windows Bitmapped (BMP) and
PaintBrush (PCX) files or paragraph text.

3. Place your mouse on one of the bullet handles.  A cross-line cursor appears.
4. Click and drag the bullet handle to reshape the object as desired.
5. When done, click outside the object bounding box.  The object is reshaped.

Note:  If you want, you can save the new shape and re-use it with other graphics.  To do this,
click Modify Shape on the New Object toolbar.  The Modify Shape dialog box appears.  Click
Save As and type a name for the shape.  The new name appears in the list of choices.

To change an object shape using one of the predefined shapes
1. Click once on the object (or objects) you want to modify.  The object bounding box

appears.
2. Select Object > Modify Shape or click Modify Shape on the New Object toolbar.  The

object bounding box handles change.  The Modify Shape  dialog box appears.

Note:  The predefined shapes include curved and linear shapes.  To return a image back to
its original shape after modifying its shape, use the Normal option.

3. Select the shape you want to use from the list of choices.  An outline of the shape appears
in the sample area.

4. When done, click OK.  The image shape is modified.
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Zooming In and Out
When working with Graphic images in full edit, you will want to get a detailed view of the
image you are creating.

Note:  The Zoom feature is not available with “in-place” edits.

To zoom in your view

• Click Zoom In  on the Control toolbar or select Zoom > Zoom In .  The image magnification
increases by 200%.  From a view that is full out, you may zoom in eight times.

To zoom out your view

• Click Zoom Out  on the Control toolbar or select the Zoom > Zoom Out .  The image
magnification decreases by 200%.  From a view that is full in, you may zoom out eight
times.

To return Zoom to normal view
• Click Actual Size on the Control toolbar or select Zoom > Actual Size .

To fit the Image Worksheet the Graphic Editor window
• Click Fit to Page on the Control toolbar or select Zoom > Fit to Page .

To zoom in on a selected object
1. Click on the object that you want to magnify.
2. Click Zoom on Selection on the Control toolbar or select Zoom > Manual Zoom on

Selection .  The selected image is magnified so that it takes up the entire window.

To zoom in on a manually selected area
1. Click Manual Zoom  on the Control toolbar or select Zoom > Manual Zoom .  The cursor

appearance changes.
2. Click and drag the cursor over the area you would like to magnify.  An outline is created.
3. Release the mouse.  The manually selected area is magnified so that it takes up the entire

window.

Creating and Updating Template Placeholders
Images can be displayed normally or in template Placeholder form.  When creating a template,
you must convert at least one graphic object (or displayed text) into placeholder form, before
the file can be saved as a template.  Depending upon the graphic object that is converted, there
are different update procedures for replacing the placeholder with new content.  When you
double-click on a placeholder from Page Editor, the editing tools (or dialog box) for the type of
object selected will appear.  The Placeholder is now in “in-place” edit.  To update the place-
holder, double-click placeholder again and the object dialog box will appear.  Replace the
contents, as necessary.  Because graphic objects are so common, there are special procedures
for updating a graphic placeholder.

Note:  Drawing objects cannot be converted into placeholder form.
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To insert a graphic object as a Normal object
1. Select Object > Add > Image .  The Image dialog box appears.
2. Select an image from the Library Image display area.
3. Click Preview .  A larger version appears in the Preview area.
4. Click OK.  The image appears with a bounding box.

To convert an  graphic object into Placeholder form
1. Click once on the image you want and right-click.  A pop-up menu appears.
2. Select Show > As Placeholder .  The graphic object appears in a Placeholder form.

Note:  Each graphic placeholder contains a button icon that identifies what kind of place-
holder it is.  Also, each graphic placeholder has a unique color.  For a listing of colors see
the topic “Normal or Template Placeholder Form.”

To insert a new graphic into a graphic placeholder from a template file

To complete this procedure, the project file must be saved as a template and then reopened.
This procedure can be done as an “in-place” edit from a Web page.
1. Click once on the graphic placeholder you want to update.
2. Double-click.  The Image dialog box appears.  The graphic object is now in “in-place” edit

mode.
3. Make your image selection and click OK.  The placeholder is converted to normal and the

new image appears.

 Note:  Depending upon the object that is converted into a placeholder, there are different
update procedures for replacing a placeholder with new content.  When you double-click
placeholder, the normal editing tools (or dialog box) will appear for the type of object
selected.  To update, most objects, double-click again and the object’s associated dialog box
will appear.

4. To exit “in-place” edit mode, click outside the image.  “in-place” edit is complete.  The
Page Editor window appears.

Inserting Graphic Images
Graphic objects have two elements, the bounding box and the image file content.  When
inserting a graphic image onto a Web page be aware of both elements.  This is particularly true
when creating a graphic placeholder.  To maintain your design, replacement images should fill
the bounding box space allocated.

Note:  The Image button in Graphic Editor (on the New Object toolbar) is different from the
Image button in Page Editor (on the Insert Object toolbar).  The Image button on the Insert
Object toolbar opens the Image Attributes dialog box so you can reuse or create a new
graphic resource.  The Image button in Graphic Editor (on the New Object toolbar) opens
the Image dialog box so you can fill the selected image file (which is an already defined
resource) with an imported graphic or a Library graphic.
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To insert a graphic image while Graphic Editor is active
1. From the Graphic Editor window in either full edit or “in-place” edit, select Object > Add

> Image .  The Image dialog box appears.
2. Select the type of image that you want—Vector or Raster .
3. Click the down-arrow next to Library Name  and select an image library.  Use the horizon-

tal scroll bar to scroll through the catalog of images.
4. Click on an image from the Library Image  display area.
5. Click the Preview check box.  A larger version appears.
6. Decide what you want to do:

• To insert the image selected, click OK.  The Graphic Editor window reappears.  The
image is inserted.

• To import an image from you hard disk, click Import .  The Import dialog box appears.
Use the dialog box fields and buttons to navigate to your selection.  Click OK.  The
Graphic Editor window reappears.  The image is inserted.

Note:  Importing an image does not update your image libraries.  To do that, see the chapter
titled “Editing Internet Design Shop Libraries.”

7. To deselect the object, click outside the box.  The object bounding box disappears.

Inserting a Drawing Object
Drawing objects have several elements, initial shape, line color, fill color, and line nodes.
When you create a drawing object you insert an initial shape and then change it as necessary.
Drawing objects can demonstrate three different bounding box handles:  (1) selected for
proportional resize or move–without line or fill edit available, (2) when initially inserted or
selected–with line or fill edit available, or (3) selected for node edit.  (Figure 15.18)

To insert a drawing object
1. From the Graphic Editor window in either full edit or “in place” edit, select Object > Add >

Drawing  or click Drawing on the New Object toolbar.  The Drawing Object toolbar
appears.

Figure 15.18 – Drawing Object Selection Handles

Object unselected 1. Selected for propor-
tional resize or move

2. Selected for line or fill
edit, resize, or move

3. Selected for node
edit



Chapter 15. Using Graphic Editor

WebShop 2000 User Guide ◆   ◆   ◆         15–23

SPECIFIC FEATURES

2. Select one of the drawing tools and click and drag the tool over part of the image work-
sheet.  An object outline appears.  This defines the initial shape.

Note:   Choose from either the Rectangle, Ellipse or Polygon tools.

3. Release the mouse.  The drawing object is inserted and object is selected for line or fill
editing.

4. Click outside the object.  The bounding box handles and the Drawing toolbar disappear.

To resize a drawing object
1. Click on the drawing object.  The object is selected for moving or resizing.  Line or fill

editing is not available and the Drawing Object toolbar appears.
2. Decide how you want to resize the image.

• To resize the image proportionately, click and drag one of the corner handles.  The
object bounding box gets either bigger or smaller.  Aspect ratio is maintained.

• To resize the image without regard for its proportions, click Edit Object  on the
Drawing toolbar.  The object is selected for moving or resizing with line and fill
editing available.  Click and drag one of the side handles.  The object bounding box
gets either bigger or smaller.  Aspect ratio is distorted.

3. When done, release the mouse to set the size.  The object is resized.
4. Click outside the object.  The bounding box handles and the Drawing toolbar disappear.

To change the line color and fill color for a drawing object
1. Click on the drawing object.  The object is selected for moving or resizing.  Line or fill

editing is not available and the Drawing Object toolbar appears.
2. Click Edit Object  on the Drawing toolbar.  The object is selected for moving or resizing

with line and fill editing available.
3. Decide how you want to edit the drawing object.

• To change the line color from the default color palette, click Pen Color  on the Draw-
ing toolbar.  A color palette appears.  Click on the color that you want.  A color palette
disappears. The line color is updated.

Note:  To set a transparent line, click the upper left color box that contains an X.

• To change the fill color from the default color palette, click Brush Color  on the
Drawing toolbar.   A color palette appears.  Click on the color that you want.  A color
palette disappears. The fill color is updated.

• To change the default line color and line width, click Pen Color  on the Drawing
toolbar.  A color palette appears.  Click More .  The Set Default Line Options dialog
box appears. The click the Color Library  drop-down arrow.  Select a color palette.
The color palette is updated.  Click on the color that you want.  Click the increase/
decrease arrows to change the line width setting.  When done, click OK.  The color
palette disappears.  The line color and width is updated.

• To change the fill color using a color library, click Brush Color  on the Drawing
toolbar.   A color palette appears.  Click More .  The Choose Color dialog box appears.
The click the Color Library  drop-down arrow.  Select a color palette.  The color palette
is updated.  Click on the color that you want and click OK.  The color palette disap-
pears.  The fill color is updated.
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Note:  The default color palettes that first appear for a line and fill color edit are both the
same and are updated together.  When you add a new color using a color library palette or a
custom color, the selected color is added to the default color palette as a custom color
swatch in the bottom three rows.

4. To continue, click outside the object.  The bounding box handles and the Drawing toolbar
disappear.

Creating Map Link Links
Just as you can select text and make it a link, you can also select any graphic image and make it
a link.  To do this, click on an inserted image and select Insert > Link .  Furthermore, you can
assign links to different parts of the same graphic image.  This is called assigning Map Link
links.

To assign Map Link links
1. Place a graphic image on a Web page.
2. Double-click on it.  The image shifts to “in-place” edit.
3. Select Object > Map Link  or click Map Link  on the New Object toolbar.  The Map Link

toolbar appears.

Note:  This toolbar has three buttons.  Each button defines a different area shape.  Choose
between square, circle or polygon.

4. Select one of the tools and drag the mouse over part of the image.  This defines the link
area.

5. Release the mouse.  The Link dialog box appears.
6. Specify the link for this part of the image and click OK.  The image reappears.

Note:  Once you have assigned a URL link to a mapped area of the image, you can resize
the area or change its attributes.

7. When done assigning links, click outside the image.  The image returns to normal.

To resize the link area or change the link attributes
1. Double-click on the image that has the image map links.  The image shifts to “in-place”

edit.  The link areas are displayed.
2. Click once on the area you want to select.
3. Click on it one more time.  The Map Link Editing toolbar appears.  The resize handles

appear.

Note:  This toolbar has three buttons.  Each button performs a different edit function.
Choose between edit nodes, edit object, or edit link.  Once selected the object is ready to be
resized.

4. Click and drag one of the resize handles and resize the image map accordingly.

Note:  If you click Edit Object, the resize handles are replaced with the object node bullets.
Do not resize the object by clicking and dragging the object nodes.

5. When done editing, click outside the image.  The image returns to normal.
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Inserting OLE Objects

WebShop supports OLE 2 (Object Linking and Embedding).  You can launch other applications
from inside WebShop, create a document or picture in that application and bring it in WebShop.

If you prefer to work in other applications, this can be very useful.  You may perform these
functions without leaving the other application, then insert the result automatically in
WebShop’s work area.

As an example, let us create a simple picture in the Windows Paint program, and place it in the
Image Worksheet.

To create a simple picture and place it in the Image Worksheet
1. Click OLE on the New Object toolbar.  The Insert New Object  dialog box appears.  A list

of available programs is displayed.  These are programs that support OLE.

2. Click Paintbrush Picture  and click OK.  The Paint application opens.

3. Create a simple picture then select File > Exit & Return to WebShop .

Note:  The Paint program closes and the picture you created is placed in the Image Work-
sheet.



Chapter 16.
Dynamic Pages and ASP
Technology

Introduction
Dynamic Pages are the Web pages that perform database operations based on parameters and
conditions that you define.  Dynamic Pages contain Active Server Page (ASP) technology that
lets you dynamically present information based on visitor interaction.  The terms Dynamic Page
and ASP Page are used interchangeably.  Many Dynamic Pages use forms that ask a visitor for
information.  Based on visitor input, certain data can be displayed as feedback or special
processing can be executed.  The most frequent Dynamic Page applications include (1) sending
email, (2) redirecting a viewer to a URL, (3) adding form input into a database, (4) creating a
query/search page, or (5) issuing a cookie and requesting data from the server database based on
a cookie that as been retrieved.  However, the applications that you can design are limited only
by your imagination.

Note:  For more information on these specific applications, see the Supplemental User
Guide found on the program CD titled “Dynamic Pages.”

Topics covered in this chapter include:
• Dynamic Page Window Display
• Associated FrameSet Window Display
• Dynamic Page Toolbar and Menu Options
• Dynamic Page Actions and Icons
• Dynamic Elements
• Getting Started
• Specifying Your Dynamic Page Actions

Dynamic Page Window Display

To manage the operations performed by a Dynamic Page, the Dynamic Page window that
appears when you first open a Dynamic Page includes as at least two parts:  (1) the Dynamic
Page Manager window that is used to specify the Dynamic Page actions and (2) the Page Editor
window that is used to design a Feedback Section that will conditionally display information to
a Web site visitor.
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It is important to keep in mind that a Dynamic Page contains both action specifications for
controlling Dynamic Page operations and text and graphic specifications for controlling what
appears in the browser window whenever a page display is specified.  The Dynamic Page
Manager window displays the actions that the Dynamic Page will perform and their sequence
(from top to bottom).  The Page Editor window displays the text and graphic specifications for
Feedback Sections that appear only when a Feedback Section action is specified.  When
constructing a Dynamic Page, most likely, you will specify more than one Feedback Section
action in your action list and will consequently define more than Feedback Section display.
That’s because a Dynamic Page lets you set up different information displays based upon
varying conditions.  That’s the whole point of a Dynamic Page!

Unlike a Plain Page, a Dynamic Page lets you dynamically present information based upon
varying conditions.  It’s up to you to define the conditions that will trigger each information
display using the available Dynamic Page actions and then define the information display that
the visitor will see using the page design tools that you have already learned.  Every information
display that you present must be specified as a Feedback Section before it can be viewed by a
Web site visitor.

Logical Layout Note:  An information display defined as Feedback Section is an resource to
a Dynamic Page and does not appear on Logical Layout.  Only the Dynamic Page icon will
appear not the individual information displays.  Clicking on a Dynamic Page icon from
Logical Layout, lets you access the Dynamic Page action listing from which you can then
access any of individual Feedback Sections that are associated with that Dynamic Page.

Physical Layout Note:   An information display defined as Feedback Section does not
appear on Physical Layout - only the *.ASP resource file that contains the individual
Feedback Sections.  If you use a Dynamic Page as a frame resource (FCO) for a FrameSet
Page each Dynamic Page FCO becomes a separate *.ASP resource file.  You may create

Dynamic Page Window for a Single Dynamic Page
with Frame Manager Open

Frame
Manager Window

Dynamic Page
Manager
Window

Page Editor
Window

Frame Manager
FCO Listing

Dynamic Page Manager
Action List and Action Icons

Dynamic Page Window for a Single Dynamic Page

Dynamic Page Manager
Action List and Action Icons

Page Editor
Window

Dynamic Page
Manager Window

Page Editor windows are visible to Web site visitor only
when Feedback Section is specified.  Cross-hatch indicates

that a Feedback Section is not specified.

Frame and Dynamic Page Manager
windows are not visible to Web site

visitor.  For development purposes only

Figure 16.1 Dynamic Page Window for a Single Dynamic Page
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ASP resource files directly from Physical Layout.  These resource files can then be used
independently as Frame Content Overlays (FCOs).  For more information see the chapter
titled “WebShop Frames.”

FrameSet Note:  If you create a Dynamic Page from Logical Layout and then click either
Split Horizontal or Split Vertical on the Frames and Page Editor toolbar, the Dynamic Page is
automatically converted into a FrameSet Page.  By clicking either of the two Split buttons,
you in effect are preparing a FrameSet Page that uses ASP resource files–not a Dynamic
Page that stands alone as a Logical Page.  If you continue to divide the frame areas, you will
be creating separate Dynamic Page resource files.  Each ASP resource file, when displayed
as part of a FrameSet Page, contains its own action listing.  Any FrameSet Page can make
use of ASP resource files as individual Frame Content Overlays. For more information see
the topic “Associated FrameSet Window Display” later in this chapter.

To resize the Dynamic Page Manager window or the Page Editor window
1. Position the cursor over the window border between the Dynamic Page Manager window

and the Page Editor window.  The cursor changes shape.
2. Click and drag the window border to a new position.  The window border moves with the

cursor.
3. Release the mouse at the new position.  The window is resized.

Associated FrameSet Window Display

Any FrameSet Page that uses a Dynamic Page as a Frame Content Overlay for  one of the
specified frames will display the Dynamic Page Manager window and Page Editor window in
the frame area specified.

Remember!  ASP resource files when opened in Page Editor always generate a double
window display that includes a Page Editor window and a Dynamic Page Manager window.
To view the page as it will appear in a browser, you must minimize the Dynamic Page
Manager window.

Normally, a FrameSet Page when opened in Page Editor displays a separate “window” for each
frame area.  Each frame area can have one or more separately assigned page resources (or
Frame Content Overlays) that can appear in that frame area.  The “windows” defined by each
frame area can be resized by repositioning the window border between frame areas.  By
repositioning the window border between frame areas, you change the Frame Definition
associated with the page.

When a Dynamic Page is displayed in a frame, the frame area assigned to the ASP resource file
is divided into a Page Editor window and a Dynamic Page Manager window.  These ASP
resource file “windows” can be resized by repositioning the window border between the Page
Editor window and a Dynamic Page Manager window.  Resizing these window areas does not
change the Frame Definition associated with the page.  To affect the Frame Definition associ-
ated with the page, one of the frame “windows” between frame areas must be repositioned.
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To resize a FrameSet window with an ASP resource file so that it is WYSIWYG
1. Position the cursor over the window border between the Dynamic Page Manager window

and the Page Editor window.  The cursor changes shape.
2. Click and drag the window border so that the Dynamic Page Manager window is com-

pletely obscured.  The window is now resized to approximate what will be seen in the
browser.

Frame Manager Note:  By clicking the Frame Manager button on the Frames and Page
Editor toolbar, the Frame Manager window appears.  This window is not visible to a Web site
visitor nor does it affect the Frame Definition associated with a page.  To insure that you
screen display is WYSIWYG minimize the Frame Manager window by clicking on the Frame
Manager button.

Dynamic Page Toolbar and Menu Options

The Dynamic Page toolbar and menu appears whenever the cursor is placed inside a Dynamic
Page.  To access the menu options, use the Dynamic Page menu located on the Menu bar.  The
toolbar operations and menu commands are conditional and become active only when you click
on an action list icon or when you place your cursor in the Page Editor window.  If you right-
click within the Dynamic Page Manager window, a pop-up menu appears.  Many of the options
listed below are available from this pop-up menu as well (Figure 16.11).

Figure 16.2–Frame Set Page Window with Multiple Dynamic Pages Specified

DynPages 1, 2, 3, and 4 are separate Frame Resources (FCOs) for one
FrameSet page identified as FrameSet1 on Logical Layout
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Toolbar Buttons and Menu Options
• Delete .  Deletes the selected item from the resource tree in the Dynamic Page Manager

window.
• Insert (or Insert Dynamic Element) .  Inserts a Dynamic Element into the Page Editor area

to the right of the Dynamic Page Manager window.  To activate the Insert feature, you must
select one of the Frame-Content Overlay icons in the Dynamic Page Manager window.

• Add Into .  Inserts a subordinate action into the Dynamic Page action list.  The inserted
action is subordinate to the selected action and is placed at the end of the action’s subordi-
nate list.

• Insert Before .  Inserts an action into the Dynamic Page action list.  The inserted action is
placed before selected action and on the same level as the selected action

Dynamic Page Actions and Icons

A Dynamic Page is composed of actions that you specify using the Dynamic Page Manager.
Everytime you insert an action into the Dynamic Page action
listing, an action icon appears in the Dynamic Page Manager
window.  You manage the dynamic page actions by clicking
the action icons and altering the action specifications.  The
action icons displayed in the Dynamic Page Manager window
are not visible to a Web site visitor.  They are presented for
development purposes only.

Once your site is generated, the actions that you specify are
compiled into ASP script.  This ASP script is created by
WebShop.  Your action listing is organized in a hierarchical
fashion.  The ASP scripting generated by WebShop is com-
piled from the top down, with subordinate actions generating
subordinate ASP script from left to right.

Note:  The actions you specify for your Dynamic Page are
executed only when the Dynamic Page is opened by a
visitor to your Web site.

One of the hallmarks of an ASP page is that temporary valuesFigure 16.5 – Dynamic Page Icons

Figure 16.3 – Accessing Dynamic Page Operations

insert

delete
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are created during the operation of the Dynamic Page.  These temporary value can come from
many sources.  They can come from the Web server, if the action that obtains the data is defined
as a Query.  They can come from the visitor’s PC, if the defined action is a Request.  They can
also be internally generated by the Dynamic Page itself.  Keep in mind, however, that these
temporary values are just that–temporary.  All of your Dynamic Page values will return to their
initial settings once the Web site visitor leaves the page.  The only values that are permanent are
the ones uploaded to your server after generating the Dynamic Page or the ones that you write
out to the server database.  This concept is important particularly when creating visitor IDs or
record IDs.

The following actions can be executed from a Dynamic Page.  Each action has a separate icon
that indicates the action performed.
• Query - queries a database and returns a result, or executes a database operation on a

selected record.  There are only four operations that can be performed using Query : Select,
Insert, Delete, or Update.  To establish database connectivity, you must add the RecordSet
operation into a Query operation before specifying the type of operation to be performed.

• Send Mail  - issues email to one or more email addresses.  Specify From , To, Cc, or
Subject .  Also specify an SMTP server address as necessary.  In the body of the email to be
sent, you can design a Plain Page fragment that can include images, tables, or dynamic
elements.

• Feedback Section  - displays feedback from a Plain Page that you design.  A Feedback
Section can be designed with (or without) Dynamic Elements.  Use this action whenever
you wish display text or graphics to the viewer.

Remember!  Feedback Section defines the action of displaying information and while more
than one Feedback Section can be associated with a Dynamic Page; only one resource file
is created for the Dynamic Page, not several independent resource files.  This means that a
Feedback Section is not independent of its associated action listing nor can a Feedback
Section make use of “predesigned” resources in the same way that a FrameSet Page can
make use of independent page resources.  If you want to create a Dynamic Page that uses
“predesigned” resource files, create a FrameSet Page and use an ASP resource file as one
of the Frame Content Overlays.

• Request - establishes the value for a Dynamic Page variable by obtaining data from: (1) a
form, which is completed by the user during the current session, (2) a query string, which is
an ASP-generated dynamic value, (3) a cookie, which is an generated value that is stored
on the user’s computer and identifies the user, (4) a client certificate, which is server value
that enables the transmission of secure communication, (5) a server variable, which is a
temporary (or permanent) value stored on the server, (6) an application element, which is a
value that references a .DLL file or some other application element, or (7) a session
element, which is a server value that references the current session’s status.  This action is
used whenever you wish request information for subsequent ASP processing.

• Redirect to  - redirects the viewer to different URL address or HTML page within the site.
A redirect action can be specified using a parameter or by specifying the URL location
directly.

• Condition - establishes two processing alternatives based upon a true or false condition.
Condition statements can be nested within each other to provide multiple processing
alternatives.  Each processing result must be separately specified.  Each condition statement
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is composed of three parts:  If-Then-Else.  Use this action to make branching evaluations.
• Statement - sets (or resets) a variable, value, parameter, query output parameter, or cookie

value as necessary.  Use this action direct the processing of a Dynamic Page by assigning
values directly.

• Cookie - writes a small text file to the user’s hard disk so that he/she can be identified at a
later date.  This small text file (or cookie) can be retrieved by the server and matched to a
cookie record.  Use this action to create a unique identifier for visitors to your Web site.

• RecordSet - establishes a database connectivity so that query results can be displayed to a
Web site visitor.  To initiate this operation, you must first add a Query action and then add
a RecordSet into the Query .  The Query action opens the database and accesses current
values whereas the RecordSet action allows you to manipulate the values.

 • Lock -  [investigate this more]
• Unlock - [investigate this more]

Dynamic Elements

A Dynamic Element is an element that has a changeable
value based on the processing of a Dynamic Page.  A
Dynamic Element can be defined as a parameter, variable,
or a query record field.  To enable a field to display as a
Dynamic Element, the value assigned to the parameter,
variable, or query record field must be obtained from a
defined source such as a database, a input form, a request
action, or other Dynamic Page action.

To create a Dynamic Element based on a query, the
database, table, and field must be specified through a query
Select operation.  Once the Dynamic Element has been
specified, it can be inserted onto a Feedback Section as a
query output field.  Query output fields, by default, assume
the field characteristics assigned by the source database.

Getting Started

To get started you first need to create a Dynamic Page and set the properties for the Dynamic
Page using the Property Sheet for Dynamic Page  dialog box.  The settings that you establish
here are used later when performing Dynamic Page operations.  However, you can add and
modify these settings at any time.

Figure 16.6 – Dynamic Elements
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To set up your Dynamic Page properties
1. Double-click the ROOT icon.  The Property Sheet for Dynamic Page  dialog box appears

with the Input Parameter  fields displayed.
2. Decide what you want to do.

• To add a parameter, click inside the New Parameter  field, type a parameter name, and
click Add .

• To add a variable, click Variables tab.  The Variables fields appear.  Click inside the
New Variable field, type a variable name, and click Add .

• To add a cookie key, click Cookie tab.  The Cookie fields appear.  Click inside the
New Key field, type a key name, and click Add .

Note: To specify a cookie name, expiration date, processing for check security  domain or
path, as necessary, use the fields that display in the General section.

3. When done, click OK.

Property Sheet for Dynamic Page
The Property Sheet for Dynamic Page dialog box contains the following tabs: Input Parameter ,
Variables , and Cookie .  Use this dialog box to define the input parameters, variables and
cookie keys used when performing Dynamic Page operations.  To save your specifications, you
must click OK when exiting this dialog box.

Figure 16.7 – Property Sheet for Dynamic Page Dialog Box
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Use the following definitions when use the Property Sheet for Dynamic Page dialog box.
• A parameter is an identified value that

you define for use with a Dynamic
Page. A parameter must have two
parts: a name and a value.  Parameter
values are either assigned directly or
imported and are defined as alphanu-
meric strings. You can leave a param-
eter empty or assign it a default value.

• A variable is very similar to a param-
eter except that a variable is used to
perform an operation whereas the a
parameter is used to hold a result.  A
variable must have two parts: a name
and a value.  Variable values are either
assigned directly or imported and can
defined either as and alphanumeric
string or as a number. You can leave a
variable empty or assign it a default
value.

• A cookie is a small file located on the client’s computer.  These files contain persistent state
information, such as user information.  The server, where the Web site resides, can then
request this information from the client browser to perform a task.  Two tasks are required
when using cookies.  First, they must be sent and written to the client computer.  Second
they must be retrieved/requested by the server from the client computer.  Each cookie must
have a name and value (cookie key).  Complex cookies, like cookie dictionaries, have more
than one key associated with a page.  Keys can have any of the following attributes:

• Domain–This makes sure that when the cookie is requested it will only go back to its
own domain.

• Expiration Date–This is a date that the cookie will expire and remove itself from the
client computer

• Path–This is the file path that identifies the page from which the cookie issued; it also
limits server requests for cookie information to the original page that issued it.

• Secure–This feature will require a secure connection over the Internet before the cookie
is sent.

To add a parameter
1. Click the Input Parameters  tab.
2. Click inside the New Parameter  field, type a parameter name, and click Add .  The new

parameter is listed in the Parameter List .

To assign a default value to a listed parameter
1. Select the parameter from the Parameter List , click the Modify  button.  The Modify  dialog

box appears.
2. Type the default value in the Change Value  field and click OK.  The default parameter

Figure 16.8 – Property Sheet for Dynamic Page
Dialog Box (Input Parameters Tab)
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value is assigned and appears in the
Parameter List .

Note:  You can also use to Modify
dialog box to change the parameter
name.

To import a parameter or variable
from another Dynamic Page
1. Click the Import button.  The Import

List dialog box appears.
2. Specify the Dynamic Page that

currently contains the parameter or
variable.

3. Select the parameter or variable from
the List of Parameters/Variables .

4. Click the Arrow button to transfer
your selection to the Import List .

5. To complete the import, click Import .  The imported parameters or variables now appear in
the Parameter List .

To add a variable
1. Click the Variables  tab.
2. Click inside the New Variable  field, type a variable name, and click Add .  The new

variable is listed in the Variable List .

To add a cookie key
1. Click the Cookie tab.
2. Click inside the New Key field, type a

key name, and click Add . The cookie
key is added the Key Name List .

To specify cookie key attributes
1. Click inside the Cookie Name field,

type the cookie name, press TAB to
move between fields, type values for:
Expires , Domain , and Path as
necessary.  To specify the use of
secure transmission, check the Secure
box.

2. To save your attributes, click OK.
The cookie attributes are specified.

Note: Cookie attributes apply to all
Cookie Keys for the current Dynamic
Page. These attributes cannot be
individually assigned.

Figure 16.9 – Property Sheet for Dynamic Page
Dialog Box (Variables Tab)

Figure 16.10 – Property Sheet for Dynamic Page
Dialog Box (Cookie Tab)
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Specifying Your Dynamic Page Actions

Once you have defined your parameters and variable, you are ready to start specifying your
Dynamic Page actions.  To specify an action, you can either insert an action before a selected
action or add an action into the selected action.  The distinction is important since your action
listing is organized in a hierarchical fashion.  Actions inserted before a selected action are on the
same hierarchical level and will be performed top down.  Actions added into the selected action
are subordinated to the selected action and will be performed from left to right, one the initiat-
ing actions has been performed.

The menu option Insert Before  places actions on the same hierarchy level as the selected
action.  The menu option Add Into  places actions on the next subordinate level at the end of any
previously entered subordinate actions.

To begin adding actions
1. Click the Root icon to select it.
2. Right-click and select Add Into .  A fly-out menu appears.
3. Select the action that you want.  The action icon is inserted at the first hierarchy level

below the Root icon.

To add additional actions
1. Decide if you want to add the action on the same level in front of a selected action or as a

subordinate action OR if you want to add a new subordinate action on the same level or a
new action that is one hierarchy level up
• To add an action on the same level, select an action, right-click and select Insert

Before.  A fly-out menu appears.  Select the action that you want.  An action icon is
inserted before of the action selected at the same hierarchy level as the selected action.

• To add an action as a subordinate action, select the action that begins the subordinate
list, right-click and select Add Into .  A fly-out menu appears.  Select the action that
you want.  An action icon is inserted at the end of the subordinate list as a first-level
subordinate action.

• To add a new subordinate action on the same level, select a subordinate action right-
click and select Insert Before.  A fly-out menu appears.  Select the action that you
want.  An action icon is inserted before of the action selected at the same hierarchy
level as the selected action.

• To add a new that is an action that is one hierarchy level up, select the next closest
action that is one-level higher, right-click and select Add Into .  A fly-out menu
appears.  Select the action that you want.  An action icon is inserted at the end of the
subordinate list as a first-level subordinate action.

Frequent Uses and Associated Conditions or Restrictions
The following table identifies the frequent uses associated with each action and any Associated
Conditions or Restrictions.

Action Frequent Use and Associated Conditions or Restrictions
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Query Used to obtain information from the server database; no specific
conditions or restrictions apply.  This action can be inserted onto a
Dynamic Page at any point.  There are four query operations–Delete,
Insert, Select, and Update; use the Criteria tab to limit the execution of
the query to specific conditions.  The Criteria tab is available with
Delete, Select and Update queries.  When reporting Query Results back
to a Web site visitor using a Feedback Section, insert a RecordSet
action after the Query action and before the Feedback Section action.

Send Mail Used to send email notification over the Internet; no specific conditions
or restrictions apply.  This action can be inserted onto a Dynamic Page
at any point.

Feedback Section Used to display information to the Web site visitor; no specific condi-
tions or restrictions apply.  This action can be inserted onto a Dynamic
Page at any point.  When used to report Query Results to a site visitor,
insert a RecordSet action after the Query action and before the Feed-
back Section.  When inserting Dynamic text, the Dynamic elements
must be defined as a parameter, variable or query output element using
either the Property Sheet for the Dynamic Page  or Query Properties
dialog boxes prior to being inserted onto a Feedback Section.  If used
with a Condition action, the Feedback Section will only display if the
initiating “OK” or “NO” action is performed.

Request Used to retrieve and store data in a Dynamic Page; no specific condi-
tions or restrictions apply.  This action can be inserted onto a Dynamic
Page at any point.  Variables used to initiate and store the requested
data must be defined using the Property Sheet for the Dynamic Page
dialog box prior to specifying the Request action.

Redirect to Used to retrieve and store data in a Dynamic Page; no specific condi-
tions or restrictions apply.  This action can be inserted onto a Dynamic
Page at any point.  Variables used to initiate and store the requested
data must be defined prior to specifying the Request actions.

Condition Used to define two processing alternatives based upon a true or false
condition; no specific conditions or restrictions apply.  This action can
be inserted onto a Dynamic Page at any point. The processing alterna-
tives specified by a condition statement are only executed when (and
if) the initiating condition is evaluated; the resulting actions are
subordinate to the initiating action.

If a subordinating action statement (either “OK” or “NO”) is left
unspecified, then the next initiating action is performed.  If you wish to
make multiple evaluations that specify actions for only true (or false)
conditions, you can “nest” Condition actions within one another.  The
last subordinated action statement in the “nested” series, if left unspeci-
fied, causes the next initiating action to be performed. This enables you
can chain together “one-sided” condition statements if you want.

Statement Used to assign a value to a variable while a Dynamic Page is complet-
ing its processing; no specific conditions or restrictions apply.  This
action can be inserted onto a Dynamic Page at any point.  To assign a
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value, you must specify an operation that will construct the variable’s
new value given the variable’s current value.

Cookie Used to assign a value to a variable and then write that value to the
visitor’s PC.  To assign a value, you must specify both the cookie key
that will store the temporary value and the variable that contains the
value that you wish to write onto the visitor’s PC.  ; no specific
conditions or restrictions apply.  This action cannot be inserted if a
Feedback Section has already inserted.  The Cookie action must be
performed prior to the display of a Feedback Section.

RecordSet Used establishes database connectivity so that query results can be
displayed to a Web site visitor; no specific conditions or restrictions
apply.  This action can only be inserted once the initiating Query action
has specified which database will be queried.  

Lock [needs to be clarified]
Unlock [needs to be clarified]



Part 4
COMPLETING YOUR SITE

This part of the User Guide examines the back-end procedures used to generate and upload
your Web site.  It also looks at how you might import a Web site from the Internet.

Part 4 includes:
• Generating and Uploading Your Site
• Import Site



Chapter 17.
Generating and Uploading Your Site

Introduction

When you are ready to begin developing your Web site, you must arrange for hosting services
before you begin testing out your E-commerce site.  Unlike a standard Web site, you must
generate and upload your E-commerce site to an NT-server that is 100% compatible with Active
Serve Page (ASP) technology before you can view and test your E-commerce Web pages with a
browser.  Because your E-commerce Web pages make use of ASP technology, to function
properly, they must access and update the database that stores your products and customer
orders.  Most PC systems do not have this capability—however, an NT-server that is 100%
compatible with ASP technology does.  To understand this, you must know what a hosting
service does and what kinds of system requirements are necessary to successfully host your
Web site.

Topics covered in this chapter include:
•   Selecting an ISP or Web-Hosting Service
•   Hosting Requirements
•   Active-X Component Registration
•   Boomerang Software As a Web-Host Provider
•   What is Your Integrated CNQ Project File?
•   Saving Your Files in CNQ Format
•   Generating and Uploading Your Web Site
•   Uploading A Revised Site
•   Uploading Selected Files

Selecting an ISP and a Web-Hosting Service

To arrange hosting services, you will need access to an Internet Service Provider (ISP) or a
Web-hosting service provider.  These two providers are not the same.  However, while most
ISPs do offer Web-hosting services, most Web-hosting providers do not specialize in Internet
access accounts.
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What is an ISP?
An ISP is a provider who connects you to the Internet.  They offer services such as email, dial-
up or direct access, and, of course the capability to surf the Web.  With an ISP, you gain full
access to the World Wide Web.  Normally, this means that you set up an account and make a
connection between your PC and the ISP’s server.  With this connection, you can surf the Web.
To make this connection, most people use a modem.  This is using a Dial-up Account.  How-
ever, if you want to get fancy, you could have a dedicated line that connects your PC to an ISP-
server.  Some people use a direct access provider such as, MediaOne.  What is important here is,
not that you have one or the other kind of networking, but that you know how you are going to
establish your connection with your ISP—by a modem or though a dedicated line.

What is a Web-hosting Service Provider?
A Web-hosting service provider, also known as a Web-hosting company, is a company that
hosts Web sites on the Internet for others.  Their only customers are those who want to put a
Web site on the World Wide Web.  They are not looking to give Internet access to individuals.
That’s the job of an ISP!  They are only looking to provide hosting services to individuals (or
companies) who want to “publish” a site on the Internet.

Selecting an ISP
If you currently are a customer of America Online (AOL), you have already selected an ISP;
however, you should know that you might not be able to use them as a Web-hosting service.
Web sites have specific hosting requirements (such as, the 100% compatible with ASP technol-
ogy requirement for one) that AOL may not be able to satisfy.  However, AOL does provide 2
Mb. of free Web space to its customers.  So, if you intend to put up a standard Web site, you
might want to consider using your AOL account.  If you are not a customer of America Online,
then you must find an ISP that gives you the features that you want.  Typical features to look for
in an ISP include monthly cost, email service, connection method, and speed of transmission.

Selecting a Web-hosting service
There are many factors that influence your selection of a Web-hosting service, not the least
among them are the specific requirements for hosting a Web site (see the topic “Hosting
Requirements” later in this chapter).

Before looking for a Web-hosting service, you will want to decide whether you want a full
domain Web site or a sub domain Web site.  A full domain Web site is a uniquely identified
Web site using a licensed URL (for example, www.yourname.com).  A sub-domain Web site is a
uniquely identified Web site that leases space under a preexisting URL (for example,
www.ISPdomainname.com/your name).  When making the full- or sub-domain decision, you
will want to consider how you intend to advertise your Web site.  Most companies seek to have
a full-domain Web site since it more specifically advertises their company.  If you do choose to
go with a sub-domain Web site, you will in effect be advertising someone else’s Web site and
directing them to use a specific subfolder under that domain name.  There are some clear cost
advantages, but it really comes down to the issue of marketing.

If you choose to setup a full-domain Web site, you will need to choose and register your full
domain URL before uploading your Web site to a hosting service.  To search for and verify the
availability of a domain name you like, access the “WHOIS search?” function from any of the
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domain name registration services.   One such service is Network Solutions, which can be
reached at www.networksolutions.com.  The cost and duration for registering a domain name
varies but generally it is $70 for two years with a $35 charge for each additional year after the
first two.  Many hosting services will, for a fee, help you register your domain name.  If you
choose to go the sub-domain route, you will be using your hosting service’s URL domain.  In
such cases, there normally is no setup fee.

To better evaluate your Web Hosting service provider, you should be concerned with a number
of generic factors that are not specific to your Web site.  These include:

••••• Method of access .  You will access your Web site via the World Wide Web using a
browser or via an FTP application.  If your Web-hosting service is not your ISP, you will
be limited by your ISP mode of access not your Web-hosting service mode of access.
Web-hosting companies usually run on faster lines than ISPs.

••••• Download transfer .  Normally stated as megabytes (or gigabytes) per month which,
roughly translated, is a measure of total pages downloaded per month by Internet users  (or
you can think of it as total number of hits per month).  If you anticipate a high rate of
usage, some companies will tack on an additional charge for usage that exceeds the
standard offer.  Some sites offer unlimited download transfer, but you will want to verify
exactly what that means before signing up.

••••• Storage space offered .  Normally, storage is offered as so many megabytes (or gigabytes)
per site for a flat rate.  This is one of the major variables in selecting a Web-hosting service.
If you anticipate a large number of graphics or a large database, then you will need more
storage space.  Without embellishment an E-commerce site with a modest product database,
currently requires 3–5 megabytes of storage.  An average amount of storage space offered
for a flat rate is currently between 5–20 megabytes.  Over time, your database will begin to
accumulate data, so you don’t want to max out too quickly.

••••• FTP capability .  It may sound obvious but you have to send files over the Internet via FTP.
Any Web-hosting service that does not offer this should not be used.

••••• Tech support .  You will want to ask about tech support.  Normally you will not need much
tech support, but when you do it is a great thing to have.  Tech support concerns issues such
as Internet access failures (customers cannot call up your site); FTP failures (specific
images or pages not being displayed), file retention and backup procedures, Web site
installation (including security).  A good service should offer tech support in these areas.

••••• Domain name registration .  If you want to have a full domain Web site and also want help
registering it, many Web-hosting companies offer registration services to nurse you through
the process.  You can do this on your own, but it’s often nice to get a little help along the
way.

••••• Initial setup fees.   Most companies will assess an initial set up fee.  Depending upon the
provider this may or may not apply to sub-domain Web sites.

Hosting Requirements

A Web site has some very specific requirements that you must be aware of when looking for a
Web-hosting service provider.  These requirements are summarized below.
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••••• NT-server that is 100% compatible with ASP technology .  To run an E-commerce site
created by this program, your hosting service must run an NT-server that is 100% compat-
ible with ASP technology.  This requirement is normally met by an NT-server that has
Microsoft Internet Information Server (version 3.0 or higher) installed.  Microsoft Internet
Information Server (IIS) is a Web site management program and is capable of interpreting
Active Server Pages (ASPs).  These pages are critical to your Web site.  This program
manages your site properties and folder security.  For Windows ’95 users an alternative
Web site management program would be Peer Web-server.

••••• Active-X Component Registration .  WebShop’s E-commerce functionality right now
makes use of Active-X component technology for sending email.  The Active-X compo-
nent is a program developed by Boomerang Software that resides not in your HTML files
but on your Web-hosting company’s NT-server.  The Active-X component is a *.DLL file
that must be registered on your Web-hosting company’s NT-directory of Active-X compo-
nents.  For successful hosting of your site, you need to request that your Web site / ISP
provider register the Active-X component on the NT-server that is hosting your site.

••••• Site Security and Folder Security .  You will want to insure security over your Web site.
That means your Web site administrator will have to place access restrictions on your entire
Web site during development and more specifically on your Administration folder and
Database folder once you decide to go live.  Make sure you select a Web-hosting provider
that will correctly set up the security measures covered in the chapter titled, Maintaining
Security and Backing up Your Files.

Active-X Component Registration

An Active-X component is a *.DLL file that resides in the Web-server’s System folder.  To
successfully run your Web site, the Active-X component that automatically sends email
confirmations to you and your customers (once a buy transaction is complete) must be regis-
tered on your hosting company’s Windows NT Server.  To do that, contact your Web site / ISP
provider and ask them to register the Boomerang Software Active-X component.  For them to
register this component, you will need to send them the contents of the folder located on the
WebShop program CD X:\Server Components\Send Mail  (where X designates your CD ROM
drive).

The Send Mail  folder contains the following files:

••••• MailX.dll

••••• Readme.txt

••••• Reg.bat

••••• Unreg.bat

Once you have confirmed the contents of this folder, you will want to do the following:
1.  Copy the Send Mail  folder and place it on your hard disk.
2.  Send your Web Site/ISP provider the folder by Email and ask them to run the batch file

Reg.bat  or upload your site (including the above files) and ask them to test the Active-X
component.
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You will want to be sure that your Web-host administrator reads the Readme text file before
attempting to register the Boomerang Active-X component.  Your Web Site/ISP provider can
unregister the Active-X component by running the batch file Unreg.bat .  The Active-X compo-
nent has been fully tested on Windows NT Servers Running IIS.  If there are any questions,
from the Web Site/ISP provider, regarding the registration of the Active-X component, have
them call the Boomerang Software Technical Support Department at (617) 484-4664 or email
Boomerang Software, Inc. at either of the following email addresses:

techsupport@boomerangsoftware.com
webhostingsupport@boomerangsoftware.com

Boomerang Software as a Web-Host Provider

Boomerang Software currently offers Web-hosting services.  There are a number of different
service plans to choose from:

••••• BASIC PLAN  – 5 Mb. of server space for a sub-domain name.  You may choose from one
of two URLs: www.uswebx.com  or www.webhorizon.com .  Both of these URLs are
managed  by Boomerang Software for its customers.

••••• BASIC PLUS  – 50 Mb. of server space.  The same policies from the Basic Plan option
apply except that you get ten times the server space with Basic Plus.

••••• PROFESSIONAL PLAN  – 5 Mb. of server space for a unique URL domain name.  You will
have to make sure that you locate a domain name, which is not already reserved.  The
Internet registration service, InterNIC (also called as Network Solutions), will bill you
separately for the first two years of domain name use.  Boomerang Software will assess a
onetime setup fee.

••••• PROFESSIONAL PLUS  – 50 Mb. of server space.  The same policies from the Professional
Plan option apply except that you get ten times the server space with Professional Plus.

To find out more about these service plans and prices:
• Visit the Web site at www.boomerangsoftware.com, or
• Send an email to webhostingsupport@boomerangsoftware.com.

What is Your Integrated CNQ Project File?

One of the important parts of creating and maintaining a Web site is your ability to easily
manage the different HTML files and all other files that are generated and required to present
your site.

As you design and update your site, you will create not one single file , but many small files in
many different formats.  Some of these formats include HTML, GIF, JPEG, SCRIPTS, CGI,
and many others.  Losing, or having any one of them become corrupted, results in a broken link,
a Web site malfunction, or some other operation failure.  Keeping everything together, and
working, is very difficult if all your files reside independently on your hard disk.  WebShop
fixes this problem by storing all of your files in a single integrated file format.  These files have
a special *.CNQ extension that is unique to WebShop.  That CNQ file contains the page,
graphic, and object resource files of your entire Web site.  When you want to work on your
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Web site again, you simply open that one file!  Everything is there.

Note:  WebShop automatically creates a backup file (*.BAK) of your current CNQ file
whenever you execute a save.  You will want to be sure that you have both of these files.

Additional Benefits
Not only does your CNQ file provide a single resource file for your entire Web site, but it also
saves your resource files in their original file formats.  This has important implications—
particularly for the graphic files you use.

Currently supported HTML specifications favor Internet images be in *.GIF or *.JPEG format.
These are pixel by pixel formats, similar to a bit map style format.  If you want to edit them or
change their size as part of your ongoing updates to your site, they may lose resolution and
versatility.  In addition, any special graphics that you create, using graphic drawing tools (which
might have special vector characteristics) will lose detail as soon as you place them on your site.
*.JPEG and *.GIF formats cannot support this kind of detail and to load these images on to your
site, these images must be converted.

WebShop’s CNQ file format avoids some of these problems.  When you save your Web site
project to a CNQ file, it saves your images in their original format.  The required conversion to
*.JPEG or *.GIF format does not happen until  your site is generated.  During site generation,
WebShop creates all of the necessary files and folders automatically.  Any image resource files,
not currently in JPEG or GIF format, will be created and placed on the server in its proper place.
That means you get the best of both worlds—a development file that saves your work in its
original format, and a production directory of files that organizes your work in a format suitable
for the Internet.

Note: To avoid problems, it is highly recommended that you follow the following strategy to
make updates to your site.  Once you create your site by generating and uploading it to your
server—to make changes—do not import the site from your server and make changes to
your HTML code directly.  Rather, you must open your Web site’s CNQ file from your hard
disk and make your changes to the CNQ file.  Then, after completing your changes, regen-
erate and reload your site to your server.  In a worst-case, you may import your Web site
from the remote server if your CNQ file is lost or corrupted.

Saving Your Files in CNQ Format

By default, WebShop saves your Web site in CNQ format whenever you execute a save.  Once
you execute a save, all of the associated resources of your site are saved.  You do not save files
individually, in a piecemeal fashion.  All of your files are saved together at the same time.

To initially save your Web site project in CNQ format

1. Click Save from the File  menu.  The Save As dialog box appears.
2. Enter the name for your project.
3. Specify the directory location for your file.
4. Click OK.
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Generating and Uploading Your Web Site

When you are ready to take your site to the Internet, you must use WebShop’s Site Generate or
Site Upload features.  The Site Generate feature takes your CNQ file and creates all of the
necessary files and folders automatically in a local directory.  Once you complete site genera-
tion, all of your files are ready for you to upload.

The Site Upload feature both generates and transfers your Web site files and folders from your
computer’s virtual memory to your Server’s directory automatically.  Where Site Generate
creates files and folders on your hard disk, Site Upload only generates files to your remote ISP-
server.  You will want to use Site Upload during your initial development and testing.  To test a
new E-commerce site in development, you may want to upload your Web site many times,
successively, by over-writing the remote server files with each iteration.

Note: Overwriting is a file-to-file operation, not a folder-to-folder operation.  We recommend
that you selectively delete the files on your server prior to uploading new files—if your new
Web site has many instances of folder and file additions or deletions.  Warning !  Do not
overwrite your ShopDB.mdb file in your Database folder.

Generating A New Site
You will only want to use the Generate Site feature when you want your Web site files stored
locally on your PC.  Remember: The files created by Generate Site are upload-ready.  Your
*.CNQ file is not upload-ready.

Once you save your CNQ file, you are ready to generate your site.  This operation creates and
places your Web site files where you specify on your hard disk.  It is recommended that you
generate it to another directory or folder separate from the location of the CNQ file.

Figure 17.1 – Save As Dialog Box
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To generate your site prior to upload

1. Create a new folder title “My WebSite ”
on your hard drive.

2. Select File > Save  from the File  menu
options to execute a save.

3. Select File > Generate  Site  from the File
menu options.  The Browse For Folder
dialog box appears.

4. Select the folder “My WebSite ” that you
created.

Note:  The Generate Site feature creates
and places all the sub folders and files
necessary for your site in the specified
folder.  To learn the Physical size of your
site after generation, preview it once with
the Preview feature.  Then, in Physical
Layout, right-click the Root folder in the
resource tree.  Select properties.  The
Properties dialog box appears.  Click the
Resource tab.  The Size field will display
your site’s estimated size.

5. Click OK.  The program begins processing.  This may take some time.  When finished, the
message The site has been successfully generated  appears.

6. Click OK.

Uploading A New Site
Before you begin you will need to have your hosting service’s Internet domain name, your ISP-
assigned user name (or user login) and password.  In general, it is not necessary to know your
exact directory address (or upload path).  NT-servers with IIS installed identify folder address
locations by user name.  However, if you currently are hosting more than one site with the same
provider, you will need to specify your exact account location.

When you first upload you will be creating an FTP session profile, that is, a predefined set of
parameters that you can reuse.  Every time you go to execute a Site Upload (using that *.CNQ
file), WebShop remembers the most recent upload profile for you and will place the files on
your remote NT-server accordingly.

To upload a new site

1. Select File > Upload  Site  from the File  menu options.  The Upload Web Site dialog box
appears.

2. Click in the FTP Server Name or Address  field and type “ftp.<domainname.ext>”
3. Click in the User Login  and Password  fields and type “<user name>” and “<pass-

word>”
4. Click in the Upload Path  field and enter the directory address only if you have more than

one site associated with your user name/folder name.

Figure 17.2 – Browse for Folder Dialog Box
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5. If you want to store your
password for future use, click
the Remember Password
check box.

Note:  You might want to
consider the security implica-
tions of saving your password.
If you want to maintain tight
control over your server files,
do not save your password as
part of your FTP session
profile.  For example, if
someone other than you uses
your computer, that person is
able to upload files to your
server without your permis-
sion — if the password is saved on the FTP session profile.  While it is a great convenience
to save your ISP password, particularly if you are prone to forgetting passwords, you must
weigh the possible security implications.

6. Click Upload .
• If either your password or your User ID were incorrect, the message Password was

not allowed  appears.
• If you enter the wrong FTP domain name, the message Server name or address

could not be resolved  appears.
• If your upload is successful, the message Upload was successful  appears.

Your Web site files are now stored in the Web-server’s directory and are ready to be viewed
online.  The CNQ file remains on your hard disk.

Uploading A Revised Site

When uploading a revised site, you must decide how you want to treat your site’s remote
database.  If you have been “live” for a while, your ShopDB.mdb file has dynamically created
data that does not exist in your local CNQ file.  This is valuable data.  Your remote
ShopDB.mdb file contains your customer records and order records.  If you overwrite this file,
you will permanently lose all of this information.  Therefore, you want to be careful not to
overwrite this data inadvertently.

Note: Your dynamically created data will be preserved if you un-check the Upload Data
Bases check box.

Also, be aware that when over-writing your remote server files, if you have removed a page or a
resource, you will not be over-writing those resources.  They will continue to exist on the
remote Web-server even though they are not used.  To solve this problem, we recommend that
you selectively delete the files on your server prior to uploading your new files.

Note: To delete existing files prior to uploading new ones requires a distinct FTP session

Figure 17.3 – Upload Web Site Dialog Box with Example Data
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with appropriate server permissions.  If you encounter problems, call your provider for
support.

To upload a revised site

1. Select File > Upload  Site  from the File  menu options.  The Upload Web Site dialog box
appears.

Note: Since you have already uploaded this site before all of the fields on the Upload Web
Site dialog box should have values entered.

2. If you did not select the Remember Password  check box, enter your password.
3. Decide whether to overwrite your server’s ShopDB.mdb file.

Note: If you do not want to overwrite this file, un-check the Upload Database check box.

Warning!  If your site is live (that is, no longer in development) do not over-write your
ShopDB.mdb file.

4.  Click Upload .
• If either your password or your User ID were incorrect, the message Password was

not allowed  appears.
• If you typed the wrong FTP domain name, the message Server name or address

could not be resolved  appears.
• If your upload is successful, the message Upload was successful  appears.

Note:  You must call, or ask, the Web-hosting company to place the appropriate permissions
on your site folder (see the chapter titled, “ Maintaining Security and Backing up Your Files”).

Your Web site files are now stored in your server’s directory and are ready to be viewed online.

Uploading Selected Files

When uploading selected files, you will not be using the Upload Site feature, which uploads
your site all at once.  To gain more flexibility, use the File Transfer Protocol (FTP) program.
There are several FTP programs available through the Internet.

To transfer your files selectively

1. Launch the WebShop program.
2. Open your project file.
3. Generate your site on your computer.
4. Set up an FTP session profile.
5. Establish connection with your remote ISP-server.
6. Specify the files that you want to transfer.
7. Execute the transfer.

In general, it is not necessary to know the exact directory address on the NT-server where your
files are stored.  Most NT-servers identify folder addresses by user ID so a specific location is
not required.  However, if you are currently hosting more than one site with the same provider,
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you might want to set up two FTP session profiles and record the exact address locations in
specifically defined session profiles.

BoomFTP
One of the sub-components installed with
WebShop 2000 is the BoomFTP program.  This is
a utility program that you can use to upload
selected files to your Web-server.

Note:  If BoomFTP sub-component was
deselected during installation, it will not be
available.

To launch the BoomFTP program

1. Click the Start  button on your Windows
taskbar.

2. Select Programs > Boomerang Software >
WebShop 2000 > BoomFTP.   The
BoomFTP Main screen appears.

Note:  The actual name of the BoomFTP
menu option may be different if you changed
the default program group during installation.

Figure 17.4 – BoomFTP Main Screen

Figure 17.5 – BoomFTP Connection Properties
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To set up a reusable FTP session profile

1. With the BoomFTP Main  screen open, select Connect > Connect .  The Connect dialog
box appears.

Note:  The Connect dialog box lists currently recorded session profiles.  Once you add a
new reusable session profile, it will be listed here.

2. Click New.  The Connection Properties  dialog box appears.
3. Click in the ConnectionName field and enter a profile name.  You might want to use the

name of your ISP and your ISP assigned user ID somewhere in your profile name.
4. In the FTP Server  section, click in the Host field and type “ftp.<domainname.ext>”
5. Accept the Port  field default.
6. In the Authentication  section, click in the User ID  and Password  fields and type “<user

name>” and “<password>”

Note:  Use the Anonymous login check box whenever you want to enter an FTP site
anonymously.  Some FTP sites have free downloading privileges.  In these cases, no user
ID or password is required.  Boomerang Software Web-hosting customers should leave
Anonymous unchecked.

7. If you want to specify an inital directory:
• In the Initial Directories section, click in the Local field and enter the directory

address that you want to access on your local computer.
• In the Initial Directories section, click in the Remote field and enter the directory

address that you want to access on the FTP-server.
8. When you are done, click OK to record the profile.   The Connect dialog box reappears.

The reusable session profile has been added.
9. Click on the profile name to select it and click OK.   FTP processing begins.

• If you enter the wrong FTP domain name, an error message appears.
• If either your password or your User ID are incorrect, an error message appears.
• If your connection is successful, the FTP server directories appear.

The FTP program has successfully connected to your ISP-server.  You can now initiate a file
upload or download using the BoomFTP Main screen.

An BoomFTP Main screen has two sections.  The Local System section identifies the location
on your local drive where you want to upload or down load files either to or from.  The Remote
System  section identifies the location on your remote server where you want to upload or down
load files either to or from.  The program icons listed on the left apply to the Local system
directory. The program icons listed on the right apply to the Remote system directory.   Sepa-
rate menus are available on the Main menu bar.  For more information about using this screen,
use the Help menu options.

To upload selected files to your ISP-server

1. Locate the folder/files that you want to upload from your local system, by double-clicking
on the left side Folder Up  or Down icon to move up or down one level in your local
directory. To open a folder, double-click on it.
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2. Locate the remote system folder that you want transfer data to by double-clicking on the
right side Folder Up  icon, or Down icon to move up or down one level in the current
directory.  To open a folder, double-click on it.

3. On your local system highlight the specific folder or files that you want to upload by
clicking on them.  To select more than one file use either the SHIFT key (for contiguous
files) or the CTRL key (for selected files only) to make a multiple selections.

4. To execute the transfer, click and drag the selected files from the Local directory to the
Remote folder.  The cursor changes shape to indicate the drag and drop operation.

Note: You can also select Local > Transfer or click the Upload icon on the Main toolbar.

5. Release the mouse.  A confirmation dialog box appears.  Click OK to confirm the transfer.

Note:  If you are transferring very large files, the transfer may take some time.  The program
displays a progress indicator to inform you of its progress. If you are over-writing files, the
programs asks if you want to copy over the existing file.  Respond either Yes or No as
necessary.

6. When the transfer is complete, the new files are listed in the Remote System’s directory
where you specified, or the over-written file lists the transfer date and time.



Chapter 18.
Import Site

Introduction

WebShop includes a site import feature that can import entire Web sites from remote servers
(either an FTP-server or a Web-server) as well as from your local computer.  This feature lets you
take an existing Web site, such as one you may have already created, and bring it into WebShop
for editing and maintenance.

Note: There is no such thing as a 100% perfect site import.  This is due to the many ways
sites are originally created. Some are coded line by line by developers, others generated
by tools. Some optimized for one browser, others more general, and a good number of sites
use undocumented features. Furthermore, it is not uncommon to find errors in the HTML
code of sites on the web, or instances where the site creator did not follow the exact
specifications of the HTML standards. So depending on the site you want to import, a good
import tool, such as the Site Import of Internet Design Shop WEBSHOP, would average
about 80% success rate. This success rate can be higher or lower depending on the
complexity of the site and other factors mentioned earlier. If the Site Import cannot interpret
part of the site’s code that is non-compliant, it leaves it out. In addition an FTP import is
more successful than an HTTP import.  A proper Site Import may have to follow links from
page to page or even locations outside the site. This brings an added level of complexity to
conducting a Site Import. More about these are explained in the other sections of this
chapter. As a rule, however, when you do a site import, you must be willing to do a good
effort to obtain the result or close to the result you want. You must select the proper settings
and limit the focus of the Site Import appropriately to minimize problems and achieve
optimum results.

The HTML features that currently are not supported in this version of Site Import include
Cascading Style Sheets, Free Pages and ASP technology.  When imported, Free Pages
become Plain Pages, cascading style sheets are replaced with the program’s Default style,
and Dynamic Pages become static HTML Plain Pages including whatever data was
present at the time of the import. Check the Boomerang Software Web site for future
versions of Site Import.

Site Import has two options – New and Merge.  When you select New, the project that is
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currently open is destroyed and replaced by the imported one. If you select Merge, the site (or
single resource) is being merged into the existing project.  By default, only the Physical Layout
displays the imported resources.  However, you can also enable the program to create the site’s
Logical Layout (see the Advanced tab). In this case, the Start Page becomes the Home Page, and
all other pages are placed one level down, as children pages off the Home Page. This Logical
Layout is created because the program has no information about the Logical Layout. Of course,
the program could analyze the linking structure and arrive at some conclusion as to what the
Logical Layout might be, but this is both difficult to do and, for the most part, entirely subjective.

The Import File tab on the dialog box is used for importing a single page or resource into a
project (or instead of the existing project, if you choose the “New” option).  So be forewarned, if
you choose New and specify only one HTML page, the imported HTML page will be the only
HTML resource in your Physical Layout.  If you chose the Add to Logical Layout option as well,
this HTML resource will appear as the Home Page for your project, however if you import a non-
HTML page resource, your new project will contain an empty Logical Layout.

Topics covered in this chapter include:
• Site Import Protocols
• Why is a Start Page Important?
• Zone References
• Address Formats
• Using Import Site
• Using the Import Zone Tab
• Using the Import File Tab
• Using the Advanced Tab

Site Import Protocols

There are two protocols used with Site Import – http:// and ftp://.
• If you specify a domain URL address, the http:// protocol is used.
• If you specify a file or folder, the ftp:// protocol is used.

When you specify a site import from your hard disk or network, the program uses the internal
file:// protocol.  A hard disk or network import is similar to an FTP import.

Importing a site using the ftp:// protocol or a hard disk or network import is more successful than
an HTTP import since resource files can be specifically selected.  An HTTP import is less precise
since only the domain URL can be used.

Why is a Start Page Important?

Whenever you perform Import Site, you must specify a Start Page.   The Start Page anchors the
site import operation.  To import the site, Import Site uses the Start Page to trace backwards to
the supporting files using the links found on each page.  The Start Page is like the first bead on a
long chain, which by picking up the first bead, picks up the whole chain and any other chains
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connected to it.  When evaluating what to import, the program chains backwards, identifying
files based upon the links that each file contains.

For example, if there is a page link such as - <A HREF=”AnyOtherPage.htm”> or an image an
image link such as - <IMG SRC=”Images/AnyImage.gif”>, the program will import the two
referenced resources (the *.HTM  resource and the *.GIF).  Equally, if there is a reference to
additional resources on the AnyOtherPage.htm file, these resources will also be imported.
However, there is one problem.  Most sites have external links and references.  By importing
resources though sequentially chained links,  you risk to importing the entire Internet into your
poor computer.  Some limitation is required.  That’s why you must mention the zone (or the
zones) from which the resources may be imported. You specify the zones by using the  Add to
Zone or Browse for Folder buttons included under the Import Zone tab of the Import Web Site
dialog box.  Every zone is actually a folder.  So you may have as many zones you want, however,
at least one is required.

By specifying a zone, that doesn’t mean that the entire content of that folder will be imported.
First, there may be files, and these files may have no references either to or from the files already
imported.   So, if you import a site using the HTTP protocol (by clicking the Add to Zone and
specifying a URL), this becomes the main rule for the import operation.  The HTTP protocol
doesn’t provide information about the content of a specified folder (as defined by a URL).  That
means that you won’t be able to specify the Start Page from which to begin the import process.
In this case, the specified Start Page must be the same as the URL for the zone. Later, the hosting
Web-server will decide, what page to start with (by default this page usually Index.htm). So
remember, if you use HTTP protocol, you have very little control on what you import. That
however, is not your only option.  You may also use the FTP protocol by using the Browse for
Folder button and specifying the folder that contains the desired site.  In this case, you can see
the content of the site graphically.  The specified folder is expanded by the program so that you
can see its files and subfolders.  With the FTP protocol, you will have much more flexibility to
decide what to import and where from.  To do this, you must first, specify a Start Page.  (This can
be different from Index.htm.) Next you can exclude certain files or folders from the import zone by
using the Exclude button.  Conversely, you can later choose to include excluded files or folders
by using the Include button.

Note:   If the file is included as part of the Import Zone that doesn’t mean, that it will be
imported in any case.  There may be files, that will have no reference to from others or the
reference may be hidden. For example, you have a Java Applet, that uses three class files.
The HTML file specified as the Start Page only references one of them. So what about the
other two files, without which the first one will not work?  For this reason there is a function
called “Force Include” that imports files even if there is no reference to them. If you apply
“Force Include” to a folder, the entire content of the folder is imported.

Zone References

A zone is a folder (even when specified by a domain name URL).  By providing a Zone reference,
you are not telling the program to import the entire contents of the folder.  Rather, you are
providing a reference area.   Relational links are built from the Start Page to the identified zone.
You may specify as many zones (or folders) as you want, but at least one is required.

With an HTTP import, the Zone reference and the Start Page reference are normally the same.
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Generally the domain name URL prompts the Web-server to access Index.htm, which becomes
the Start Page.  With an HTTP import, you have very little control over what you import since the
zone of the site is the same as the domain name URL.  However, with the FTP protocol you have
more flexibility.  By connecting to the Web-site via FTP, WebShop is able to present a graphical
display of the folder specified.  This allows you to selectively choose the files and sub-folders to
include.

Address Formats
• To specify an http URL  – use the format: http://www.<domainname>
• To specify an ftp URL  – use the format: ftp://ftp.<domainname>/<filename>
• To specify a hard disk or network URL  – use Browser for Folder button

Using Import Site

You can import sites, site fragments, or separate files, and use them as a new site, or add them to
an existing one.  To import a site, use File > Import Site > New or File > Import Site > Merge.
The New option lets you create a new project file, the Merge option lets you add site fragments
to an existing project file.  Both options use the Import Web Site dialog box.

Import Web Site Dialog Box
The Import Web Site dialog box enables you to import Web Sites from remote Web-servers (via
FTP or HTTP protocols) or from your local hard disk or network.

The dialog box contains three tabs: Import Zone , Import File , Advanced .

••••• Import Zone tab .  Use this tab to import an entire site (from either the Web or your com-
puter). To do this, click the Import Zone  tab, set zone (site) URL to import and click OK.

••••• Import File .  Use this tab to import specific files (either from Web or your computer).  To do
this, click the Import File  tab, set the file URLs or paths and click OK.

••••• Advanced .  Use this tab to specify additional settings that control how the site is imported.
This tab can be used with any import operation.

Important!  Keep in mind that graphics and Web pages available through the Internet are
generally copyrighted material.  The import and use of such materials without prior written
permission of the copyright holder is a violation of international copyright treaty.  While
there is nothing wrong with importing a Web site to study it and see how it functions, you
should not infringe on the copyright for such materials.

Using the Import Zone Tab

To import a Site using an Import Zone, specify the Import Zone that you want to include by
adding URL folders to the Import Zone and specifying a Start Page.  WebShop imports all of the
files from the Import Zone (including subfolders and files) that are connected to the Start Page in
some manner.  The pages or resources should be linked from the Start Page, or linked to a file that
is linked from the Start Page.  You can also use the Force Include  option to include a file from the
Import Zone that is not connected to the Start Page, but is otherwise necessary for the operation
of the Web site.
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Import Zone Fields
••••• Import Zone window .  Contains a tree-control of the Import Zone.  Use this window to

identify the URL addresses associated with the pages to be imported.  To add or remove
URL addresses, use the Add To Zone  or Remove from Zone  buttons.  When you select a
URL address to import, the Import Zone window displays the address as a resource folder.
By default, WebShop sets all Web page addresses (and resources included in a folders), as
resources to “include” when the import is performed.  A small folder icon is placed next to
the resource name to indicate that it is a folder.  A small check mark in the folder icon
indicates that the folder is set to be included in the import.  A cross icon indicates that the
item is set to be excluded from the import.  If you wish to exclude a file or resource, you must
click on the icon in the Import Zone window and click Exclude .

••••• Start Page .  Use this field to specify the Start Page.  WebShop imports all of the files from

Figure 18.1 – Import Web Site Dialog Box
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the Import Zone (including subfolders and files) that are connected to the Start Page in some
manner.

Import Zone Buttons
••••• Include .  Lets you specify a file or subfolder to include in the import operation.  If a folder is

included, all of its subfolders are added to the Import Zone.

••••• Exclude .  Lets you select a file or subfolder to exclude from import.  If a folder is excluded, all
of its subfolders are excluded from the Import Zone.

••••• Force Include .  Lets you select a file or subfolder and then click Force Include to force the
file or folder to be included whether they are related to the Start Page or not. If a folder is
force included, the program automatically imports all its associated subfolders and files.

••••• Set as Start Page .  Lets you select a file as the starting point from the tree control to use as
the Start Page.

••••• Add to Zone .  Lets you create a new folder in the Import Zone folder.  When a new sub
folder is created, you must specify a URL for the remote location or a path for the local file or
folder.  WebShop verifies the path and, if valid, expands it to a tree when you double-click
on it.

••••• Remove from Zone .  Lets you remove a folder from the Import Zone folder.

••••• Browse for Folder .  Lets you browse your computer to locate a subfolder that you want to
add to the Import Zone folder.  The program will expand this folder to a tree.   The Browse
for Folder  button cannot browse the Internet, only your local hard disk or LAN.

••••• Browse for Start Page .  Lets you browse your computer to locate a file that you want to
use as the Start Page. The Browse for Start Page button cannot browse the Internet, only
your local hard disk or LAN.

Importing an Entire Site

When importing a site it is recommended that you launch your browser and open the Web site
that you want to import.  Using your browser address line, copy the URLs you want use when
completing the import.  This will prevent transcription errors.

To import a Web site as a new project

1. Select File > Import Site > New.  The Import Web Site dialog box appears.  By default, the
Import Zone  tab is active.

2. To add folders to your Import Zone, click Add to Zone .  The dialog box buttons become
active and a URL icon is added to the Import Zone with a file name box and blinking cursor.

3. Decide how you want to add your zone references.

• To specify a zone reference using an FTP protocol, type (or copy from your browser’s
address line) a file or folder URL.  The URL is verified and a folder icon with the
specified URL appears on the Import Zone  window.

• To specify a zone reference using an HTTP protocol, type (or copy from your browser’s
address line) the domain name URL and press ENTER.  The URL is verified and a folder
icon with the specified URL appears on the Import Zone  window.

• To specify a zone reference from your hard drive or network, click Browse for Folder.
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The Choose Folder  dialog box appears.  Navigate to the folder you want and click OK.

4. Decide if you want to expand the folder to select specific resources.

• To expand an FTP or a hard drive folder, double-click on the folder icon.  The contents
of the folder are displayed as a resource tree.  Subfolders will display a folder icon, and
files will display a file icon.

Note:  You cannot expand an HTTP zone reference.

5. Repeat Steps 2–4 until all zone references have been added.

Note:  If the entire Web site is contained in a single folder on a remote server, only two
items need to be specified: the domain name URL and the Home Page URL.

6. Select the files or subfolders you wish to include or exclude.

• To include a subfolder or file, select the folder in the Import Zone display and click
Include .  A green check mark displays on the folder or file icon.

• To exclude  a subfolder or files of a Web site from being imported, select the folder in
the Import Zone display and click Exclude .  A red cross displays on the folder or file
icon.

7. To remove a zone reference (and all of its associated files), select the folder icon and click
Remove from Zone.  The folder icon and URL address is removed.

8. In the Start Page  field, decide how you want to specify your Start Page.

• To select a page listed in the Import Zone, use the Set As Start Page button.

• To import a site using an FTP protocol, specify a file name URL.
• To import a site using an HTTP protocol, specify the Home Page URL (in most cases it

will be the same as the domain name URL)
• To import a site from your hard drive or network, click Browse for Start Page.  The

Select Starting Page  dialog box appears.  Navigate to the file you want and click OK.

9. When done, click OK.  The site is imported.

Note:  WebShop follows HTML specifications closely.  It is not uncommon to find errors in
the HTML code of some Web sites.  If the Web site you import has errors, or it does not
conform to HTML specifications, some of the Web page features may not work or parts of
Web pages may not be brought in.

When you are done editing the imported site, select File > Upload  to upload the files.  This
feature generates the site and uploads the files in one operation.  Only the files that you included
in the import are uploaded.

Force Include Feature
Keep in mind that all included files and folders are imported except those that do not have links.
If a Web page does not have any incoming links, it will not be imported.

You may, however, force WebShop to import such a file using one of two methods:

• Select that file from the list in the Import Zone window and click Force Include .  This
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ensures that the file, or page, is imported regardless of any links.
• Select the main folder or group that has the file or page and click Force Include .  This forces

the program to include and import any and all files, resources, or pages that are in that
particular folder.

The Force Include feature is especially important for such items as Java Applets’ image files,
custom CGI files, AVI, MIDI, and animated GIF’s.

For example, a Java Applet is generally a single file.  However, some Java Applets include more
than one class file.  Multiple class files may not have links from an HTML page but may have
links within the Java code.  In such a case, it is possible to import the Main Java Applet class but
not the related class files.  The Force Include option can overcome this situation.  If you know
where all the Java class Applet files are located, include them in the Import Zone and click Force
Include .  If you are not sure about their location, use the Force Include to import the entire folder
or group.

When importing a site, you must specify the Start Page.  This specification displays in the Start
Page field of the Import Web Site  dialog box.  WebShop begins the import operation at the Start
Page that you specify, tracing all HTML links throughout the pages specified for import.

There are three methods of specifying the Start Page:

• Place the cursor in the Start Page  field and type the location address of the start page.  This
can be either the full path on your PC or LAN (for example, c:\site2\index.html.  or the exact
URL address, for example, http://www.companyxsite.com/index.html.)

• Click Browse for Start Page .  The Select Starting Page  dialog box appears.  Select the file
you wish and click OK.

• If you have already created the Import Zone resource tree in the Import Zone window, click
the file icon in the Import Zone and click Set as Start Page .  The selected page URL
appears in the Start Page field.
Note:  Using the Set as Start Page button limits your choice of a start page to the list
displayed in the Import Zone.  However, if you want a start page other than those listed in
the Import Zone, use the ‘Start Page” field.  Enter the location of the start page you want the
import to start from in this field.  The location can be on your local hard disk, LAN, or an
external URL Internet address.

When you insert a folder in the Import Zone and import the site, all the contents of that folder are
imported except those pages that have no links or references.

Using the Import File Tab

With the Import File  tab selected, browse for file(s) to import on your local computer, or enter the
URL address for the file(s) you want to import.  The Import File tab does not let you selectively
choose files from a resource tree.  You must specify them directly.

Note:  If you select File > Import Site > New and specify only one file, you will have a project
file that contains only one page.  Generally, Import File is used with File > Import Site >
Merge.
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Import File Fields
• Items to Import window .  Contains a simple listing of URL addresses to import.

Import File Buttons
• Browse .  Lets you browse your computer to locate a file that you want to add to the

Import listing.
• Add URL .  Lets you specify a URL location to import.
• Remove .  Lets you remove an item from the Import listing.

To import Web pages using the Import File tab

1. Click the Import File  tab.

2. Decide how you want to specify the files to import

• To specify a URL location, click Add URL and (or copy from your browser’s address
line) a file URL and press ENTER.  The URL is verified and a page icon with a check
mark appears.

• To browse a folder on your hard disk or LAN, click Browse.  The Import File  dialog box
appears. Navigate to the folder and double-click file that you want.  You may also select
multiple files at once. A page icon with a check mark appears.

3. If you wish to remove any files from the import listing, select the page icon and click
Remove. The page icon and URL address are removed.

4. Click OK.  The specified pages are imported.

The advanced features of the Site Import enable you to divide the work of maintaining a large
site between a number of people.  Each group can import the portion of the site it maintains, edit
it, and place that part back on the Web-server.

Using the Advanced Tab

With the Advanced tab selected, specify additional settings that control how the site is im-
ported. By default all of the advanced tab operations are selected.  It is recommended that for
most site imports, these default settings should remain unchanged.

Advanced Tab Check Boxes
• Import Images .  Enables image import.
• Import Sounds .  Enables audio import.
• Import Video .  Enables video import.
• Import Applets .  Enables Java Applet import.
• Add to Logical Layout .  Updates Logical Layout for any pages imported.  When

unselected only physical files are added to Site Manager.
Note:  By default, the Start Page is always made the Home Page and any associated pages
that are imported are treated as children off of the Home Page.  This results in a Logical
Layout with only two levels.
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To adjust the settings used to import a site
1. Click the Advanced  tab.
2. To prevent the program from importing images, sounds, video, or Applets, clear the appro-

priate check boxes.

Note:  You may not want to import all of the files from the zone specified. They might be
copyrighted, or too large.

3. Clear the Add to Logical Layout  check box to prevent the addition of imported pages to the
current Logical Layout.  In this case, the imported files are added only to the Physical
Layout.

Note:  When merging imported files with a current project, select the parent page for new
files. Imported *.HTM files will be added to the logical structure as children of the selected
page.

4. When done, click OK.   The import operation begins.



Part 5
CUSTOMIZING

This part of the User Guide examines how WebShop can be specifically customized to suit your
needs and how resources that have value use across multiple projects can be installed.

Part 6 includes:
• Creating WebShop Templates
• Editing WebShop Libraries



Chapter 19.
Creating WebShop Templates

Introduction

This chapter examines the procedures for creating your own template files and inserting them
into WebShop libraries.  Templates provide a versatile and useful means of creating reusable
tools that save time and guarantee consistency.  To create a template, you must convert the
display of at least one object as a slot. “Slots” are placeholder objects that a user can customize
after importing the template. By converting an object into a slot, the most object properties
remain unchanged, however, the object itself is displayed as grayed out text or with an icon that
identifies what kind of object goes there.

Topics covered in this chapter include:
• Considerations
• Opening a File and Converting It Into a Template
• Adding a Template File to a Library
• Removing a Template from a Library
• Creating a New Template Library
• Removing a Template Library

Considerations
When considering how you might use templates, keep the following in mind:
• Templates are saved in libraries, which can be used on multiple project files.
• You can save an entire Web site as a template or just individual pages.
• When saving individual page templates, it is recommended that you do not create Dynamic

Page templates. (Dynamic Pages are specific to individual forms and databases and are not
good candidates for template treatment.)

• Use templates to store objects such as forms, graphics, boilerplate text, headers and footers.
The resources associated with these objects are automatically imported with the template
and become part of the project’s available resources.

• Save template files with only one style sheet, Default_Style .  Upon importing the template,
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you can reassign the style using the styles available for the hosting site.
• Use the Slot feature to create template flexibility.  “Slots” are placeholder objects that a

user can customize after importing the template. WebShop allows you to make any of the
following objects into “slots” — paragraph text, text line, images, media objects, form
fields, or horizontal rules.

• Do not try to tack on an E-commerce template to an existing site.  It is recommended that if
you think that in the future you would like your Web site to have E-commerce functional-
ity, then build you Web site using one of the E-commerce templates and disable the E-
commerce functionality by removing any links to the E-commerce web pages.

WebShop currently does not allow for the importation of E-commerce functionality into an
existing *.CNQ Project file.  You could set up two separate sites and provide links between the
E-commerce site and pre-existing Web site, but you cannot import E-commerce functionality
into an existing project file and then generate and upload the site.

Opening a File and Converting It Into a Template

Any WebShop file you turn into a template by making at least one object (for example, a text
object or a clip art image) display as a slot. “Slots” are placeholder objects that a user can
customize after importing the template.  By converting an object into a slot, the most of the
object properties remain unchanged, however, the object is now displayed with grayed out text
or with an icon that identifies what kind of object goes there.

Once an object has been converted into a slot, you simply save the file designating it as a
template file with an extension of *.CTM.

Opening a Project file

To open a file
1. Click Open in the Main toolbar or select the File > Open menu options.
2. If you wish to view the file before you open it, click Preview in the lower right corner of

the Open dialog box.
3. When you locate the correct file, click it to highlight it, and then click Open in the Main

toolbar or double-click file name.

Convert an Object to a Slot
After you open the file, convert any of the objects on the page to a slot. The object could be
paragraph text, text line, images, media objects, form fields, or horizontal rules.

To convert an object to a slot
1. Click the object to select it.  The object is highlighted
2. Right-click.  A pop-up menu appears.
2. Select Show > As Slot . The object now appears in slot form.

If you use Show > Normal  to convert the object or text back to Normal, the content of the slot is
restored.
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There are a number of considerations to keep in mind when displaying objects:
• If you convert an object to a slot and later convert it back to Normal, the content of the

object is restored with its original content.
• If you convert an object to a slot, save the file as a WebShop document file (with a file

extension of *.CNQ), reopen the file and convert that same object to show as Normal, the
content of the object is restored with its original content.

• If you convert an object to a slot, save the file as a WebShop template file (with a file
extension of *.CTM), then reopen the file, you cannot use the Normal option in the Show
menu.  After saving the file as a template, you cannot restore the original contents of an
object without manually replacing it.

Save File as a Template
After you have converted a number of objects and/or pieces of text into “slots,” you can save
the file as a WebShop template.  For this operation, you must use the Save As option in the File
menu; you may not use the Save File button on the Main toolbar.  CTM files are stored outside
the project file and must be saved into one of the Template libraries before they are available as
resources.

To save the current file as a template file
1. Select File > Save As .   The Save As  dialog box appears.
2. Click Save as Type  at the bottom of the  dialog box.
3. Click Templates in the Save as Type  list box.
4. To give the file a new name, enter a new name in the File Name  box.

Note:  Since WebShop documents have a file extension of *.CNQ and templates have an
extension of *.CTM, it is not necessary to give templates a different file name. You may have
an INDEX.CNQ (document file) and an INDEX.CTM (template file) in the same directory.  It
is not necessary to add the *.CTM file extension to the file name when you are saving it to a
template format.

5. When done, click OK.  The current file is saved as a template file.

Now that you have created a WebShop template, you must add the template to a template
library.

Adding a Template File to a Library

To add a new template file to a library, open the Template Library Edit dialog box.  This dialog
box enables you to add templates to existing libraries, remove templates from existing libraries,
create new template libraries, and delete template libraries.

To add a template to an existing template library
1. Select Library > Edit Template Library .  The Template Library Edit dialog box appears.
2. Select one of the existing libraries where you want to add the template.
3. In the Look In  section, specify the directory location where the *.CTM file is stored.
4. Click once on the *.CTM  file that you want.
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5. Click Show Preview  below the Sample box so that you may view the template before
inserting it into a library.

6. Click Add .  The template has now been added to the library.  If you scroll through the list
of templates in the library, the new template file displays at the end of the list.

7. Click Close to close the Template Library Edit  dialog box.

Now that you have added a new template to the template library, use the New command to view
the template library contents and verify that the new template is properly inserted.

To verify the new template is in the template library
1. Select File > New .  The New dialog box appears.
2. Select the Library tab to open the template library that you want.
3. Use the horizontal scroll bar to scroll through the template list box until you see the new

template that you inserted (it is the last file in the library).

Removing a Template from a Library

To remove a template from the template library, use the Template Library Edit dialog box.

To delete a template from a library
1. Select the Library > Edit Template Library  menu options. The Template Library Edit

dialog box appears.

Figure 19.1 – Template Library Edit Dialog Box
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2. Select the Library that you want.  A list of template files are displayed.
3. Select the template that you want to delete.  If necessary, use the scroll bar to locate the

template file.
4. When you locate the template, right-click on it.  A pop-up menu appears.
5. Select Delete .  A confirmation message appears.
6. Click Yes to confirm the deletion.  The template is removed from the library listing.
7. Close the Template Library Edit  dialog box.

The template is now deleted from the template library.

Creating a New Template Library

In addition to adding new templates, you can also add new template libraries to WebShop.
When you create a new library, it is stored as a selectable library within the Library Type
named  “Web Site.”  Currently, there is only one Library Type for WebShop.

To create a new template library
1. Select Library > Edit Template Library .  The Template Library Edit  dialog box appears.
2. Click New Library .  The Library dialog box appears.
3. Enter the name for the new template library and click OK.  The new library is displayed in

the Library list box.

Note: The entry box accepts alphanumeric characters only; you may not use punctuation
marks, underlines, dashes, or any non-alphanumeric character.

4. When done, close the Template Library Edit  dialog box.

You have now created a new template library that is empty (that is, it has no template files).

Removing a Template Library
To remove a template library, use the Template Library Edit dialog box.  When you delete a
library, you are simultaneously deleting any template files associated with that library.  It is
recommended that you delete template files individually before deleting the template library
itself.

To delete the template library
1. Select Library > Edit Template Libraries .  The Template Library Edit  dialog box appears.
2. Select the Library that you want to delete.
3. Click Delete Library .  A confirmation message appears.
4. Click Yes to confirm the deletion.  The library is removed from the Library list box.
5. When done, close the Template Library Edit  dialog box.

The template library and any template files contained in that library are now deleted from the
WebShop library files on your hard disk.



Chapter 20 .
Editing WebShop Libraries

Introduction
In this chapter we will examine the different image and color libraries available in WebShop.
The instructions in this chapter will show you how to edit and create your own graphical
libraries and insert them into WebShop for future use.  You can also learn how to tailor graphic
libraries so that you can add, edit, and delete images and objects, as you want.

Topics covered in this chapter include:
• Editing an Image Library
• Adding an Image to a Library
• Deleting a Picture from a Library
• Creating a New Image Library Category
• Editing Brush and Pattern Libraries
• Editing a Color Library
• Creating a New Color Library

Editing an Image Library
Select Library > Edit Image Library .  The Library Edit  dialog box appears.  This dialog box
shows many groups of image libraries including:
• Clipart Library .  This library contains Windows Metafiles (.WMF) and Enhanced Windows

Metafiles (.EMF).  You can only insert these types of images into this library.  You can use
these images as clip art in any of the WebShop graphic projects.

• Vector Image Library .  This library contains Windows Metafiles (.WMF) and Enhanced
Windows Metafiles (.EMF).  You can only insert these types of images into this library.
You can use these images as clip art in any of the WebShop graphic projects.

• Raster Image Library .  This library contains raster or bitmapped images.  These image
types include: Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG),
Paint Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF).  You can
use these images as clip art in any of the WebShop graphic projects.

• Border Library .  This library contains Windows Metafiles (.WMF) and Enhanced Win-
dows Metafiles (.EMF).  You can insert only these types of images into this library.

• Raster Brush Library .  This library contains raster or bitmapped images.  These image
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types include: Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG),
Paint Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF).  These files
are generally very small images that you can use as repeated brush strokes in a background
pattern.

• Vector Brush Library .  This library contains Windows Metafiles (.WMF) and Enhanced
Windows Metafiles (.EMF).  You can insert only these types of images into this library.
These files are generally very small images that you can use as repeated brush strokes in a
background pattern.

• Bullet Library .  This library contains small raster or bitmapped images that may be used as
bullets to highlight text or graphics.  These image types include: Windows Bitmap (.BMP),
CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA
Bitmap (.TGA), and TIFF Bitmap (.TIF).

• Button Library .  This library contains small raster or bitmapped images that may be used as
buttons to highlight text or graphics.  These image types include: Windows Bitmap (.BMP),
CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA
Bitmap (.TGA), and TIFF Bitmap (.TIF).  These files are especially useful in creating
graphic hypertext links in web pages.

Figure 20.1 – Library Edit Dialog Box
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• Background Library .  This library contains raster or bitmapped images.  These image
types include: Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG),
Paint Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF).  These
images are generally used as web page backgrounds.

• Horizontal Rule Library .  This library contains raster or bitmapped images.  These image
types include: Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG),
Paint Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF).  These
images are generally used only in web pages as horizontal dividers.

Each library includes one or more categories of images that are divided by subject matter.  See
the list on the adjacent page for a list of categories in each library.

Adding an Image to a Library

You may edit any of the picture libraries using Library > Edit Image Library  menu options.

To add an image to a library

1. Select Library > Edit  Image Library .  The Library Edit  dialog box appears.

Note:  You can add only specific file types to specific libraries.  You must check which
libraries support, which file types.

2. Select the library type in the LibraryType  selector at the bottom of the dialog box.
3. Select the library category in the library selector drop-down list (it is located just below the

Files of Type  selector.)
4. Decide how you want to add the new image.

• To add an image from your hard disk, navigate to the drive and folder that contains the
file you wish to add using the dialog box fields.  Click the Show Preview  option if you
wish to see the image before you import it.  When done, click Add .  The image is
added to the selected library.

• To add an image from a Twain compliant device, click Acquire .  The device driver
dialog box appears.  Use this dialog box to specify the image you want to bring in.
When done, click OK.  The image is added to the selected library.

Note:  If a device driver is not currently open, the Acquire button is inactive.  To select a
source, go to Site Manager and select File > Select Source.  The Select Source dialog box
appears.  Select a data source and decide if you want to acquire multiple images, and click
OK. The Acquire feature is now active.

5. When you are done editing, click OK.  The Edit Library dialog box disappears.

It is important to remember that you must select compatible images for the libraries.  For
example, you cannot import a Windows Bitmapped image (.BMP) into a Vector Image Library.

Deleting a Picture from a Library
You may delete any of the pictures in a library using the Edit Image Library option in the
Library menu.
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To delete an image from a library
1. Select Library > Edit Image Library .  The Library Edit  dialog box appears.
2. Select the library type in the Library Type  selector at the bottom of the dialog box.
3. Select the library category in the library selector combo drop-down list box located just

below the Files of Type  selector.
4. In the image list box (below the library selector), Select the file that you want to remove.
5. Click the Show Preview  check box if you wish to see the image before you remove it.
6. Right-click the image file to open the drop-down menu.
7. Select the Delete  option to remove the image from the selected library.

Note:  Be careful not to click Delete Library.  The Delete Library option removes the entire
library from the WebShop system.

Creating a New Image Library Category

You may add picture libraries to the program libraries using the Library > Edit Image  menu
options.

To add a new image library
1. Select Library > Edit Image Library .  The Library Edit  dialog box appears.
2. Select the library type in the Library Type  selector at the bottom of the dialog box.
3. Click New Library  to continue.  The Library dialog box appears.
4. Enter the name for the new library category.
5. Click OK to add the new image category to that library.

Editing Brush and Pattern Libraries
Brush and pattern libraries are edited and created in the same manner as the picture libraries.
The only consideration with these libraries is the manner in which the original graphic is used.
For example, the graphic of a butterfly is simply inserted in the picture library as is and used in
any instance when you need a butterfly image.  Brush and pattern libraries, however, are very
small patterns or images that are reproduced repeatedly throughout the image to produce a
specific pattern.  If you wish to create a wallpaper effect of a particular graphic image, you may
insert that image into a brush or pattern library.

Editing a Color Library
You may create and edit color libraries using the Library > Edit Color Library  menu options .
The color library feature is an advanced feature intended for the advanced graphic artist who
requires precise control of color selections in a color library.

Note:  The default color library cannot be deleted or modified.
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To change a color in the color library

1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
3. Select the Library that you wish to edit from the Library list.
4. The colors for that particular library appear in the color swatch display below the library

selector.  Click the color square that you wish to change.
5. The Color Library  dialog box includes a display of Basic Colors  in the upper left corner.

Click the color that is closest to the new color that you want to insert.
6. In the color gradient display in the upper right corner, you can notice that the cross hair

indicator moves to the color that you selected in the Basic Colors  section.  If this is the
color that you want, click Replace Col  to replace the color in the library with the selected
color.  The color swatch indicator in the color library will reflect the new color.  If the color
in the gradient display is not the exact color that you want, you can place the mouse pointer
on the cross hair and, while holding down the left mouse button drag the cross hair to the
shade that you want.

Figure 20.2 – Color Library Dialog Box
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To add a color to a library

1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
3. Select the Library that you want to edit from the Library list.
4. The colors for that particular library appear in the color swatch display below the library

selector.  Click the color square immediately after the square that you want to insert the
new color.  (The new color will be inserted just before this selected square.)  If you want to
add a color to the end, select the last blank square with an X.

5. The Color Library  dialog box includes a display of Basic Colors  in the upper left corner.
Click the color that is closest to the new color that you want to insert.

6. In the color gradient display in the upper right corner, you can notice that the cross hair
indicator moves to the color that you selected in the Basic Colors  section.  If this is the
desired color, click Add Col  to add the color to that library.  If the color in the gradient
display is not the exact color you desire, you can place the mouse pointer on the cross hair
and, while holding down the left mouse button drag the cross hair to the shade you like.

To remove a color from a library

1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
3. Select the Library that you want to edit from the Library list.
4. The colors for that particular library appear in the color swatch display below the library

selector.
5. Select the color in the library that you want to remove.
6. Click Remove Col  to remove that color from that library.

Creating a New Color Library

WebShop includes a number of different color libraries for you to use.  You can also create
your own new libraries using any color combination that you desire.  You can assemble a
library from individual colors that you select or you can have WebShop create ranges of colors
based upon your specifications.

To create a new color library

1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click New Library  to create a new library.  The Name dialog box appears.
3. Enter a name for the new library.
4. Click OK to accept the new library name.  You now have a new library that does not

contain a color palette.

To add color palettes to a new color library
1. In the Basic Color section, you can select individual colors and then click Add Col  to add

the colors to the library.



Chapter 20. Editing WebShop Libraries

WebShop 2000 User Guide ◆   ◆   ◆         20–7

CUSTOMIZING

2.  If you wish to create a range of colors for the new library, you can have WebShop create a
color range based upon the colors you select.  To use this feature, you must select the first
color for the library.  You can select the color by clicking the color in the Basic Color
display or by dragging the cross hair in the gradient color display to the desired shade.

3. When you have the desired color for the first color in the color library, click First  Color .
Notice that the Color Generator section includes a numerical display indicating the mix for
the colors.  If you know the precise amounts of each color required, you can enter the
numbers in the spaces provided in the Color Generator  section.

4. Next, you must click the last color to insert in the library range.  You can select the color
by clicking the color in the Basic Colors display or by dragging the cross hair in the
gradient color display to the desired shade.  When you have the desired color, click Last
Color .

5. You must now select the number of color shades that are to appear in the library through
the first and last colors (this number must also include the first and last).  To enter the
number of color shades, use the scroll arrows in the Count box or enter the number desired.
The horizontal display bar to the left of the Count indicator displays a gradient for the
number of shades selected for the first and last colors.

6. To complete the color library, click Generate .  A color range using the Count number is
inserted into the new library.  The range of colors begins with the First Color  you selected
and ends with the Last Color .

To remove a color library

1. Select Library > Edit Color Library .  The Color Library dialog box appears.
2. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
3. Click the library that you wish to remove from the library list.
4. Click Delete Library .
5. Click Yes to confirm the deletion.  The library is removed from the program.

To rename a color library

1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click Rename Library  to rename it.
3. Click the combo box at the bottom of the dialog box to open the list of available libraries.
4. Select the library name that you wish to rename.
5. Click Rename Library .
6. Enter a new name for the library.
7. Click OK to accept the new library name.  The library is renamed.

You can also cut, copy or paste color swatches (groups of colors) between individual color
libraries.  The procedure for these is simple.

To cut or copy a color swatch
1. Select Library > Edit Color Library .  The Color Library  dialog box appears.
2. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
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3. Click the Library that you want to use from the Library list.
4. Select the colors you want to cut or copy.

• If you want to select adjacent colors, click the first color square you want.  Press
SHIFT, and then click the last color square you want.  Click and drag your cursor
across the color range you want.  All of the highlighted colors including the endpoint
points will be selected.

• If you want to select non-adjacent colors, click the first color square you want, press
CONTROL, and then click the each color square you want.  Only the squares that you
click on will be selected.

5. With the colors highlighted, right-click.  A pop-up menu appears.  Select Cut  or Copy .
• If you select Cut , the color squares are removed from the current color library.  You

may now import them to another.
• If you select Copy , the color squares remain in the current color library.  You may now

import them to another library.

To paste a color swatch
1. Click the arrow to the right of the Color Library  selector to open the drop-down library list.
2. Click the Library that you want to use from the Library list.
3. Decide where you want to paste the new colors and select one of the following:

• A single point.  The new colors will be inserted before this point.
• A range of colors that you want to overwrite.
Note:  If you want to add colors to the end of your color palette choose the last blank square
with an X.

4. With the insertion point (or range) selected, right-click.  A pop-up menu appears.
5. Select Paste .  The imported color swatch is added.



Appendix A.
License Agreement and Warranty

IMPORTANT

Opening the software package and using WebShop 2000 indicates acceptance of the terms of this License Agreement.

NOTICE OF COPYRIGHT

This software program package (“SOFTWARE”) is a proprietary product incorporating elements developed by
Boomerang Software, Inc. (“BOOMERANG”). This software is protected by copyright laws and international treaty.
You must treat the SOFTWARE like any other copyrighted material, except that you may either make one copy of the
SOFTWARE for backup or archival purposes, or you may place the SOFTWARE on a single mass storage device
(media), such as a hard disk, provided that you keep the original software for archival or backup purposes. Copyright
laws prohibit making additional copies of the SOFTWARE for any other reason. You may not copy written materials
accompanying the SOFTWARE without the express permission of BOOMERANG.

The WebShop 2000 program, its screens, icons, sequence, and organization are copyrighted materials of BOOMER-
ANG.  They may not be copied or duplicated in any medium without the written authorization of BOOMERANG.

SOFTWARE LICENSE AGREEMENT

The software on the WebShop 2000 media is licensed to the user. Before using WebShop 2000, you should carefully
read the terms and conditions of this Agreement. This Agreement is a legal contract between you (the end user) and
BOOMERANG, governing your use of the software. If you do not agree with these terms and conditions, please return
the software with all accompanying packaging materials to the vendor from who you purchased it for refund or credit.
Return policies of vendors may vary; you should check with your vendor as to their return policy on returning unused,
unregistered software. Return of software is subject to restocking charges and terms which will be applied and
deducted from the initial cost paid by the customer returning the software. This agreement shall also be binding on
any subsequent authorized licensee. If you have questions regarding this Agreement, contact BOOMERANG at
617-489-3000.

A. BOOMERANG grants you the right to use one copy of the software on a single-user computer only. Installing
the SOFTWARE on a multi-user computer or network server is a violation of this Agreement.

B. BOOMERANG further grants you the right to make a backup/archival copy of the SOFTWARE as set forth in
the Notification of Copyright.

C. You may not sublicense, rent, or lease the SOFTWARE, but you may permanently transfer your license to use
the SOFTWARE and accompanying materials by delivering to another party the original media (that is, the CD-
ROM), and original user documentation materials comprising the SOFTWARE package. The new recipient of
the SOFTWARE and accompanying materials accepts this Agreement and is licensed under the terms of this
Agreement upon initially using the SOFTWARE.

LIMITED WARRANTY / LIMITATION OF REMEDIES

BOOMERANG warrants the original media (that is, the CD-ROM) on which the SOFTWARE is recorded to be free
from defects in workmanship under normal use for a period of thirty (30) days from the date of your purchase as
evidenced by a copy of the original receipt of payment. BOOMERANG’S entire liability and your exclusive remedy
will be replacement of the media that does not meet BOOMERANG’S limited warranty and is returned to BOOMER-
ANG with a copy of the original receipt of payment. BOOMERANG will have no responsibility to replace media that
has been damaged by accident, abuse, or misapplication.

Under no circumstances including negligence, shall BOOMERANG be liable for any incidental, special, or conse-
quential damages that result from use or inability to use the SOFTWARE or related user documentation, including all
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user documentation delivered in digital format, even if BOOMERANG or any BOOMERANG authorized representa-
tives have been advised of the possibility of such damages, or that result from mistakes, omissions, interruptions,
deletion of files, errors, defects, or delays in operation or any failure of performance whether or not caused by events
beyond BOOMERANG’S reasonable control, including, but not limited to, acts of God, computer failure, theft,
destruction, or unauthorized use of BOOMERANG program or services provided by BOOMERANG in connection
with the publication of the software covered by the License Agreement.

Because any individual software title which (1) creates files combining multimedia functionality with hypertext
markup language (HTML) functionality and (2) is designed to create a commercial Web site (“WEB STORE”) to
facilitate electronic commerce over the public Internet is subject to many factors beyond the reasonable control of
BOOMERANG, including but limited to the known incompatibilities among widely-distributed programs for viewing
HTML files over the public Internet and private Internet Protocol (IP) networks, improper, insufficient, obsolete, or
inoperable hardware or software configurations on remote PCs accessing the public Internet or private IP networks,
unforeseen congestion on the public Internet or private IP networks, failure of public telecommunication transmission
providers, failure of unknown third parties to deliver access to the public Internet or the legal or illegal use of public
and private communication systems by unknown third parties, you are advised to verify all work created with this
SOFTWARE.

You are further advised to verify all confirmed or unconfirmed attempted transactions from any fully identified or
partially identified end user (“CUSTOMER”) accessing the WEB STORE and strongly encouraged to make backup
copies of all files, reports, email or any other administrative information generated as a result of work created with this
program or attempts to access Web sites generated through the use of this program.

BOOMERANG is in no way liable for the failure of any single electronic commerce transaction or any series of
transaction authorization failures experienced by one or more end-user merchants using this SOFTWARE program to
sell any product or service over any public or private communication system or by an end-user attempting to access
any file or Web site through any public or private communication system to purchase any product or service created
by any licensed or unlicensed user of this program.

Boomerang Software, Inc. cannot assume any responsibility or liability for any indirect, special, incidental, economic,
cover or consequential damages arising out of the use of or inability to use WebShop 2000 or any component of the
documentation included with the program, including any and all documentation delivered in digital format. In no case
shall Boomerang Software be liable for any amount exceeding the purchase amount paid by a licensed user for the
software.

The information contained in the WebShop 2000 documentation is subject to change.  Except as specifically provided,
Boomerang Software makes no warranty or representation, promise or guarantee, either express or implied, statutory
or otherwise, with respect to this software or user documentation, including their quality, performance, merchantabil-
ity, or fitness for a particular purpose. No Boomerang Software dealer, agent distributor, or reseller is authorized to
make revisions to this warranty.

Revisions to any component of the program or user documentation included with WebShop 2000 may occur as
deemed necessary by Boomerang Software, Inc.  The information herein is believed to be, and is presented to be,
accurate in all respects.  However, Some states do not allow the exclusion or limitation of implied warranties or
limitation of liability for incidental or consequential damages, so the above limitation or exclusion may not apply to
you.

• MS DOS, Windows, NT, Internet Explorer, Active Server Pages and True Type are trademarks of Microsoft
Corporation.

• IBM is a trademark of International Business Machines Corporation.

• Navigator is a trademark of Netscape Communications.

• PhotoSuite is a trademark of MGI Software.

All other product names or trademarks identified in the user documentation accompanying this SOFTWARE are
trademarks or registered trademarks of their respective companies. They are used in this book in an editorial fashion
only. No such use, or the use of any trade name, is intended to convey endorsement or other affiliation with Boomer-
ang Software products.
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Upload Procedures

The following sections explain how AOL users can upload their Web page files to AOL.
• Section I .  For the America Online (AOL) user who wishes to FTP (File Transfer Protocol)

files to AOL using AOL’s “Built-In” FTP program
• Section II .  For the America Online (AOL) user who wishes to upload files to a non-AOL

server without using AOL’s “Built-In” FTP program

Both of these require that you know the URL domain (or subdomain) for your Web site, user ID
and password.  The procedure introduced in Section II uses the WebShop FTP program in-
cluded with the Upload Site operation.  When possible, it is recommended that the Upload
operation be used to upload your files.

Section I.  For the America Online (AOL) user who wishes to FTP (File Transfer
Protocol) files to AOL using AOL’s “Built-In” FTP program

This section applies to the America Online (AOL) user who wishes to FTP (File Transfer
Protocol) files to AOL using AOL’s “Built-In” FTP program.

 Note:  If you are NOT an AOL customer, this section does not pertain to you.  Please refer
to the next section if you need help in uploading and downloading Web site files.

To upload your files using AOL’s “built-in” FTP program

Before you begin

1. Save your Web site project file.
2. Write down your file names and their location (usually a folder on your hard disk).

Note:  This tutorial uploads files to the Boomerang Software Web site on AOL.  The following
values are used: URL location:  members.aol.com/boomsoft; File Names:  index.htm, and
pict0000.gif.

To upload files to the “members.aol.com” subdomain
1. Log onto AOL as you normally would.
2. Select Go To from the AOL menu bar.
3. Click Keyword and type “FTP” in the “Enter word(s)” area.
4. Click Go.  The FTP - File Transfer Protocol window appears.

Note:  There is a list box in the middle with two link icons on either side.
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5. Click Go To FTP.  The “Anonymous FTP” window appears.

Note:  A scrollable list box in the middle shows “Favorite Sites.” Two link buttons appear in
the lower window area: Connect and Other Site.

For AOL users who are uploading files to a Web-server OTHER than an AOL, jump to the
procedure “To upload to “www.webhorizon.com/giftshop” subdomain (on a non-AOL Web-
server)”

6. Scroll through the list box until you see members.aol.com.
7. Click this once and click Connect.  You are connected to “members.aol.com”

Note:  The current status appears in the window title bar.  It reads: “members.aol.com/<your
screen name>.”  This indicates that you are in your own personal FTP area.  Seven com-
mand buttons appear on the bottom.  In the middle, a list box shows the folders and files
currently available on the remote Web-server.  This is the FTP control console.

8. Click Upload to begin an upload session.  The window members.aol.com appears.

Note:  There is an input box titled, Remote Filename, and two buttons: Continue and Cancel.

9. Type index.htm for Remote Filename and click Continue.  The Upload File box appears.

Note:  There are two options: Send and Select File.  These are joined by an empty input line
titled, File

10. Click Select File.  The Attach File window appears.
11. Scroll through the folder tree and locate the Web project folder boom.htm.
12. Double-click the folder.  The folder contains the files: index and pict0000.
13. Double-click Index.  The Upload File box reappears.

Note:  The File input line displays the pathname in gray text.

14. Click Send.  The file is uploaded.  The members.aol.com window reappears.

Note:  The Filename input line displays “index.htm” and the file “index.htm” appears in the
control console list box.

15. Clear index.htm and type pict0000.gif (in the next filename for uploading) and click
Continue.  The Upload File box appears.

16. Repeat Steps 10–14 (one file at a time) until all of the files are uploaded.

Note:  The uploaded files appear in the control console list box.

To upload files to “ www.webhorizon.com/giftshop” subdomain (on a non-AOL
Web-server)
1. Click Other Site.  The Other Site window appears.

Note:  There is an input line titled “Site Address” and a Connect button in the lower portion
of this window.  There is also a check box labeled “Ask for login name and Password.”

2. Type the FTP server address.  This is the target Web-server.

For example:  “ftp.webhorizon.com” would upload to www.webhorizon.com/giftshop.
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3. Place a check mark next to “Ask for login name and Password” and click Connect.  The
Remote Sign On window appears.

Note:  The title bar for this screen is labeled “Anonymous FTP.”

4. Type your login name in the first box followed by your password in the second box.
5. Click Continue.

If your login name and password are accepted, the FTP control window appears with a listing of
any files on the remote server.  The title bar identifies the Web site subdomain.

Section II.  For the America Online (AOL) user who wishes to upload files to a
non-AOL server without using AOL’s “Built-In” FTP program

This section applies to AOL users who are in the following groups:
• AOL is your only connection to the Internet.
• You want to publish your Web site to a server that does not reside on the AOL network.

You need the Windows 95 version of AOL 3.0 software to take advantage of this publishing
method.

To publish your Web site to an non-AOL Web-server

Before you begin

••••• Save your Web site project file.  You do not need to write down your file names or their
location.

To upload your Project file to a Non-AOL Web-server
1. Log onto AOL as you normally would.  The Welcome screen appears.
2. Minimize the AOL window.

Note:  When done, you will come back to AOL to view your Web site.

3. Open Internet Design Shop and open the Web project you wish to upload.
4. Select Site > Upload  Site.  The Upload Web Site dialog box appears.
5. Fill in the four input lines as follows:

••••• FTP Server Name or Address:  Type the FTP server address for the server you have
selected as your Web-host provider.

••••• User Login:  Type your login name given to you by your Web-host provider.

••••• Password:  Type your password.  To save the password, check the Remember Pass-
word check box.

••••• Upload Path:  Type the upload path given to you by your Web-host provider.
6. Click Upload.  The Web site publishing operation uploads all your files to the target Web-

server.

Note:  You can follow the progress of your upload on screen.

7. When done, exit WebShop and maximize the AOL Welcome screen.  Navigate to Internet
Explore and type your Web site URL.  You Web site should appear.
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